Apparently, Apple is now blocking jailbroken/unlocked phones from being restored-1015

Discussion in 'Jailbreaks and iOS Hacks' started by lPHONE, Feb 11, 2011.

  1. lPHONE macrumors 6502a


    Nov 17, 2009
    I've been doing some research on error 1015- and I have concluded that Apple is trying to brick our phones. Sure, the Apple docs say 1015 is an error you get when trying to downgrade firmware, but I'm finding another story...

    Apparently, a lot of people with jailbroken phones have been getting error 1015 from iTunes when they try to do a clean install of IOS from DFU or Recovery Mode... I new it would only be a matter of time until Apple started hacking the hackers.

    And now it's happening to me.
  2. chr macrumors regular

    Feb 11, 2011
    Cool conspiracy theory, dude, but you're just being ignorant.

    It's an error generated when you've edited your hosts file--if you didn't edit it, then it's because you've used TinyUmbrella to preserve your shsh and it edited it.

    You can use TinyUmbrella to kick the phone out of recovery or manually edit your hosts file and remove (or comment out) the line pointing to
  3. Kadin macrumors 6502a


    Jun 16, 2009
    If you're getting the 1015 error from an attempt at a fresh install/restore then you've got a software/baseband mismatch issue going on. For example if your baseband right now is 6.15.00 and try to do a simple restore, it's gonna get stuck in recovery mode with that error. This is nothing new.
  4. lPHONE, Feb 11, 2011
    Last edited: Feb 11, 2011

    lPHONE thread starter macrumors 6502a


    Nov 17, 2009

    thanks... i guess.
  5. dukebound85 macrumors P6


    Jul 17, 2005
    5045 feet above sea level
    quite the leap you made op when you encounter difficulty and instantly think apple is out to get ya lol
  6. lPHONE thread starter macrumors 6502a


    Nov 17, 2009
    that's just me being ignorant. :D
    Is there a solution?
  7. lPHONE thread starter macrumors 6502a


    Nov 17, 2009
  8. zenio macrumors 6502

    Feb 2, 2011
    Your approach is very revealing of who you are...

    Take a look in the mirror
  9. Kayan macrumors 6502

    Jul 7, 2010
    The mirror points in your direction too:)
  10. starsmiiles macrumors newbie

    Feb 10, 2011
    I just recently had this problem, only my error was 1013. If you remove all the lines containing "" in your host file, it should work fine.
  11. Kadin macrumors 6502a


    Jun 16, 2009
    Well typically you have to update the software with a custom .ipsw which doesn't update the baseband. One can be created via Pwnage Tool or found online...
  12. Crystal-RX macrumors 68030


    Dec 22, 2008
    Seattle, WA USA
    Use Tiny Umbrella to kick it out of recovery mode and your phone will be updated with the firmware you install.
  13. chr macrumors regular

    Feb 11, 2011
    Did you read my post? I explained the solution.
  14. Synergie macrumors 6502a

    Jan 15, 2011
    Halifax, Canada
    Yup I had a similar error when I upgraded to 4.2.1 from 4.1 JB with Limera1n. Except that I got 1013 Unknown Error. It only took me about 15 mins of research to find out about the checkbox in Tiny Umbrella in the advanced tab that allowed the hosts file to point to cydia. Unchecking that and reloading iTunes solved it.

    Think about it... if Apple bricked phones that people paid for, that would be illegal I think! Apple does not own the device once you buy it! They may try to stop exploits because of security risks, but in reality I don't think they want to stop jailbreaking completely... because they'd lose a TON of customers (myself included) who feel that the iphone in it's native state is a piece of useless iCrap that needs to be jailbroken just to make it do things that other smartphones do by default!! If jailbreaking were ever completely stopped for good, I'd be gone... probably to Android at this point in time.
  15. murdercitydevil macrumors 68000


    Feb 23, 2010
    They don't own the device but they own the software and no software = no device. Still, Apple isn't hacking anyone.
  16. Aatos.1 macrumors 6502

    Dec 31, 2010

    One can always outsmart Apple if you are a good hacker.

    The fanboys can live in denial that Apple is sinister...ha..ha...ha...
  17. nebo1ss macrumors 68030

    Jun 2, 2010
    As somone else already correctly pointed out this is caused by your host file being edited by Tiny Umbella.

    There are more and more threads on this topic every day and personally I think Notcom made a bad decision to edit the host file on exit from Tiny umbrella.

    No matter how many times you put your host file back to normal Tiny umbrella will edit it again the next time you run it.

    The only permanent fix to this is to go into tiny umbrella and select advance mode and uncheck the box that says change host file to cydia on exit, when you close TU it
    will normalise your host file.

    It might help a few from accidentally updating their baseband on ip4 but it is preventing those that want to do a standard restore from apple.

    I found that even after making this change and unchecking the box if you leave TU open your host file is modified until you close it again.
  18. imac9556 macrumors 6502a

    Jul 12, 2004
    +1 +1 +1 +1
    You are absolutely right... I had to send back my iPhone 4 to Apple and completely clear out/restore my phone. I kept on getting error 1013's or whatever after the restore was complete.
    That was until I remembered to UNcheck the box about change the host file under TinyUmbrella's advanced settings. It even says UNcheck if you want a "clean restore"
    After I did that, I clicked restore again and everything went through smoothly
  19. starsmiiles macrumors newbie

    Feb 10, 2011
    I wish I would have known this! I didn't realize TU altered the host file and routed it to Cydia. Thanks for point it out! :)
  20. Mystikal macrumors 68020


    Oct 4, 2007
    Irvine, CA
    Also, DFU mode can be your friend.
  21. kre62 macrumors 68020

    Jul 12, 2010
    In case anyone wants to actually know why this is happening, it's because iTunes tries to sign your baseband at the end of the install. Cydia can't save baseband signatures, so if it tries to go out and get the sig, and you have it redirected to Cydia through your hosts file, it cant get the sig and fails. Nothing to do with jailbreaking.
  22. upaymeifixit macrumors 6502a


    Feb 13, 2009
  23. lPHONE thread starter macrumors 6502a


    Nov 17, 2009
    OK, I just tried to restore & update on a brand new pc with a fresh copy of iTunes and STILL get 1015. If Apple is not blocking the restore, then what?
  24. kmpoboy2 macrumors 6502


    Jul 10, 2010
    What phone are you triying to restore? Model?, iOS?, Baseband?

Share This Page