Apple IIe issues

Discussion in 'Apple Collectors' started by Startax, Nov 8, 2016.

  1. Startax macrumors newbie

    Startax

    Joined:
    Nov 8, 2016
    Location:
    Italy
    #1
    Hello Everybody,
    writing from Italy, so sorry for my typo's...
    I own a working II Europlus (the EUR version of the +) and a IIe which I'd like to restore.
    By switching it on, the IIe beeped and I got a strange "Apple §°" something message with nothing else (attached the pic).
    Then, I went to another room looking for a floppy to insert into the drive (i had one connected) but when I came back after 3 mins I felt a 'burning smell' coming out from the IIe, which switched off.
    I waited 15 mins then I tried to switch it on again but no any beeps and the only message "IOU FLAG E5:6 7 9 0". Then I told myself that it blew up...
    I waited another 30 mins, removed the plug, opened the upper chassis and removed all the expansion cards (there was a "Z80" card (for CP/M I assume), a "Le Chat Mauve" (think graphic card) and a "Super Serial" card) and tried to switch it on again. I got the beep back, the 'uaual' "Apple §°" message and to avoid other burning smells I switched it off.
    Finally, I put all the cards back in their places and I tried the last power on, and I got the beep again.
    Considering that I'm not a 'Oscilloscope' guy and I'm not able to make so many 'professional' tests... do you know which could be the issue(s) and what kind of simple tests I can do to give you some additional information?
    Being in Italy the IIe's and II+'s aren't so common so I can't easily find somebody to repair my puppy. Moreover, if i should buy some replacement parts I would like to order with some 'confidence' without throwing away too much money... I'm able to replace a chip, but I'm not a professional.
    Attaching some pics for reference. Ask for any additional photos you may need to understand better the issue.
    Thanks for any help.
     

    Attached Files:

  2. MacTech68 macrumors 68000

    MacTech68

    Joined:
    Mar 16, 2008
    Location:
    Australia, Perth
    #2
    The socketed ICs on the motherboard possibly need re-seating. You might try simply pressing down on them. You may hear a little creaking and clicking as they re-seat into the sockets.

    The snell may be a failed Class X or Class Y capacitor in the power supply. If you can open it up and take some pictures, we might be able to pin-point the offending capacitor(s).
     

Share This Page