Resolved Apple Java 6 for 10.11

Discussion in 'OS X El Capitan (10.11)' started by TheralSadurns, Jun 8, 2015.

  1. scarecrowmac macrumors member

    scarecrowmac

    Joined:
    Jun 12, 2011
    Location:
    South Coast of NSW, Australia
    #26
  2. Neibesh, Jun 15, 2015
    Last edited: Jun 17, 2015

    Neibesh macrumors newbie

    Neibesh

    Joined:
    Jun 15, 2015
    #27
    I was able to get it working with the same fix I did with Yosemite, however I had to take rootless off.

    Pretty much just have to use these two commands in terminal:
    sudo nvram boot-args="rootless=0";osascript -e 'tell app "loginwindow" to «event aevtrrst»'
    *Restart*
    sudo mkdir -p #Target Disk Volume #/System/Library/Java/JavaVirtualMachines/1.6.0.jdk
    sudo mkdir -p #Target Disk Volume Goes Here#/System/Library/Java/Support/Deploy.bundle
    Done :)


    I didn't seem to find any issues after that while running on the first release of 10.11 with Adobe CS6.
     
  3. tsanchai macrumors newbie

    tsanchai

    Joined:
    Jun 10, 2015
    #28
    I have Pacifist on my system. Can you advise step by step method to install Java SE6? I try to run brew cask install java6 command in Terminal but the command not found come out. Can you please please instruct me how to install java6 on El Capian. It really a show stopper since IBM SPSS won't run without it
     
  4. splitfirz macrumors newbie

    Joined:
    Jul 25, 2013
    #29
    tried following the steps from the blog link. doesnt seem to help with opening arduino. the java legacy error is gone but the app doesnt launch.
     
  5. tsanchai macrumors newbie

    tsanchai

    Joined:
    Jun 10, 2015
    #30
    Can any expert here outline steps to get Java 6 work on El Capitan? I tried many options but not seems to work. IBM Statistics and Lightroom stop working and this is a real deal breaker from El Capitan. Seems that Apple does not care about backward compatibility anymore.

    Help please. I am now all in with El Capitan
     
  6. ssn637 macrumors 6502

    Joined:
    Feb 12, 2009
    Location:
    Switzerland
    #31
    I had a similar issue where Britannica's Ultimate Reference Suite refused to start without the JRE 1.6 legacy Java plug-ins, so I did the following:

    - Download the legacy Java version 2014-001 from the Apple Support site
    https://support.apple.com/kb/DL1572?locale=en_US

    - Ensure System Integrity Protection has been disabled from the Recovery partition and reboot

    - Open the Java JDK 1.6 installer package using Pacifist and extract its contents to a local folder

    - Manually copy all the contents of the extracted files to their target locations. Keep any files that would otherwise be overwritten

    Ultimate Reference Suite then launched without a hitch! It seems for some programs that simply creating empty an empty 1.6.0.jdk folder isn't enough.
     
  7. TheralSadurns thread starter macrumors 6502a

    Joined:
    Jul 8, 2010
    #32
    If you follow the steps I linked to in the OP... everything should work just fine!
    I have ONLY Java 8 installed... and both Lightroom as well as SPSS launch and work just fine!
    They do NOT need Java 6 to work! (See also the screenshot I added.)

    Screen Shot 2015-06-16 at 06.53.48.png
     
  8. tsanchai macrumors newbie

    tsanchai

    Joined:
    Jun 10, 2015
    #33
    Pressing command-R and reboot, I cannot see any recovery partition. Where can I disable Sytem integrity Protection?
     
  9. tsanchai macrumors newbie

    tsanchai

    Joined:
    Jun 10, 2015
    #34
    I have done the edit of info.plist file reboot but it do not work. help please
    P
     
  10. tsanchai macrumors newbie

    tsanchai

    Joined:
    Jun 10, 2015
    #35
    I have tested my java version and in terminal, it show version 1.8_31 but in Java Console, it show version 8 update 45 (picture attached)

    When I try to reinstall Java 8 update 45 idk, I encountered an error and cannot reinstall (picture attached)

    Then I install using Pacifict, seems going fine, but again Terminal show version 1.8_31. How can I fix and get update 45 to be the active version?
     
  11. tsanchai macrumors newbie

    tsanchai

    Joined:
    Jun 10, 2015
    #36
    When I try to upload pictures, I go plug in error
     
  12. p0wer0n macrumors newbie

    Joined:
    Jun 16, 2015
    #37
    I finally found a method to install Java SE 6 on El Capitan. I found this even before reading dotNes's method. My method is similar in the fact that it uses Pacifist to install the package.

    1. Download Apple's official Java Package from https://support.apple.com/kb/DL1572?locale=en_US
    2. Download Pacifist
    3. Download UninstallPKG
    4. Use UninstallPKG to uninstall any version of JDK on your Mac
    5. Drag JavaForOSX.pkg from JavaForOSX2014-001.dmg to a desired folder
    6. Run this command in Terminal.app (Credit goes to w0lf)
    Code:
    sudo nvram boot-args="rootless=0";osascript -e 'tell app "loginwindow" to «event aevtrrst»'
    7. After your computer restarts, right click on JavaForOSX.pkg and open it with Pacifist
    8. Select "Contents of JavaForOSX.pkg" and install it with administrator privileges.
    9. Java still won't work when you run it in Terminal for some reason, so you are going to have to install JavaForOSX.pkg using the stock installer. This time, however, the installer will install without issue. Double click JavaForOSX.pkg and install it to your HDD.

    I've gotten Minecraft to run perfectly this way, and Terminal does not return any errors when I run java.

    This is my first MacRumors post (and forum post) ever, so if I did anything wrong, tell me!
     
  13. BillyBobBongo macrumors 68020

    BillyBobBongo

    Joined:
    Jun 21, 2007
    Location:
    On The Interweb Thingy!
    #38
    Turn off the Flash-based uploader in your preferences
     

    Attached Files:

  14. DFZD macrumors 6502

    Joined:
    Apr 6, 2012
    #39
    Thanks a lot. This worked really well for me.
     
  15. manicennui macrumors newbie

    Joined:
    Jun 24, 2015
    #40
    On a clean 10.11 El Cap install I was also able to install JDK 1.6 using the method described in this thread:
    1. disable rootless security and reboot
    2. download Pacifist and the JDK 1.6 installer and install JDK 1.6 using Pacifist (this does not seem to install the JDK cleanly; I opted to replace everything)
    3. it sounds like either using homebrew/cask/tap to then install the JDK -OR- simply running the installer in the pkg at this point will install the JDK cleanly (I used homebrew/cask/tap, as these are good things to have anyway)
    4. and final re-enable rootless security and reboot

    java -version reports the 1.6.0_65 jdk.

    As a side note, there seem to be two distinct types of users in this thread, those that need JDK 1.6 for some legacy purpose (such as myself) and those that do not. This latter group can just use the JDK/JRE 1.7 or 1.8 at java.oracle.com to install Java. If you don't KNOW you need JDK 1.6, I would just use the 1.7/1.8 installers depending on your need.

    Thanks everyone.
     
  16. zaneliu macrumors 6502

    zaneliu

    Joined:
    Jan 27, 2013
    Location:
    Berkeley
  17. robert.j.wacker macrumors newbie

    robert.j.wacker

    Joined:
    Jun 12, 2015
    #42
    @tsanchai
    This is what I did and worked after much reading on forums. I had a clean install for this. I download the legacy Java from Apple's website: https://support.apple.com/kb/DL1572?locale=en_US
    Then I downloaded Pacifist:https://www.charlessoft.com
    I then installed Pacifist and restarted.
    This is the tricky part: As the computer restarts (goes from black to grey-ish, but before the apple logo appears) click together and hold the keys command and the letter r. This should bring up the recovery partition. You will see the apple logo appear and the bar load, and sometimes the bar will load twice.
    Once in recovery go to the utilities tab in the file bar and click security. Here you find a toggle that is on, it does not call it rootless here, but it is what needs to be turned off. I have had mixed results using the rootless sudo command, and have had better results turning it off in recovery (this is best anyway as this is most likely where we will have to after final public release).
    After the toggle is off, restart your system, this can be done by clicking the apple logo and clicking restart. Let it boot normally into your user account with admin privileges.
    Once computer is restarted open pacifist. Mount the Legacy Java DMG.
    Pacifist is shareware and has a 30-day trial. It will work just as it would if you pay for it (though after this I think its worth paying for). So click to use with trial, you may decide later to purchase. You do this by clicking Not Yet after the count down time gets to zero.
    Click ok on the "welcome to pacifist" window after you give the text a once over.
    Next click open package.
    In the window that pops up select the Java package. Click Open.
    Another window will pop up that shows the contents of the Java package. Single Click "Contents of JavaForOSX.pkg" so that it is highlighted blue. Click install at top follow prompt. There will be a a point where it asks if you want to replace existing files, click check box to remember for this install and click replace. You may go and individually choose the files to replace but this would take an hour or more. Once you tell it to replace files it zips along and will complete. Once it is done you do not have to restart and should be able to open apps requiring legacy Java.
    If you would like to re-enable rootless go back into the recovery portion and toggle the item back on. You may leave it off but it does leave vulnerabilities.
    Most people in this forum appear to turn rootless back on after they get Java installed. Rootless will need to be disabled for any tool that edits system files such as MCE's DVD utility so that they are able to edit the need system file. Then you may re-enable it. @zaneliu Hope this last paragraph answers your question as well.

    Hope this helps. :)
     
  18. Rique macrumors regular

    Joined:
    Mar 31, 2011
    Location:
    Northern Virginia
    #43
    Thanks for the help! This worked perfectly.
     
  19. mag01 macrumors regular

    Joined:
    Apr 10, 2011
    #44
  20. dyn macrumors 68030

    Joined:
    Aug 8, 2009
    Location:
    .nl
    #45
    That's because a lot of the apps are still build for Java 6 and/or looking for the location of Java 6. As of Java 7 Oracle has taken over the builds and these are installed in a different location. The Unifi controller software has the same issue, it doesn't detect the Java version correctly. Freemind and Freeplane have been build on Java 6 and didn't work in the beginning. They've resolved this by delivering a built-in Java 6 version. Many other apps like Xmind do the same thing so you don't run into issues with those.

    The Java support from apps that use it is really really bad. They still want Java 6 which has been EoL'ed about 2 (!) years ago! These apps are a major security risk and shouldn't be used at all.
     
  21. Shawzborne macrumors 6502a

    Shawzborne

    Joined:
    Jun 12, 2013
    #46
  22. fisherking macrumors 604

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #47
  23. krikaoli macrumors newbie

    krikaoli

    Joined:
    Aug 29, 2013
    Location:
    Brazil
    #48
    Thank you very much!

    I was having a problem, the site in Portuguese was showing the older version (2014), than I figured out to change the language to english and it showed the 2015 java version!
     
  24. HenryAZ macrumors 6502a

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #50

Share This Page