Resolved Apple Java 6 for 10.11

Discussion in 'OS X El Capitan (10.11)' started by TheralSadurns, Jun 8, 2015.

  1. ArmchairDeity macrumors newbie

    Joined:
    Oct 19, 2007
  2. johnbarrett macrumors newbie

    johnbarrett

    Joined:
    Oct 6, 2015
    Location:
    Hawaii
    #53
    Aloha,
    I am lost with java on El Captain! I have installed "jdk-8u60-macosx-x64.dmg" but I still get this dialog. This is the first time that I have had a issue with java on the mac OS X platform.

    Did you find a solution to your issue? Do you have any advice for me?

    Thanks!
    Johnny
     

    Attached Files:

  3. dsemf macrumors 6502

    Joined:
    Jul 26, 2014
    #54
    It is most likely software that requires Java 6. Try the link shown in post #51.

    DS
     
  4. oliverdowling macrumors newbie

    oliverdowling

    Joined:
    Jun 10, 2015
    Location:
    Australia
    #55
    I have a blog post linked earlier in this thread that got a lot of traffic at both the beta and official release of El Capitan.

    Installing Apple's legacy Java 6 is the simplest solution, but if you instead want to install Oracle's Java 8, the old post of mine has all the information you would need. However, with all the updates to my blog post over time, it has become a bit hard to get simple instructions from, so I've created two new posts on my blog.

    If you want to install Oracle's JRE 8, I made a post with instructions on my blog here: https://oliverdowling.com.au/2015/10/09/oracles-jre-8-on-mac-os-x-el-capitan/

    Oracle's JDK 8 is a little easier to install, because it actually comes with an installer, rather than just being a zip file. For most users, however, it is "the JRE but with more things that I'll never use". You can find the post with instructions for the JDK here: https://oliverdowling.com.au/2015/10/09/oracles-jdk-8-on-mac-os-x-el-capitan/
     
  5. hintofsilence macrumors newbie

    hintofsilence

    Joined:
    Sep 18, 2009
    Location:
    Salt Lake City, UT
    #56
    So I followed the instructions in reply #5, but it wouldn't let me perform the first of the two commands, since this is not a virtual machine. However, I ran the second of the two, turned the rootless back on, rebooted, and then it allowed the install to go forward. I'm waiting for it to finish, so not sure how well CS5 will perform once install is complete, but I am optimistic. I'll post the results here after I test it.

    Update: Illustrator seems to work, except that I am having the same issue with the whole thing crashing when trying to use the eyedropper tool, as mentioned in another comment. Rather annoying, but I can probably work around it if I have to. Anyone else found a fix for that?
     
  6. monti macrumors newbie

    Joined:
    Jul 25, 2009
    #57
  7. oliverdowling macrumors newbie

    oliverdowling

    Joined:
    Jun 10, 2015
    Location:
    Australia
    #58
    1. Disabling "rootless" (it was rebranded as System Integrity Protection, SIP) this way no longer works on El Capitan, it was only possible to do it this way during the beta, and had some obvious flaws.
    2. The Java in the link you supplied only installs Java 6, not Java 7 and 8.
    3. The installer from Apple does not require SIP being disabled.
     
  8. Elessa macrumors newbie

    Elessa

    Joined:
    Nov 11, 2015
    #59
    This worked for me. I am using Dreamweaver CS6 with El Captain. Thank you for the tip
     
  9. nfonrose macrumors newbie

    nfonrose

    Joined:
    Sep 16, 2017
    Location:
    France
    #60
    For some reason, the "Download" button has now disappeared from the apple support page, making it impossible to download the DMG file. But the file itself is still on Apple servers and I managed to find its URL thanks to the Internet Archive.

    Here is the link to the javaforosx.dmg file: http://supportdownload.apple.com/download.info.apple.com/Apple_Support_Area/Apple_Software_Updates/Mac_OS_X/downloads/031-29055.20150831-0f779fb2-4bf4-11e5-a8d8-/javaforosx.dmg
     
  10. Sko, Sep 16, 2017
    Last edited: Sep 22, 2017

    Sko macrumors 6502

    Sko

    Joined:
    Oct 17, 2009
    Location:
    Germany
    #61
    I provided an easy double click solution to use latest Java instead of old Java 6 based on Oliver's instructions here.

    Edit: updated version for Java 9
     
  11. KeithC macrumors newbie

    Joined:
    May 12, 2013
    #62
    I am using High Sierra public beta. After installing the latest public beta update of this week, 10.13.1 Beta (17B42a), Java for OS X 2015-001 no longer installs. At the Select a Destination point during the installation, it says that "Java for OS X 2015-001 can't be installed on this disk. A newer version of this package is already installed." And there are no eligible hard disks for installation. This worked fine under the previous High Sierra public beta. I have informed Apple (for whatever this is worth).
    Has anyone experienced this AND found a solution??? Thx
     
  12. Mike Boreham macrumors 68000

    Joined:
    Aug 10, 2006
    Location:
    UK
    #63
    Apple have just released :

    https://support.apple.com/kb/DL1572?locale=en_GB

    "Java for macOS 2017-001 installs the legacy Java 6 runtime for macOS 10.13 High Sierra, macOS 10.12 Sierra, macOS 10.11 El Capitan, macOS 10.10 Yosemite, macOS 10.9 Mavericks, macOS 10.8 Mountain Lion, and macOS 10.7 Lion.

    This package is exclusively intended for support of legacy software and installs the same deprecated version of Java 6 included in the 2015-001, 2014-001, and 2013-005 releases".

    I think this will solve your problem.
     
  13. camelia macrumors 6502

    camelia

    Joined:
    Apr 3, 2015
    Location:
    Mexico City
    #64
    Thank you!! :):):):)
     

Share This Page