Apple Releases Battery Fix SMC Firmware Update for MacBook Air

Discussion in 'Mac Blog Discussion' started by MacRumors, Jun 9, 2014.

  1. MacRumors macrumors bot


    Apr 12, 2001

    Apple today released MacBook Air SMC update 2.0 for mid-2013 MacBook Air models, addressing an issue that could cause excessive battery drain when the computer's lid is closed.
    This is the second battery fix released for the 2013 MacBook Airs, with update 1.9 fixing a battery issue that could cause the battery to unexpectedly cease functioning.

    The update can be downloaded from Apple's support site or via the Software Update tool in the Mac App Store.

    Article Link: Apple Releases Battery Fix SMC Firmware Update for MacBook Air
  2. sp3k0psv3t macrumors regular


    Jun 3, 2013
    Miami, FL
    Didn't know I had a battery problem lol.

    Thanks Apple
  3. Zxxv macrumors 68030

    Nov 13, 2011
  4. Alphabetize macrumors 6502


    Oct 6, 2013
    "This update is already installed on your computer"? Did this download via PowerNap? It say's it's already installed.
  5. WillFisher macrumors 6502


    Feb 19, 2011
    If I had a battery problem with my 12+ hours already achieved, well then I cannot complain about that "problem"

    Muchos gracias Apple.
  6. iolinux333 macrumors 68000

    Feb 9, 2014
    I wish they'd release the fix for my mid 2011 MBA fan, which I'd heard maybe three times total until I installed Mavericks, to stop screaming like a jet engine should I so much as breathe on it.
  7. coolfactor macrumors 68040

    Jul 29, 2002
    Vancouver, BC CANADA
    I had to install it twice. First time it rebooted, it never installed, even though the App Store says it was installed after that. Then it showed as needing to be installed again, and it worked that second time. Strange.
  8. Corrald macrumors newbie

    Jun 7, 2010
  9. vladobizik macrumors 6502

    Aug 21, 2012
    I downloaded the update, the computer restarted (for about two seconds, the fan came on at full speed and then equally abruptly stopped, frighteningly cool!), and while booting, some sort of command line gibberish appeared on he left side of the screen. Before I could make out anything, a kernel panic occcured, then another restart, after which the system finally booted normally.
    Everything is perfect now, but this was a very strange and probably unintended setup experience.
  10. JoEw macrumors 65816


    Nov 29, 2009
    12+ hours, I didn't realize it could get better! :cool:
  11. orbital~debris macrumors 6502a


    Mar 3, 2004
    England, UK, Europe
    I had this problem!

    I just reinstalled Mavericks last week… which seems to have fixed the issue. But i'll take this too, if it's going to prevent the issue from reoccurring! :):D
  12. PeckhamBog macrumors 6502


    Nov 28, 2007
    13" Only?

    My 13" updated fine, but the 11" doesn't show any update available.

    Has anyone with the smaller model seen the update?
  13. leventozler macrumors 6502

    Feb 18, 2009
    Check your SMC version, the newest is 2.12f137.
  14. newdeal macrumors 68020

    Oct 21, 2009
    I felt like my battery was draining to fast with the lid closed. It was supposed to last like 30 days but later more like 5
  15. glindon macrumors regular


    Jun 9, 2014
    Strange mine says 2.12f140. I installed Yosemite on an external drive though.
  16. Mlrollin91 macrumors G4


    Nov 20, 2008
    Ventura County
    I have this issue with my 2012 11" MBA. Close the lid with zero programs opened and the battery drops like crazy. Hopefully something similar will come out for my model.
  17. Weaselboy, Jun 9, 2014
    Last edited: Jun 9, 2014

    Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    I think Yosemite updated your firmware. I saw a post earlier where someone even found the SMC updates files inside the Yosemite installer.

    This update took my 2013 MBA from 2.13f7 to 2.13f9.

  18. loby, Jun 9, 2014
    Last edited: Jun 9, 2014

    loby macrumors 6502a


    Jul 1, 2010
    I noticed right away an improvement. A few months ago, I discussed issues with Apple support thinking it was a video issue when booting up (black screen flash quickly right before the keyboard backlight turns on and the apple logo appears). I reinstalled from scratch without a time machine backup and it improved some, but still noticed something that did not seem normal on boot up; other than that, the system seemed like it was find with no issues.

    After installing the firmware update today, I noticed that the boot up was smoother like my old mac mini 2009 that has zero issues. I turned on my system and just left it on without doing anything for at least an hour and the battery percentage still says 100%, even as I type this entry for a few minutes.

    "This update took my 2013 MBA from 2.13f7 to 2.13f9" - I am using Mavericks and this is what my SMC version now says too.

    I believe it has fixed something, though I am not sure what.. :)

    Glad it fixed something...
  19. luckydcxx macrumors 65816


    Jun 13, 2013
    i had to install it twice also. i have to say i have not been getting the 10+ hours of battery life that people claim. i get about 6 just browsing the web, to me thats still pretty decent compared to other laptops.
  20. loby macrumors 6502a


    Jul 1, 2010
    When you say, "it did not install the first time..." What happened when you or the system rebooted? Did the system boot up like normal or something else..?
  21. NT1440 macrumors G4


    May 18, 2008
    Hartford, CT
    Have you tried a SMC reset? The SMC is responsible for, amongst other things, fan control.
  22. luckydcxx macrumors 65816


    Jun 13, 2013
    yes it did the entire install and then rebooted. when i logged on it showed that there was an update still available, when i checked it was the same update. i installed it and rebooted and everything was fine then.
  23. bully worm macrumors regular

    Sep 17, 2009
    I can also attest to the "install twice" event. I restarted the first time and upon re-opening the app store, it notified me that I had to install it again. The second go around, it took a slight bit longer to install with the fans going full blast for about 1 second. After boot, it shows that I have no further updates.

    My history even shows two installs:

  24. iolinux333 macrumors 68000

    Feb 9, 2014
    I tried that yesterday, it didn't seem to help. I just tried it again and so far everything seems OK. I'm running Activity Monitor right now to see what's making the CPU heat up. I was suspecting Chrome+Flash yesterday, so I uninstalled Flash but that didn't seem to help much either. God I have hated Flash since it was invented it feels great not to have it.

    Anyway, this still never happened until Mavericks update, and started *immediately* after the update and never got better. I guess my next step is a fresh install of OS X, but I dread that. I dread that a lot.
  25. iolinux333 macrumors 68000

    Feb 9, 2014


    second time resetting seems to have done the trick. THANK YOU SO MUCH!!!


Share This Page