Apple Smart Keyboard Connection Issues

Discussion in 'iPad' started by DJ_NUFC, Dec 25, 2017.

  1. DJ_NUFC macrumors newbie

    Joined:
    Dec 23, 2017
    #1
    Hi Everyone,

    I just began getting used to the ASK with my iPP 12.9, and suddenly it started giving me serious connection issues. As soon as the iPP is idle or sleeps, the ASK disconnects. And sometimes simply disconnecting it from the smart connector and reconnecting fixes the issues (which is in itself annoying), and other times nothing works, including rebooting. And I just end up sitting there hoping it starts working again. And usually after the umpteenth reconnect to the case, it begins working again.

    Anyone had similar issues? I read somewhere that Apple had a free replacement program going on for these things, is that still the case?

    Thanks.
     
  2. batrush macrumors member

    Joined:
    Oct 22, 2017
    #2
    Same issues here. I just returned the keyboard.
     
  3. nospleen macrumors 68020

    nospleen

    Joined:
    Dec 8, 2002
    Location:
    Texas
    #3
    I have this issue and doing an alt tab fixes it. Not sure what the keys say exactly as I don’t have it on me. But the alt tab view that you use to switch through open apps works on my end. (Even when the keyboard isn’t recognized at all)

    After I do that, everything works.
     
  4. DJ_NUFC thread starter macrumors newbie

    Joined:
    Dec 23, 2017
    #4
    Goddamnit! LoL. I really like the keyboard, but don’t know what to do. I’m gonna take it into the store and see what they say anyway. Surprised Apple would design something so dodgy. The 3 small connectors seem way too small and mine seem to be depressed all the way in, which could be the issue. But it’s brand new, lol.
    --- Post Merged, Dec 25, 2017 ---
    Interesting, I’ll try that next time it freezes up.
     
  5. TBFoxRDMS macrumors newbie

    Joined:
    Sep 15, 2007
    #5
    Took mine back for Apple Care replacement. New one is fine so far.
     
  6. DJ_NUFC thread starter macrumors newbie

    Joined:
    Dec 23, 2017
    #6
    Just to let everyone know, this CMD+Tab tip just worked! Not sure if this is how it’s gonna be for this issue going forward, but it actually just worked right now after my keyboard stopped responding again. Someone let Apple know, lol.
     
  7. nospleen macrumors 68020

    nospleen

    Joined:
    Dec 8, 2002
    Location:
    Texas
    #7
    Glad to hear that worked for you. I thought it was weird when I first figured that out, but it's continued to work. Lol
     
  8. roccobladr macrumors 6502

    Joined:
    Jul 25, 2011
    #8
    Same thing happens and the same thing fixes it for me. I use my iPad Pro 10.5 as my main computer so I find myself doing this fix multiple times per day. Really annoying and strange to come from apple.
     
  9. rachelsgoldens macrumors member

    Joined:
    Sep 8, 2016
    #9
    I had this happen to me with my 12.9 2015 edition. I ended up with another iPad and it works fine. It’s a common issue on the Apple Support Page. Lots of people change out the keyboard if it’s under warranty and that works for them.
    I had bought the first iPad on Swappa and the ASK with a Pencil on eBay. It worked for a while then quit. Got a great deal on another iPad with an ASK on Swappa. both keyboards work flawlessly with the 2nd iPad. So I sold the first iPad and kept the 2nd ASK. Wish I had known the Alt Tab, would have saved myself some time and money!
     
  10. Mr. Zarniwoop macrumors demi-god

    Mr. Zarniwoop

    Joined:
    Jun 9, 2005
    #10
    I experienced this issue, and took it to Apple. They said my model of Smart Keyboard was recalled for connection issues, and gave me a new one. It's now flawless as far as I can tell.
     

Share This Page

9 December 25, 2017