Apple TV 3 6.1 Update Buffer Issue

Discussion in 'Apple TV and Home Theater' started by kittonian, Mar 19, 2014.

  1. kittonian macrumors member

    Joined:
    Aug 4, 2008
    #1
    After this update, streaming large movies from my Mac Pro via iTunes as I've always done in the past now (BD/DVD rips) has significant issues. It's almost as if it is dropping frames or somehow the buffering is getting off track. The audio is always fine and the picture "looks" great.

    If I stop the movie and resume, all is well for another 10 minutes or so until it begins to get worse and worse. This is not with just one movie, this is with all the movies that have played without issue time and again in the past. Definitely something up with the update.

    It almost seems as if ATV is no longer releasing the already used portion of the stream and begins to stutter as it nears it's capacity limits because when I resume the stream it often has to begin buffering from that point in the timeline instead of resuming with an already buffered stream.
     
  2. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #2
    I have exactly the same problem. I was about to reluctantly restore the thing, but have you tried that? I might see if it's possible to downgrade the software at all. I'm assuming it's not, since it's a variant of iOS. Still, they may still be signing the prior version!
     
  3. ZeRoLiMiT macrumors 6502a

    ZeRoLiMiT

    Joined:
    Jun 6, 2010
    Location:
    Southern California
    #3
    Current version here and no problem streaming 1080p content
     
  4. kittonian thread starter macrumors member

    Joined:
    Aug 4, 2008
    #4
    I have not tried a full restore and/or downgrade but I assume that as long as there was no irreversible updating done when going to 6.1 it should somehow be possible to roll back.

    I really can't believe more people aren't talking about this issue. It seems that if you are streaming HD files that are under 3GB in size all is well. Once you start streaming 10GB+ that's where the issues begin.

    At this point I am having to stop/resume movies 4-5 times just to get through them. Ridiculous!
     
  5. Equestris macrumors newbie

    Equestris

    Joined:
    Aug 1, 2012
    Location:
    Rasta, Norway.
    #5
    I´m having the same problems and it started after the latest ATV update, frustrating. :(
     
  6. jdag, Mar 23, 2014
    Last edited: Mar 23, 2014

    jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #6
    Wow...thanks for posting. I was actually doing searches relative to file size and bit rate today, thinking it was something with some of my recent encodes. I am hoping someone here has a fix.

    As mentioned above, stopping the movie helps for a brief time. Unplugging helps too. But in both cases only for a short period.

    I have 3 ATVs, all connected via wifi, and have seen this issue on 2 of them. I have not used the 3rd recently.
     
  7. crhendo macrumors member

    Joined:
    Oct 28, 2009
    #7
    ......add me to the list as well. All since the recent upgrade. I have noticed that it mainly happens on my direct attached ATV while my wireless ATV appears to be OK (so far).
     
  8. brian.leveille macrumors newbie

    Joined:
    Mar 17, 2007
    #8
    Same here.

    Very annoying. My symptoms are the same as others have listed. I hope either they put out a patch soon, or someone figures out a workaround.

    -bl
     
  9. J@ffa macrumors 6502a

    J@ffa

    Joined:
    Jul 21, 2002
    Location:
    Behind you!
    #9
    Just for the record (in case anyone thinks of trying) — I restored my Apple TV with a USB cable via iTunes and set it up from scratch. No change, so it's definitely the update itself.

    Until Apple get around to fixing it, the best way to resolve it (albeit temporarily) is to tap the rewind button, then hit the play button pretty much straight away. That sorts it out for the usual amount of time, and it's a bit quicker than backing out to the menu and hitting play > resume. I've reported this problem to Apple via the feedback page — the more of us do so, the more likely Apple are to notice and fix the issue.
     
  10. kittonian thread starter macrumors member

    Joined:
    Aug 4, 2008
    #10
    I did some experimenting tonight and found that on 720p sources I don't have this issue, however on all 1080p sources I do (TV Shows and Movies). I thought it might have something to do with the metadata encoding via subler but it turns out that doesn't seem to have anything to do with it.

    Definitely need Apple to fix this one!
     
  11. jtrenthacker macrumors regular

    Joined:
    Apr 12, 2012
    #11
    I'm glad others are having this problem because I thought I was going crazy. All of my encodes are 720p and I thought it might be something I did wrong on the last couple encodes because that's when I started noticing the dropped frames. Also thinking it might have to do with size as my Wolf of Wall Street encode is 7gb and it was dropping frames about 15 minutes in. However, I watched some of my other encodes that are around 4-4.5gb and they play just fine.

    On the encodes that drop frames, I can stop the movie and play it again and it is fine for another 10-15 minutes and then back to stuttering. Very annoying. I thought maybe it was a router issue so I rebooted the router, iTunes, my computer, and the ATV (ethernet connection). Still the same. I hope Apple has a fix soon.
     
  12. McScooby macrumors 6502

    Joined:
    Oct 15, 2005
    Location:
    The Paps of Glenn Close, Scotland.
    #12
    +1, with a 1080p encode, it's driving me nuts, but so glad I stumbled across this thread, at least it's not just me!
    To make it worse though, I restored the ATV, previously had paired another remote with it, and now can't find the ATV remote. Problem sorted I thought, just use iPhone remote app, that'll work. Like Hell it does, pairs ok on restart but now doesn't find ATV on network, all wired btw, strange really considering iTunes does, so now I'm controlling it via iTunes & sound drop-outs and stuttering every few mins, sort it they better and fast!!
     
  13. jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #13
    I think I know the answer already...

    But is there anyway to revert back to the prior version? Unfortunately all 3 of my Apple TVs have been updated to 6.1 and all exhibit this stuttering effect.
     
  14. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #14
    Hmm I use my AppleTV constantly anytime I'm home and I haven't had any issues at all.

    It's connected via Ethernet. Are you guys that are experiencing the problem using wifi? Maybe the update screwed up the wifi.
     
  15. jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #15
    I use wifi, but the issue is happening with Ethernet too:
    https://discussions.apple.com/thread/6011768?tstart=0
     
  16. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #16
    Apple TV 3 6.1 Update Buffer Issue


    From your link.

    "JustinTMurc
    Re: ATV3 framedrops after 6.1 update
    Mar 23, 2014 5:53 PM (in response to YannieNL)
    If you have one of the original Apple TV 3rd generations you can downgrade to a firmware released in June. Apple released a small revision in 2013 that they didn't announce. You can't even tell by looking at the ATV.

    http://www.idownloadblog.com/2013/01/30/apple-tv-32-minor-upgrade/

    If you have the 3,1 version Apple is still signing an older version software released in June. Google "Apple TV Firmware Links" and it'll be something with "xxx.icj.me/xxx/xxxx" for an address. You can get the older version from there. It's the one with a green check mark (6.1.4 is what it's listed as) I'm not going to link the site because I don't think Apple allows that on their own forums. Just downgraded my ATV and it's working like before now. You'll need a microusb and the power cord.

    1. Open iTunes
    2. Connect ATV via MicroUSB
    3. Connect Power Cord
    4. When ATV shows in iTunes hold 'Option' and click restore then point it to the old FW you downloaded.

    Worked for me. Hope it works for some other people."



    Not the most elegant solution but a solution none the less.
     
  17. jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #17
    Yeah saw that...I really don't want to do that if it can be avoided
     
  18. Locoman, Mar 29, 2014
    Last edited: Apr 8, 2014

    Locoman macrumors newbie

    Joined:
    Dec 15, 2011
    #18
    i did what "cynics" suggested and my buffering issues went away. Thanks.

    But now the WiFi doesn't work, have to connect with ethernet cable. :(
     
  19. cynics macrumors G3

    Joined:
    Jan 8, 2012
    #19

    I totally agree, sounds like a pain and something you shouldn't have to do. However if it's that important it looks to be the only option.

    Have you guys been reporting this to Apple? Sound very wide spread.
     
  20. jdag macrumors 6502a

    Joined:
    Jun 15, 2012
    #20
    Exiting the movie, and even doing a very brief rewind, also seem to solve the issue for about 10 minutes. I really don't want to have to put a very old version of the OS onto the units. I have to believe this will be corrected sooner than later.
     
  21. MyopicPaideia macrumors 68000

    MyopicPaideia

    Joined:
    Mar 19, 2011
    Location:
    Trollhättan, Sweden
    #21
    Yup, I am getting this issue with all HD content, both 720p and 1080p. When I first noticed it, it felt like frame dropping on long pans like you used to get with some a DVD or Blu-ray players, but then I started noticing it in all situations something like 20 minutes in to HD content.

    Glad to know it just isn't me. I will be submitting a bug report as well!
     
  22. Menel macrumors 603

    Menel

    Joined:
    Aug 4, 2011
    Location:
    ATL
    #22
    Are people also seeing this with Netflix/Hulu?
     
  23. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #23
    On mine, Netflix works as well as before, it's just streaming videos from iTunes that have trouble.
     
  24. IscariotJ macrumors 6502a

    Joined:
    Jan 13, 2004
    Location:
    UK
    #24
    Same problem here, on two ATV2's ( one ethernet, the other wifi ).... The abnormally long time it took to update was obviously a warning.... ;)
     
  25. Apollo 13 macrumors 6502a

    Joined:
    May 29, 2010
    #25
    having problem with airplay. If I airplay file from my phone it shuts off in a couple mins if I airplay NBA League pass it does the same damn thing. It's pissing me off.
     

Share This Page