Apple TV 4K Dolby Vision issue

Discussion in 'Apple TV and Home Theater' started by chunter1001, Sep 23, 2017.

  1. chunter1001 macrumors member

    Joined:
    Jun 23, 2012
    #1
    Installed my ATV4K last night. Ran into a recurring issue where the Dolby Vision badge randomly appears which causes a slight stutter in playback when listening to music. Sometimes the screen will go black during this.

    My tv is a 2017 LG C7. Playback selected is 4k DV at 60Hz.

    Anybody else experiencing this? The HDMI cable is a new high-speed Amazon cable with 18 Gbps capability. Use the same cables for Xbox One S and 4K DTV boxes.
     
  2. thomasfxlt58 macrumors regular

    Joined:
    Sep 14, 2014
    #2
    Change your output setting to 4k/24hz or 4k/30 for DV on the ATV 4k. It should do this automatically but apparently it doesn’t yet.
     
  3. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #3
    Update: Replaced the HDMI cable which appears to have solved the problem.
     
  4. viking1972 macrumors newbie

    Joined:
    Sep 23, 2017
    #4
    Glad to hear that. I'm having the same problem. Which cable were you successful with?
     
  5. Dave Meadows macrumors 68040

    Dave Meadows

    Joined:
    Nov 10, 2010
  6. thomasfxlt58 macrumors regular

    Joined:
    Sep 14, 2014
    #6
    It would be if the the ATV passed native frame rates assuming the original is 24fps. If it’s been upsampled to 60, the 60 would be one less conversion. Some of the 4k sets have been upgraded to allow the input of DV 60fps.
     
  7. archer75 macrumors 68020

    Joined:
    Jan 26, 2005
    Location:
    Oregon
    #7
    Mono price premium certified support 18gbps which is what you need. They start at a few bucks. I have several.
     
  8. cmChimera macrumors 68040

    cmChimera

    Joined:
    Feb 12, 2010
    #8
    Could you link this cable please? I’m terrified of buying the wrong one, as I’m having issues with cables too I think.
     
  9. archer75 macrumors 68020

    Joined:
    Jan 26, 2005
    Location:
    Oregon
    #9
  10. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #10
    I had a spare of the Amazon Basics High Speed HDMI (current HDMI version). Just swapped it out, and it worked flawlessly. Not sure what could have happened to the one I replaced.
     
  11. benji888 macrumors 68000

    benji888

    Joined:
    Sep 27, 2006
    Location:
    United States
    #11
    Just get a certified cable, a cable not made to spec seems to show when using DV and ATV 4K, maybe this is because the ATV sends LPCM audio, which takes more bandwidth.

    https://www.hdmi.org/manufacturer/premiumcable/faq.aspx
     
  12. Stvevio macrumors newbie

    Stvevio

    Joined:
    Oct 5, 2017
    #12
    Hey, so I have a OLED 55" E6 and when I watch Netflix through the tv and select a Dolby Vision movie the Dolby Vision drop-down appears in the corner as I'm sure you're aware. But when I play the exact movie through Apple TV the Dolby Vision doesn't kick in.
    So what's the optimal setting you've decided on? I like the HDR but is DV the better way? My only concern is there's only a couple movies in DV so would I be forcing the display to show everything in DV is I change my ATV to DV?

    Wish it just automatically selected the appropriate display when selecting .....
     
  13. peppespizzapie Suspended

    Joined:
    Jul 5, 2010
    #13

    I had the same. Altough i bought all new HDMI 4K cables, some of the brands SAY it's for 4K, they arent. I replaced the HDMI cable and have no problems anymore.
     
  14. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #14
    So this problem came back. It was noticeable during music playback every once in a while there would be a pause in the music and then the Dolby Vision logo appeared in the upper righthand corner of the screen. After chatting with Apple Support, I exchanged the Amazon Basics high speed cable (which should work) with the Apple-approved Belkin.

    This issue disappeared. However, when I went through the Reset Video Settings and then try to turn Dolby Vision back on, I get a completely red screen. Then, then the confirm change screen is scrambled. However, if I go back and try again, it works fine. Any ideas what could be causing this?
     
  15. TexaClone macrumors newbie

    Joined:
    Oct 17, 2017
    #15
    I would try the Monoprice cable and check your cable length. If you are over 6 feet, you might have something causing interference.
     
  16. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #16
    Thanks! You're helping me out over on AVS Forum, too. I've got the 6-ft Belkin, but will try the 6-ft Monoprice.
     
  17. Patrick Turner macrumors newbie

    Joined:
    Sep 30, 2017
    #17

    Yesterday's OLED C7 Firmware update has fixed this problem for me. (Re: the intermittent red screen problem when starting Dolby Vision).
     
  18. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #18
    Great to hear it! Do you have pixel shift enabled? I ask because i can see some intermittent minor jumpiness when scrolling the icons on the home screen or in long lists. I wasn’t able to test if turning this feature off resolved the problem.
     
  19. TexaClone macrumors newbie

    Joined:
    Oct 17, 2017
    #19
    I have the OLED B7 and haven't had any issue with DV. I think it came with the 3.15 or 16 firmware. I didn't see any problems with that firmware on the DV side. But, I had massive lip sync issues, found the Korean 4.70.06 firmware and that fixed the lip sync, so now all is working flawlessly. (I have a Sonos Playbar setup, so that it where the lip sync issue came from)
     
  20. richard371 macrumors 68020

    Joined:
    Feb 1, 2008
    #20
    It dos fix the lips sync but now YouTube hdr 4K videos look washed out.
     
  21. numbersyx macrumors 65816

    numbersyx

    Joined:
    Sep 29, 2006
    #21
    I have the same issue with movies. If I play a Netflix or iTunes movie with DV there appears to be a split second difference in lip sync. Switching it back to HDR solves the problem. I have a Monoprice cable. Wonder what the issue is?
     
  22. mmm1345 Suspended

    mmm1345

    Joined:
    Aug 8, 2017
    #22
    I find 4k DV/30hz to be the best setting on my C7
     
  23. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #23
    I have the Monoprice cable arriving today. Thanks again for your help.

    Just to be clear, you have your ATVK sending a 4k DV signal to your B7 at 60Hz, correct?
     
  24. TexaClone macrumors newbie

    Joined:
    Oct 17, 2017
    #24
    Yep. See attached.[​IMG]
     
  25. chunter1001 thread starter macrumors member

    Joined:
    Jun 23, 2012
    #25
    Thanks! I installed the Monoprice cable, but still see random "flashes" - especially when navigating the Home screen icons. I even replaced the ATV4K and tried other HDMI inputs. I'm at a loss on this one
     

Share This Page

44 September 23, 2017