Apple TV can't connect to Internet

Katie Chen

macrumors newbie
Original poster
Mar 5, 2014
3
0
my Apple TV 3 doesn't seem to be able to connect to internet
i've tried both through WIFI and Ethernet cable. It seems to be connected to the network with all the IP address, etc details shown
I can obtain "software update", and I can stream video from my iPad through AirPlay
I can only see "computer" and "settings" icons on the home screen
I'm using a TP-LINK wireless router

Apple Support didn't know what's wrong. They have even given me a new Apple TV but still same problem remained

Can anyone help please? many thanks!
 

NukeIT

macrumors regular
Mar 20, 2013
233
0
What if you connect it straight to your WAN line?? Bypass the router and see what happens, at least then you would know if the router is blocking it
 

westrock2000

macrumors 6502a
Oct 18, 2013
524
22
my Apple TV 3 doesn't seem to be able to connect to internet
i've tried both through WIFI and Ethernet cable. It seems to be connected to the network with all the IP address, etc details shown
I can obtain "software update", and I can stream video from my iPad through AirPlay
I can only see "computer" and "settings" icons on the home screen
I'm using a TP-LINK wireless router
I had a similar problem. You can try my solution of going into the network and changing the DNS to 8.8.8.8 which is the public Google DNS.

Can read about my experience here:
http://forums.macrumors.com/showthread.php?t=1701033
 

Mrbobb

macrumors 601
Aug 27, 2012
4,987
192
It could be as simple as waiting for u to sign in the Apple Store. Not doing any fancy static addressing or hardware firewall are u? ICloud account?
 

Katie Chen

macrumors newbie
Original poster
Mar 5, 2014
3
0
I haven't changed any of the network setting. Took the advice to connect directly without the router and it works!

Then i connect the Apple TV through wifi again and it works miraculously!

Still I don't know what's wrong before but anyway it works now when I haven't really changed any of the setting

Thank you all for your reply!