Apple Watch not waking up new iMac

Discussion in 'iMac' started by Bill P., Jun 22, 2017.

  1. Bill P. macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #1
    I have an Apple Watch 1 which isn't waking up my new iMac. I've restarted both with the iMac giving a message that I needed to log in with my passcode after a restart in order for the watch to work, but it still isn't detecting the watch to wake up.

    I've also enabled Two-factor authentication on everything as required for this to work.

    Thoughts appreciated.

    Bill
     
  2. btrach144 macrumors 65816

    btrach144

    Joined:
    Aug 28, 2015
    #2
    Did you try restarting your Apple Watch?

    Also, go to Settings>Security and select "Unlock Mac with Apple Watch"

    You've probably done the above but just wanted to give the basics and maybe someone else can fill in from here.
     
  3. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #3
    Hi btrach144 and thanks for checking in. Yes, did both of those things....

    Bill
     
  4. iMi macrumors 65816

    iMi

    Joined:
    Sep 13, 2014
    #4
    You need to make sure you have two-factor authentication turned on the account. Double check and let us know if that doesn't help.
     
  5. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #5
    Yep, all devices now using two-factor authentication.

    Thanks,

    Bill
     
  6. benz240 macrumors regular

    Joined:
    Dec 25, 2008
    #6
    In my experience, Apple Watch wakeup/unlock of macs has been spotty at best. Granted I have a first gen watch but it only works about 50% of the time, and sometimes it will just stop altogether until I restart the watch, computer, or both. Not worth the hassle.
     
  7. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #7
    Hi Benz and thanks for the input.

    I haven't had the iMac wake up via my watch yet. However, the watch itself has been rock solid, never stopping. I love it and use its features constantly.
     
  8. Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #8
    Give AppleCare a call.
     
  9. 960design macrumors 68030

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #9
    My first gen watch has been waking up an iMac27 and MBPr2013 and now a newer MBPr2016 dozens of times per day.

    The watch does need to be placed on the wrist and the pin code entered to enable the password bypass, so that sounds correct.

    Hmmm, you stated, "wake up". I still have to touch the pad or normally I tap the space bar to wake up my computer.

    I work on several at the same time, for example. iMac is just to the left of me working, while I'm typing this message on my MBPr15. My watch woke up the MBPr, and now that my iMac has gone to sleep, I tap the touch pad and my watch wakes it up as well.

    So the iWatch actually does not wake up my computer, it only auto unlocks it.


    Bluetooth and WiFi turned on your mac? Internet Sharing is turned off?


    iMac running High Sierra, MBPr running Sierra, Watch running WatchOS4.
     
  10. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #10
    Hi 960design and thanks for the input.

    I have wifi and bluetooth turned on, but I see that my watch isn't listed in the bluetooth prefs as my trackpad, keyboard, etc. are. Internet sharing is turned off--is that a problem??

    I do hit the spacebar to wake up the iMac as I did this morning, but the watch still fails to unlock it.

    Thanks again,

    Bill
     
  11. 960design macrumors 68030

    Joined:
    Apr 17, 2012
    Location:
    Destin, FL
    #11
    iWatch does not show up in the Bluetooth preferences. The only things in there are two sets of bluetooth headphones; and keyboard and trackpad on the iMac.

    Using your iPhone Tap Watch > General > AppleID to make sure you are signed in on the watch (yep, the watch ).
     
  12. Robbo1 macrumors member

    Joined:
    Apr 4, 2017
    #12
    FWIW, I set up my Watch to unlock my new iMac the other day and it has been working flawlessly.
     
  13. AppleCorn, Jun 27, 2017
    Last edited: Jun 27, 2017

    AppleCorn macrumors newbie

    Joined:
    Feb 15, 2015
    #13
    Hi Bill,
    I have exactly the same troubles. And exactly the same devices.
    I've called Apple and they've tried a lot to try to get it going right. The next day they called and tried again. One thing that did occur, during several attempts, was that when they asked me to tap 'sleep' and then put my watch by the iMac and that did wake the screen, but you had to enter your password. So they felt like the Watch Bluetooth contacted the iMac Bluetooth. So, I had to send them two big files from my iMac for them to investigate the trouble. That was on June 20th and 21st. Hope they can find the trouble!!

    Thanks

    P.S. I can't get the Wakes to appear anymore like it did when working with Apple watching me.
    Hmmmm!
     
  14. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #14
    Thanks for all of the input.

    960design, I checked and have Apple ID signed in on the iWatch app.

    Robbo1, good to get the affermation!

    AppleCorn, do let us know if you find the problem!!

    I know the iMac senses my watch because when I went through what needed to be done to get everything supposedly working together my iMac now gives me a message on the sign in screen something to the effect that I needed to enter my password after restarting rather than using the watch.

    Best,

    Bill
     
  15. AppleCorn macrumors newbie

    Joined:
    Feb 15, 2015
    #15
    Yeah, I get that too when I do a 'restart'. But, if you go to Security & Privacy/General on your iMac and turn off the 'Allow your Apple Watch to unlock your Mac' and then run a 'restart' it doesn't tell you about the Watch.
    So, I'm not sure that the Watch Bluetooth is used there.
    They gave me a Case number regarding our issue. If I don't get a call in a couple days I'll give them a call and hope they figured it out!
    There has to be more than just the two of us. If I see anything I'll send it to Bill!

    Thanks,
    Ken
     
  16. SaSaSushi macrumors 68040

    SaSaSushi

    Joined:
    Aug 8, 2007
    Location:
    Takamatsu, Japan
    #16
    I would occasionally have this problem with my Late 2013 iMac. Turning Bluetooth off on the Mac and then reenabling it would cure it for me. It's a bit of a pain because once you disable BT you, of course, lose the Magic Mouse so make sure to have a USB mouse handy.

    I haven't had this problem yet with the 2017 iMac. It unlocks dependably.

    You can also try unpairing and repairing the Apple Watch from the Watch app.
     
  17. AppleCorn macrumors newbie

    Joined:
    Feb 15, 2015
    #17
    great news Bill!!!! The call i made today AppleCare fixed it!!!
    This is the order it took place!

    1. Go to System Preference/Security&Privacy/General
    2. Unlock to edit it.
    3. unmark "Disable automatic login" (in the other instructions it showed it leave it But Don't)
    4. Mark the "Allow your Apple Watch to unlock your Mac"
    5. ReLock the System Preference/Security&Privacy/General

    6. Go to Users & Groups and unlock to edit.
    7. Tap "login Options"
    8. Then select the "Automatic login" to your name.
    9. ReLock the Users & Groups.

    Enter the "sleep" by the logoff

    Wave your Watch near the the screen.!!!!!

    I sure hope it works for you to!!!!!!

    Thanks,
    Ken
     
  18. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #18
    What a guy! It worked, Ken. The change I needed to make was the uncheck "Disable Automatic Login". Seems obvious now doesn't it.

    Many thanks for sharing and taking the time with Apple support. I very much appreciate it, Ken.

    Enjoy your evening and have a great 4th!!

    Best regards,

    Bill
     
  19. Bill P. thread starter macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #19
    Solved! I was still having a few wakeup issues. As it turns out, this new iMac was sitting near my old one, also connected to wifi, etc. Once I boxed up the old one and put it in the other room, the watch and Mac started getting along famously!
     

Share This Page