Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Apple Watch Series 5 and Mac Unlock

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
Is anyone else having issues with an Apple Watch Series 5 and Mac unlock? My series 4 works fine but even after repairing the Series 5 to my phone it does not work on my iMac Pro. Both work fine on my MacBook Pro though. Nothing but issues with the Series 5 and I have even swapped out at Apple to no avail. Also handoff is not working with series 5 either.
 

AL2TEACH

macrumors 6502
Feb 17, 2007
312
37
Denver, CO.
Comment

mk313

macrumors 65816
Feb 6, 2012
1,215
513
I had an issue AFTER I repaired my watch to my phone. I had to go into the security settings on the mac, disable the series 5 and then re-enable it and now it works fine again.
 
Comment

MacGarage

macrumors regular
Jun 18, 2017
156
71
Ohio
One of our S5s is having an issue. It stopped working and when you click on unlock with the watch, it states you need to be logged onto iCloud...she is...have done the items listed above except unpairing.
 
Comment

jaybar

macrumors 68000
Dec 11, 2008
1,533
384
I have never found unlock to work consistently. We have two accounts on our iMac. My husband does not have an AW, but I do. It never consistently unlocks my account. Perhaps if we only had one account on the iMac, it might work better?
 
Comment

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
What confuses me is it works fine on Series 4 but for the life of me and frankly Apple after doing multiple treble shooting steps some of which are mentioned above nothing has worked.
 
Comment

deep1

macrumors 6502
Mar 29, 2011
294
135
Had same issue on S5, logged out of iCloud account On MAC, restart Mac, restart Apple Watch. Login to iCloud on Mac. Then turn it on.
 
Comment

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
It's weird it will work for 10-15 minutes then stop. Handoff works fine. No problem with series 4 only series 5. Tried all the steps above.
 
Comment

Duncan68

macrumors 6502
Sep 22, 2018
464
326
I know for a fact that USB-A ports interfere with unlock on a Mac mini. Using a Thunderbolt port instead solved the issue for me.
 
Comment

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
Stilll having this issue deleted the bluetooth plist to no avail. It will work for a few minutes then stops unlocking. However handoff between messages, news etc works fine. Seems to be only my iMac Pro and MacBook Pro. Anybody else have any suggestions? No issues with series 4 only 5.
 
Comment

nickdalzell1

macrumors 65816
Dec 8, 2019
1,265
627
Mine stops unlocking after awhile at random as well. Last time a watch restart fixed it. It will, for a millisecond, say 'unlocking with apple watch' then default to 'unlock with touch id.'
 
Comment

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
Mine stops unlocking after awhile at random as well. Last time a watch restart fixed it. It will, for a millisecond, say 'unlocking with apple watch' then default to 'unlock with touch id.'
That pretty much sums it up on both my macs. However, a watch restart does not always fix it. So aggrevating.
 
Comment

lclev

Contributor
Jul 29, 2013
356
145
Ohio
I had issues when I still had both my S4 and S5 paired with my iPhone. When I got rid of my S4 then the S5 no longer had issues. For some reason switching between the two watches didn’t always work. I would loose handoff and unlocking of my MB Pro. Now with just the S5 it has worked flawlessly.

I wanted to keep the S4 as a backup, but evidently while it should work, for me it did not.

Lisa
 
Comment

nickdalzell1

macrumors 65816
Dec 8, 2019
1,265
627
While I have both a S3 and S5, my S3 is powered off and in its box in storage at the moment so it's not a conflict I'm aware of. Possible Catalina bug?
 
Comment

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
While I have both a S3 and S5, my S3 is powered off and in its box in storage at the moment so it's not a conflict I'm aware of. Possible Catalina bug?
I am thinking it has to be catalina bug or watchOS. Has anybody else reported it?
 
Comment

lmcrael

macrumors member
Sep 22, 2014
82
40
I think this is a catalina bug. I'm having the same issue intermittently on my series 4 and 2019 macbook pro. It didnt start happening until I installed the latest catalina update.
 
Comment

bbfc

macrumors 68040
Oct 22, 2011
3,190
741
Newcastle, England.
Mine has just stopped working. I have updated to the latest Catalina 10.15.4 beta, so maybe its a bug in that. Nothing else has changed. I can't even get it to enable in settings > security.
 
Comment

smf72

macrumors regular
Original poster
Jun 28, 2010
224
23
Mine has just stopped working. I have updated to the latest Catalina 10.15.4 beta, so maybe its a bug in that. Nothing else has changed. I can't even get it to enable in settings > security.
Are you using a series 5 and beta watchOS ? I am still on 10.15.3 and watchOS 6.1.3. If you are on the beta do you mind reporting the bug
 
Comment

bbfc

macrumors 68040
Oct 22, 2011
3,190
741
Newcastle, England.
Are you using a series 5 and beta watchOS ? I am still on 10.15.3 and watchOS 6.1.3. If you are on the beta do you mind reporting the bug
I'm using the latest beta of Catalina 10.15.4 and watchOS 6.1.3.

Edit: It's working now.
 
Last edited:
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.