Apple's EFI Firmware 2.9 Update for 2011 MacBook Airs Appears Buggy, Some Users Unable to Install

MacRumors

macrumors bot
Apr 12, 2001
7,187
8,365
0
19
www.macrumors.com



Apple's recent EFI Firmware 2.9 update for 2011 MacBook Air models appears to be causing trouble for several MacBook Air users, according to a thread on the Apple Support Communities.

Released on July 15 to fix sleep/wake issues and a bug that caused fans to run at full speed after waking from sleep, the EFI update has caused some MacBook Air machines to shut down completely for several hours and on other machines, the update is still listed in the App Store after being installed.

Multiple users have said their machines turned off and did not reboot for several hours after attempting to install the update, while others have been unable to install the update at all. Some users have also reported completely bricked machines even after several hours.

One user attempted to install the update multiple times with no luck, while another user took his machine to the Apple Store where employees were also unable to get the update to install.
I had the same issue. The machine simply shuts off and doesn't restart so the firmware update is never applied. The power button stopped working and the machine would not turn on at all. So I took it the the Apple Store and they cracked it open to do a physical SMC reset.

It booted up fine after that. We tried the install again and no dice. Same thing happened. This time the guy at the Genius Bar did some kind of "soft" SMC reset. He pressed SHIFT+FN+CONTROL+POWER at the same time (the first 3 keys are in the lower left corner) ... held it for a few seconds and let them go. When he pressed the Power button after that the machine booted up fine. Still didn't apply the firmware update though. The guy at the Genius Bar said he would report this issue to Engineering to alert them to the problem with the update.
It is not clear if the issue is widespread or limited to just a 2011 MacBook Air users, but as none of the affected users in the thread have discovered a solution, those who have not yet attempted to install the 2.9 update might wait to wait for an official fix from Apple.

Article Link: Apple's EFI Firmware 2.9 Update for 2011 MacBook Airs Appears Buggy, Some Users Unable to Install
 

blue-fireball

macrumors member
Jan 13, 2014
35
0
0
I wonder if this is unofficially related to many 2011 MacBook Airs not supporting Handoff in Yosemite so far, despite having Bluetooth 4.
 

MikhailT

macrumors 601
Nov 12, 2007
4,330
821
0
I've seen this issue before. It was related to having FileVault enabled. As soon as it was turned off, it worked fine.
 

rdinterman

macrumors regular
Sep 17, 2012
107
127
0
Florida
Installed with no issues, mine stayed off for about 3-4 minutes after "restart" but than came right back up. I, too, was hoping this would be related to handoff not working in the Mid-2011 MBA despite have Bluetooth LE.
 

blue-fireball

macrumors member
Jan 13, 2014
35
0
0
I clicked to update, since I like to live dangerously. The update downloaded, told me to plug my laptop into power, and then disappeared and did not update at all, even after manually restarting. I think I have won this round: no nagging about updates from the App Store and no buggy firmware installed. Confirmed the lack of installation in the System Information (Boot ROM Version).
 

smithrh

macrumors 68020
Feb 28, 2009
2,463
833
0
For cripes sake:

Bugged != Buggy

Title implies that installing this EFI firmware will bug your MBA.
 

GMcKenzie

macrumors newbie
Aug 18, 2011
13
0
0
Weird glitch - you need to hit the return key

After installing the update and restarting, your screen may go dark and your computer may appear to hang. Hit the Return key and installation will continue.
 

Reason077

macrumors 68020
Aug 14, 2007
2,155
646
0
Title implies that installing this EFI firmware will bug your MBA.
Actually, it does not surprise me at all that the SMC firmware is "bugged". (side note: SMC != EFI)

The SMC chip is a small, low power, general purpose CPU - which remains active even when the rest of the system is shut down. It can access much of your systems hardware (including responding to network requests!), even when your computer is off.

The SMC is not easily accessible by standard debugging tools and techniques, and it operates independently of the OS, so reinstalling or replacing the hard drive cannot remove it.

This makes it the perfect place for government agencies to install surveillance and "security" code!

In fact, the existence of back doors in the SMC has been known about for some time.
 

Habberkuk

macrumors member
Mar 2, 2013
62
0
0
Under your bed...
I know it might be stupid to update after reading this post, but I want to try it anyway because it take forever to wake my mac from sleep. However, the update doesn't show up under the update section of the App Store. The link provided in this article doesn't work either. Did Apple take this update back?
 

oberman

macrumors newbie
Jul 23, 2014
16
0
0
I can confirm MikhailT's workaround, disable FileVault and it works like a charm.
 

Goldenbear

macrumors regular
Jun 30, 2007
226
3
0
Los Angeles
Mine installed fine with Filevault turned on. Twice, in fact, because the update kept appearing in the app store.

Today, the update disappeared from the app store.

MBA still takes a little while to wake up from sleep when it's been on battery, but the wait time was a little shorter today.

More importantly, I can once again connect wirelessly from my bedroom. 10.9.4 killed my wireless, unless I was less than 10 feet from my router. All is good once again.

YMMV
 

BoyRacer

macrumors member
Sep 21, 2003
36
5
0
50
watchthatmac.com
Whats Bootrom version AFTER install?

Hi!

I foolishly didn't check the BootRom version on my MacBook Air 2011 BEFORE running the EFO Firmware 2.9 Update.

Can someone who knows the BootRom versions both prior to installation of the EFO update and after the update, please post it here?

Apple has a page documenting all firmware versions:
http://support.apple.com/kb/HT1237

The reason I'm requesting the version number: so I can confirm that the EFI update actually installed.

My MacBook Air BootRom firmware is currently MBA41.0077.B0F.

Many thanks!

Oh, sorry - the title should NOT include the word 'Whats'; it should be "BootRom version after install?" Less haste, more speed...
 
Last edited:

TheGarreth

macrumors member
Jun 15, 2010
50
3
0
Sunnyvale, CA
BoyRacer, your update did not install. The current version MBA41.0077.B0F was the previous version we were all running on. For a short time yesterday after the update was released, Apple's firmware page was updated to reflect MBA41.0077.B11F as being the current version - they have since, having realized this was a bad/erroneous update, canceled the software update & revised that page to show MBA41.0077B0F as being the current version.
From everything I'm reading, it's pretty apparent that the new EFI didn't actually install for anyone.
 

gavroche

macrumors 65816
Oct 25, 2007
1,158
951
0
Left Coast
My install took a very long time to restart after reboot. Thought it was bricked. Was in process of researching the issue on the iPad when it finally rebooted. My points of note:
1) Definitely starts from sleep more rapidly now. Love this.
2) Having issues with wi-fi now. Specifically, after waking the computer from sleep, nearly every single time the wifi network is no longer chosen and active. I have to wait for it to scan for available networks, and select correct one to join. Annoying.