AppleTV 4K displaying Green Box when playing movies

Discussion in 'Apple TV and Home Theater' started by appleguy, Dec 30, 2018.

Tags:
  1. appleguy macrumors 6502

    appleguy

    Joined:
    Aug 23, 2002
    Location:
    Auckland, NZ
    #1
    I just got myself a brand new Panasonic OLED 4K TV.
    I have had a AppleTV4K for a while just had my 4K movies off to the side until I got this. Went to play one last night. I get nothing but a Green Screen (The Size of the Movie) when playing the movie in Plex
    The sound plays.
    This happens if the AppleTV is set to 4K HDR resolution.
    If I drop down to 4K SDR the video does play.
    Other home made videos with my DJI Osmo play ok as well in HDR

    Netflix is playing fine with the 4K HDR

    The HDMI cable is a High Speed one with Ethernet (I can’t remember the spec of the cable I have had it a little while) But if Other Videos in 4K it should be ok right?

    I have tried the same video with the Infuse5 Player back to Plex getting the Same Green Screen.
    I even tried with Infuse 5 Directly connecting to my MediaServer (on NAS) And getting a Green Screen.

    I am assuming the Cabling is ok As NetFlix is running fine
    As for my home 4K movies.
    Just not my Encoded Movies
     
  2. priitv8 macrumors 68040

    Joined:
    Jan 13, 2011
    Location:
    Estonia
    #2
    What does MediaInfo say about the movie file?
    Sounds like a codec/format problem to me.
     
  3. Diemenz macrumors member

    Joined:
    Sep 9, 2015
    #3
    The above poster is correct. This is a codec issue. Have Plex transcode it.
     

Share This Page