AppleTV Can Not be Signed into Homesharing

VideoBeagle

macrumors 6502a
Original poster
Aug 17, 2010
776
9
App Q&A testing by request.
AppleTV 3 can not be signed into homesharing.

Two Factor Authentication requiers the password+access code be entered into the AppleTV 3

The entry form on the AppleTV 3 only allows for numbers, not letters or symbols.

I do not know if this problem exists with the 4 or 4k.

I have sent the above message to apple.com/feedback.

I urge anyone reading this to do the same to hopefully prompt action.
 

MikeBusch2

macrumors newbie
May 31, 2012
11
1
I have a similar issue.

Updated my primary Mac (Also a 2012 i7 iMac) to Catalina, which obviously replaces iTunes with TV\Music\Whatever. My AppleTV3 couldn't see my shared library, which I re-shared through system prefs > Sharing > Media Sharing.

My AppleTV3 still wouldn't see my library. I tried signing out and back in, and while I received a 6-digit code (digits, no letters or symbols) on my other devices, I am prompted with a message saying that my Apple ID could not be found, or the password was incorrect (it's not).

Riddle me this, Batman....who the hell do you think you're sending the 6-digit code code to, if not my LEGIT Apple ID, which I then entered as requested on my AppleTV3? Peculiar how I can access the same shared library from my iPhone or my MacBook.

Between this artificially planned obsolescence on the part of my AppleTV3, the childish Nvidia driver spat, and the already-faulty battery in my 2-year-old MacBook 12", I'm really ready to bail on this Apple stuff. It's been a long time since things "just worked" as I've been conditioned to believe.

If I wanted to have to deal with this crap, I'd have stayed with Windows.

-Mike
 

thisisnotmyname

macrumors 68000
Oct 22, 2014
1,944
4,213
known but velocity indeterminate
Apple TV 4Ks having an issue with home sharing since updating to Catalina. May not be confined to Apple TV 3rd gen. Make sure you've activated the new new Home Sharing preferences in System Settings though too (although mine is active and still isn't working).
 

bickers1972

macrumors newbie
Oct 30, 2013
6
0
Same issue as well for me on my ATV 3's since updating to Catalina. I'm going to raise a ticket with Apple but if anyone has an update on this would be grateful if you could post it on here.
 

Anthonyricco

macrumors newbie
Oct 10, 2019
1
0
Hey Guys
Yeah wierd thing happened yesterday - I tried to get into my Computers folder on my Apple TV - and had the same problem, username and password worked, but after I was sent and put in the verification it gave me the error. I forgot it on that screen and went out and when I got home I switched on the TV and on the screen was my library.

Looks like it's sorted, not sure if it went in because it was left on that screen or if apple fixed it but there is no way I'm taking a chance logging out and trying again. Haha.

Now just have to figure out how to get playlists I've made In the Apple TV app on my computer to show on Apple TV because now everything is just lumped together.