Apps keep asking for password to use 'Local Items' keychain

Discussion in 'OS X Mavericks (10.9)' started by timothycricket, Oct 9, 2013.

  1. timothycricket macrumors newbie

    Joined:
    Mar 15, 2013
    #1
    Hey guys, just installed Mavericks GM yesterday and this morning I booted up for the first time and I kept getting incessant '_______ wants to use the 'Local Items' keychain.' It doesn't appear that I can connect to the internet and everything seems more crash prone than before. I tried opening up Keychains via Utilities but I can't access or delete the 'Local Items' keychain without the password which is not my mac user's password.

    Before I committed to either rolling back to 10.8 or trying to reinstall 10.9, I thought I'd give the forums a try. Thanks for any help you guys can provide!
     
  2. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #2
    Keychain is used for storing passwords for many things, including your home networks Wi-Fi Password and your email account password.

    Basically what is happening is that the OS X Security model requires a newly installed application (Such as those installed when you upgraded to Mavericks) to request your permission before giving it access to passwords.

    Instead of just clicking the "Allow" button, click the "Always Allow" button if you trust the action that is being done.

    While looking into this, I ran into a bug where I'm not able to unlock my login keychain either. When I click the lock icon, nothing happens. So now I have something to look into myself.
     
  3. nicroma macrumors 6502a

    nicroma

    Joined:
    Jun 20, 2009
    Location:
    Midwest, USA
    #3
    I had this same problem. Luckily I ran into this while testing and not with my production data. My fix was to set up a fresh install of Mavericks and then I migrated my data and now it's running fine.
     
  4. timothycricket thread starter macrumors newbie

    Joined:
    Mar 15, 2013
    #4
    Yeah I figured that this would happen. I'll do a clean install tomorrow. Thanks a lot guys!
     
  5. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #5
    By restarting, or locking the screen and unlocking it, the login keychain was unlocked again. I restarted since then, and the Keychain Access utility is not having the issue anymore.
     
  6. singhjeet29 macrumors regular

    Joined:
    Oct 9, 2008
    #6
    I'm having the same problem, which started after my MBP battery died and I restarted it, and I've tried a lot of different things and neither of them are working. It looks like there must have been a 'Local Items.keychain' file that was deleted somehow.

    But the system keeps nagging me for a password for it. I can't use Safari, iCloud etc. b/c apparently Local Items is where all those passwords were stored ...
     
  7. RabidMacFan macrumors regular

    Joined:
    Jun 19, 2012
    Location:
    California
    #7
    The default keychain is called "login". The actual keychain files can be found at
    ~/Library/Keychains/
    /Library/Keychains/
     
  8. singhjeet29 macrumors regular

    Joined:
    Oct 9, 2008
    #8
    Yeah but it wasn't the login keychain that was problematic, I could unlock that one just fine. Regardless I couldn't seem to find a solution and just clean installed Mavericks.
     
  9. russcus macrumors newbie

    Joined:
    Oct 20, 2013
    #9
    This is how I fixed this problem

    I had the same issue. Here is what I found and what I did.

    Local items appears to be a sort of 'pseudo keychain' within login. It does not exist as an independent keychain file and is locked and unlocked when login is locked and unlocked.

    My login keychain has had a different password than my user account for years.
    The problem began for me when I changed my Keychain Access preferences to "synchronize the login keychain password with account." The PW for login was changed correctly, but local items did not inherit the new PW. So logging into my user account correctly unlocked the login keychain, but local items remained locked. Eight agents and daemons asked for the PW to local items each time a logged in. Keychain Access cannot alter local items' password or other settings to remedy this.

    I cleared the "synchronize..." checkbox in Keychain Access and set the PW for login to be the same as the account's PW. I confirmed that local items inherited the PW. Now all three (account, login and local items) all had the same password. In Keychain Access Preferences / First Aid tab, all checkboxes are checked EXCEPT ""synchronize the login keychain password with account." Everything works as expected. Logging into the account unlocks both login and local items and no agents demand a PW for local items.

    Hope this helps.
     
  10. Westside guy macrumors 601

    Westside guy

    Joined:
    Oct 15, 2003
    Location:
    The soggy side of the Pacific NW
    #10
    After upgrading to 10.9 Mavericks today, I ran into the same issue after moving a bunch of stuff to my iCloud keychain. I found this thread while searching for the answer, so I thought I'd add the solution (what worked for me, anyway).

    Like some others here, I've consistently used a different password for my keychain password than my login password.

    Anyway - in my case, the "Local Items" keychain password turned out to be the same as my login keychain password. This doesn't seem too surprising, given the information previously posted here.
     
  11. TantoGlamour macrumors newbie

    Joined:
    Mar 30, 2013
    #11
    I Forgot the Keychain Password

    I Forgot the Keychain Password if I had one. I update to Mavericks and I cant do nothing, always appears a message "____ App wants to use the 'Local Items' keychain.'... I try to use Keychain First Aid and I asked again for the lost PW, thats stupid!!! To repair a keychain with a wrong PW u need the wrong PW!!! I make a new keychain as recommended in some forums and put my Adm PW, then try to repair the Local Items Keychain and again the same problem. I need the changed-wrong PW. Someone resolve that?
     
  12. yabot macrumors regular

    Joined:
    Jun 26, 2013
    #12
    can someone help me with this as well please i have no idea how to solve it. i installed mavericks from app store and its really slowed my laptop down (2013 15 inch retina), and keeps asking for keychain password, i have no idea how to get rid of it and have tried matching my account password with keychain password but that doesnt seem to work either,

    pleeaaseee, thanks.
     
  13. Npalamidis macrumors newbie

    Joined:
    Jun 26, 2007
    Location:
    Venezuela
    #13
    This solved me this problem.

    I was suffering with this same problem, I followed these steps and everything returned to normality:

    1.- I opened KeyChain app and run the FirstAid (from the KeyChain app Menu)with my user Password (this do work) because the problem is not with your password. If there is any trouble with your keychain file this will fix it.

    2.- Opened Disk Aid and run Fix Persmissions just in case there was left some wrong file permissions during the upgrade.

    3.- Went back to the Key Chain App and Locked and Unlocked the Keychain using the Lock in the top left corner of the app. When asked for my password I simply typed my User password.

    After this everything worked fine. These are the steps that I followed but I really think that #3 did the trick here. You could try to do only #3 directly and it might fix your problem, but fixing the Keychain and fixing OS permissions is never a bad Idea.

    Good Luck friends.:apple:
     
  14. MrChurchyard macrumors member

    Joined:
    Sep 22, 2008
    #14
    I just ran into the same issue.

    Permissions repair or Keychain First Aid don't seem to help; it seems to be a problem with the iCloud Keychain. It seems that the OS somehow forgot that it was supposed to have an iCloud Keychain, leaving its contents orphaned as “Local” keychain.

    I don't remember exactly how I fixed it, but I think I deleted the Local keychain and reactivated the iCloud Keychain sync.
     
  15. simchal123 macrumors newbie

    Joined:
    Oct 27, 2013
    #15
    Have you sorted your problem out yet? I need to fix this ASAP because I've get extremely important course work and law related files on here and this issue is making everything difficult :( thanks
     
  16. Grateful Crown macrumors newbie

    Joined:
    Oct 28, 2013
    #16
    Hope this helps

    Hi everyone

    I suddenly had the same problem after awhile of no issues with mavericks.
    so naturally I went to google to look for sites to find a solution and I stumbled across this one (second on the list i think)

    I tried a few things without success
    then I tried locking the "login" keychain and unlocking it again with the user password (the user password was not working with "local items" keychain)

    After unlocking "login" again a box appeared asking me to change the password for "local items" but I needed the old password
    however if you click the "reset password" button on the bottom left of the box it tells you that you won't be able to access your "iCloud" keychain and accepting that seemed to sort it all out "local items" became unlocked, the annoying boxes stopped popping up and I still have access to everything


    Sorry for the long winded post
     
  17. kappaknight macrumors 68000

    kappaknight

    Joined:
    Mar 5, 2009
    #17
    Thanks for this post. I learned from here that there's a Keychain app under the Apps/Utilities Folder.

    In my case, my Mavericks install can't seem to remember the log in to my local Macs. What I did was go into the app and removed all instances of the keychains that had the computer name on it. It seems like when multiple copies are in there, OS X will ask you for the password instead of trying them - even if they're all the same.

    So once I removed all the duplicate keys, and saved a brand new one, that seemed to have worked.
     
  18. matt303 macrumors newbie

    Joined:
    Feb 27, 2011
    #18
    Wife's just suffered this, almost everything that needed the key started prompting, it wouldn't accept her password, then the key chain tool beach balled and made the machine unresponsive to the point of needing power cycling. Once rebooted locked and unlocked the key chain then locked it and seems OK for now.

    Nearly had a smashed MBP there.
     
  19. Oliver4AU, Oct 30, 2013
    Last edited: Oct 30, 2013

    Oliver4AU macrumors newbie

    Joined:
    Oct 30, 2013
    Location:
    In the heart of the Heart of Dixie
    #19
    Worked for me!

    I could not unlock the Local Items folder. None of the passwords that I use would work. I could not run the First Aid in the Keychain app. I re-installed Maverick, which hung up and showed less than 1 minute for over 30 minutes. Then I ran your #3 suggestion. It would not complete, so that did not work. For my next attempt, I tried your #2 suggestion, followed by #3. Fixed!:D
     
  20. buffalo macrumors 65816

    Joined:
    Jun 5, 2005
    Location:
    Colorado Springs / Ohio
    #20
    Ughh, is anybody still having this problem?

    I've been getting these popups since Mavericks install, except for me it's asking for my Login keychain instead of Local Items.

    I have tried
    #1. Keychain Access > Keychain First Aid > Repair
    #2. Disk Utility > Macintosh HD > Repair Disk Permissions
    #3. Keychain Access > lock and unlock my Login keychain

    Unfortunately, I have not had any success with either of these methods. The most common applications that seems to ask for my password are Safari, Address Book, Messages, and then a couple oddballs.

    Any suggestions? I'm starting to wonder if a wipe of my HDD and clean install might be my best options... Thanks!
     
  21. prensesmetch macrumors newbie

    Joined:
    Nov 26, 2013
    #21
    I had the same problem after upgrading to Mavericks. I called up the Apple store, and this was the fix that was given me:

    * Go to Finder.

    * On the Finder menu, click on "Go", then on "Go to Folder". A box should come up.

    * On the box, type in "~/Library/Keychains/" and click on "Go". It should lead you to the Keychains folder where you will find three items: (1) a folder with a name mixed with letters and numbers, (2) login.keychain, and (3) metadata.keychain.

    * Delete the folder with a name mixed with letters and numbers.

    * Restart your computer. Check to see if the problem has been solved.

    It worked for me. Hope it works for you too!
     
  22. Iphone4sinwhite macrumors 6502

    Joined:
    Oct 24, 2011
    #22
    You are a wonderful human being. Thank you Sir.
     
  23. jayjax macrumors newbie

    Joined:
    Dec 18, 2013
    #23
    I signed up specifically to say THANK YOU! It worked like a charm!!!!!!!! :D
     
  24. ivoh2player macrumors newbie

    Joined:
    Dec 19, 2013
    #24
    Thanks so much sir! I created an account just thank you!
     
  25. pcimring macrumors newbie

    Joined:
    Dec 24, 2013
    #25
    Spot on!

    I signed up on this forum to join your fan club and say thanks :) After upgrading to Mavericks, I first tried 3 or 4 other proposed solutions - this is the one that worked. Good job, mate! :)
     

Share This Page