Are you still having Wi-Fi issues on you iPad? I found the fix!

Discussion in 'iPad' started by Wifiuser, May 26, 2010.

  1. Wifiuser macrumors newbie

    May 26, 2010
    Hello everyone. Yes, I am sure I figured out the fix. The many fixes that worked for some of the people some of the time, and the rest of them that tried them and nothing worked, this is for you. It is really a combination of the fixes with one extra step. My remedy might take a little bit of time depending on how advanced your router is configured. I have fixed mine, and 3 of my friends routers with various iPad connection issues and it has fixed all of them. Tested on the following routers (Linksys, D-Link, & Netgear). I am sure it will work on other brands too due to my success on these routers. Before continuing, hand write or copy your personal configuration settings into word/publisher/etc or by any other means except creating a backup bin file via your router.

    1) Install the latest firmware on your router even if it already has the latest version. When the router firmware is newly updated, do a hard reset to bring the router to its factory settings with the new firmware. Refer to your individual product manual. (Usually while the router is plugged in, press and hold the reset button on the back of the device and unplug the power to the device while continuing to hold the reset button for 20-30 seconds more, then release the reset button.) Do not restore your existing configuration from a bin file (I know this is a pain but you want it fixed right?)

    2) Change your broadcast channel to 6 or 11. Not always necessary but it wont hurt. P.S. Don't forget to save the settings as you go from page to page.

    3) Proceed to your wireless security settings and setup WPA (I personally setup all the routers with WPA2 but to each is own). Before preceding to the next step, connect your iPad/iPhone/iTouch and your other wireless devices to your wireless network. P.S. Don't forget to save the settings as you go from page to page.

    4) Now you may proceed to manually reconfigure your router. (I.e. DHCP/Static DHCP/Static IP/Port forwarding settings, etc if applicable. I have a static ip for my router and use static DHCP for all my network devices as I do a lot of remote access configurations, windows rdp and real vnc connections so this was tedious for me) P.S. Don't forget to save the settings as you go from page to page.

    5) Finally, this next step is not always necessary but I recommend doing it just for the sake of making sure you you start fresh. Once you have saved all settings on your router, Power off all network connected devices and unplug your router for at least 10 seconds. Power up 1 device at a time and make sure it connects to the Internet. Wahla. Your iPad/iPhone/iTouch connection issues are solved.

    Any other questions, I will try to handle on an individual basis.
  2. Streethawk macrumors 6502

    Feb 25, 2010
    Manchester, UK
    Do you think Starbucks will let me reconfigure their WiFi?;)
  3. Macdicted macrumors regular

    Jan 22, 2010
    NYC > Tampa Bay
    So the answer is to reset all routers everywhere you go ?

    May solve the home issues but doesn't help anywhere else. Don't think people bought an iPad just for home use. I know I didn't.

    Not sure why it's taking Apple so long for an update. They acknowledged problems several weeks ago. How much longer should it take ? I'm on my second WiFi and will be returning this one too and getting a 3G.
  4. fjfjfjfj macrumors 6502

    Mar 20, 2009
    New York, NY
    Thank you for taking the time to work all of that out, that was nice of you to find a fix to the problems so many have with their wifi. I hope it works well.
  5. GbV76 macrumors member

    Nov 29, 2003
    Ontario, Canada
    Turning the 'Auto Brightness' feature off fixed my wi-fi issues (I always had to manually rejoin my network). Strange but true.
  6. jtara macrumors 68000

    Mar 23, 2009
    I'll bet your problem comes back after a while.

    All you've done is come-up with an extraordinarily complicated way of resetting the pool of IP addresses used by DHCP.

    The problem will come back once your router has worked it's way through the pool, and the iPad attempts to use an IP address that it's released and has been re-assigned to another device.
  7. Aduntu macrumors 6502a


    Mar 29, 2010
    The connection issues most are experiencing have nothing to do with DHCP lease issues.
  8. aerodoc macrumors member

    Aug 10, 2009
    It would be good to see what others think, but there doesn't seem to be anything there that others haven't tried or that would seem to indicate that it would work. But who knows.
  9. gdjsnyder macrumors 6502a


    Apr 19, 2010
    Swoyersville, PA
    Maybe this could work as a temporary fix, but the wifi issue isn't an issue with routers, it's an issue with the iPad itself. So yeah I can reconfigure my router, my boyfriends router, my friends router, my works router, my schools router and so forth. But the issue isn't with the routers, it's with the iPad. And a genius tried to give me the whole "it's a router issue" b.s. A while ago. But really, if it is, how comes my boyfriends iPad has never had a wifi issue on his network, but I have issues on his network. And how come when he's at my house he doesn't have a single issue on my network, but I still do? Simple answer, the routers aren't the problem.
  10. fishepa macrumors regular

    Mar 9, 2009
  11. Blorzoga macrumors 68030


    May 21, 2010
    Screen brightness

    I originally had the problem because I was using the stock fios wireless router that came with the install. When my connection was lost, I would go to settings, screen brightness, slide the brightness up and down a few times and voilà, it reconnected..Never had to reenter my password. Strange but true. I've since switched to my old linksys router and haven't had a problem since.
  12. Wifiuser thread starter macrumors newbie

    May 26, 2010
    The issue that I have been dealing with is only on secure networks, not unsecured networks. Starbucks is unsecured as well as airports, Tmobile hotspots, Qwest hotspots, AT&T hotspots. If anyone is having this issue on unsecured networks, sorry this doesn't work for you. All the threads I have read are related to secured networks. I have never claimed to be an Apple tech and that I have reprogramed the wireless network card within the iPad because that is Apples job, all I found was a fix for the problem. This isn't something that just worked for me. In all the threads everyone who found something that worked for them, shared it with others that had the same problem, that's what these forums are for to help each other work through and talk about their individual problems to find a fix. I decided to share what worked and I am getting unwaranted heavy sarcasm. So why hassle someone who is trying to help. If you don't want to try, then don't! For those that do, great. Please let me know how & if it worked for you.
  13. Wifiuser thread starter macrumors newbie

    May 26, 2010
    I agree there is a problem with the internal bios with the wireless adaptor inside the iPad. Apple needs to fix that ASAP. But I would like to give an example. "Microsoft comes out with a new OS. Developers/Manufacturers need to modify their software to work with the new OS right? My fix is the same thing. It's all about adapting to our new environment. Are we just gonna sit here and wait for Apple to come out with a fix, or our we going to be proactive and do something to make it work. I feel sorry for everyone who just wants to sit on their backside and keep complaining when it is within their power to at least make their own situation a little easier. This comment is not directed towards you as seem willing to try. This is just directed to the others who are trying to belittle my helping hand. Thanks for your comments. I encourage them so I might be able to tailor my fix to be more precise.
  14. mpuck972 macrumors 6502


    Aug 31, 2007
    Seems like it would be easier for Apple to fix their screwed up firmware.
  15. JulianL macrumors 65816

    Feb 2, 2010
    London, UK
    I've got horrible WiFi issues. My iPad was delivered a few hours ago and already I've lost network connection about 5 or 6 times. At first I thought it was a DHCP issue because whenever I lost connection I found that doing a renew lease fixed it so I tried switching to static IP but I still got disconnects so I've gone back to DHCP and just renew the lease every 15 or 20 minutes when I need to get connectivity back. I'm sure Apple will release a fix in the not too distant future.

    - Julian

    (Sent from my iPad - yay!!!!)
  16. Dodgeroo macrumors regular

    Mar 28, 2010
    Whilst waiting for my iPad I made sure my router was set to WPA2, channel 11.

    It arrived today, connected first time, full signal, and has been fine since, sleeping & waking fine. My router's a linksys WRT54G by the way.

    Thanks for the guide though, let's hope it helps someone!
  17. Blorzoga macrumors 68030


    May 21, 2010
    Try sliding the screen brightness up and down a few times when you disconnect. It should reconnect. Don't know why, but it worked for me.
  18. Noumenon macrumors regular

    Jun 30, 2007
    Unless your wearing a hat, in which case that does not work.
  19. PCClone macrumors 6502a

    Feb 26, 2010
  20. Wifiuser thread starter macrumors newbie

    May 26, 2010
    Or 4G? LOL I use a 4G wireless router and it works beautifully. It used to loose connection every 2-3 min before I ran my fix for it. Now it stays connected and has yet to disconnect.;););)
  21. Aduntu macrumors 6502a


    Mar 29, 2010
    You should really stop calling it a "fix." Many people have been adjusting the same settings on their routers since day one and still have issues. Lumping all the methods that have been used so far into a single post doesn't constitute a fix.
  22. Wifiuser thread starter macrumors newbie

    May 26, 2010
    Do you have the wifi issue?
  23. lionheartednyhc macrumors 65816


    Jul 13, 2009
    I just exchanged mine for a MBP and never had a problem since :cool:
  24. Aduntu macrumors 6502a


    Mar 29, 2010
    Nope. But I've dedicated a fair share of my time both on here, and in person, to those with the problems. I'm completely aware of the issues.
  25. 0101001 macrumors 6502

    Apr 3, 2010
    Works perfect for me too.

Share This Page