Areca1800 ix-16 + OWC Ext Pro RE SSD, Benches

Discussion in 'Mac Pro' started by JulianBoolean, Mar 9, 2011.

  1. JulianBoolean, Mar 9, 2011
    Last edited: Mar 9, 2011

    JulianBoolean macrumors regular

    Joined:
    Aug 14, 2010
    #1
    Hey,

    1. Good news from the Guinea pig :) I've been away for a while, don't know if this is old news by now but the new Areca raid cards are handling this particular brand of SSDs really nicely, far better than expected in fact. I took a bit of a risk, as at the time of purchase, no information was available regarding the compatibility of the OWC raid edition SSDs and the Areca 1800 raid card.

    2. The whole setup is posted below, It's one of 5 seats in high end retouching studio. File sizes tend to be quite large. 6Gb, two hundred layer images are not uncommon, hence the choice for more ram slots instead of the faster clock speed of the 6 core. Our initial testing is done, had a whole bunch of photoshop crashes, until disabling open GL, but non since. It's been performing really well 8-10 hours per day for several weeks. We are about build out 3 more.

    3. At first I could not understand why the write times, and especially the read times are so far off the charts. I'm thinking this is the the 4GB Cache upgrade (goes right on the card) rockin hard? If I un check "disable file system cache" on the testing software, the write times increase a bit, and the read times go WAY up.

    4. Critics will note there is 8Tb working space and 4TB of back up space. The 4x 2TB drives in the internal bays are an after thought to the 1TB drives originally planned. I don't like my guys keeping too much work on the local drives (as opposed the studio server) as it makes global file management difficult, and full drives are slow drives.


    5. Thanks to everybody who helped me plot this out on paper, especially a big shout out to Nanofrog and Honomaui. You guys stuck with me till every last question was asked and answered.



    Mac Pro 12 Core, 2.93 GHz

    • 64GB SDRAM

    • ATI Radeon 5870 Graphics Card

    • APC Smart-UPS


    [..] ------------


    RAID Card

    • Areca Raid Card, Model ARC-1800 ix-16

    • 4GB Cache Upgrade

    • Battery BackUp Module


    [..] ------------


    Lower Optical Bay : Boot, Apps & Scratch

    • 1x 240GB OWC Mercury Extreme Pro SSD (OS + Apps)
    • Connected To The ICH

    • 3x 200GB OWC OWC Mercury Extreme Pro RE SSD (Scratch)
    • Connected To The RAID Card (RAID 0)

    • MaxConnect 8x - 2.5 inch Disk Drives Mounting Assembly

    • Nippon Labs SATA to Molex Power Adapter


    [..] ------------


    Internal Drives : Bays 1-4 Working Jobs

    • 4x 2TB Western Digital RE3 (RAID5)

    • MaxConnect SAS/SATA BackPlane Attachment
    • Connects the 4 internal HDs to the Areca RAID Card.


    [..] ------------


    4x 1TB External Back Up

    • OWC Mercury Elite-AlPro, Qx2 (RAID 5)

    • MaxPower 6G PCIe 2.0 RAID Controller Card

    • Remember to run this external BU thru the UPS too.


    [..] ------------


    Thanks again,

    Julian
     

    Attached Files:

  2. philipma1957, Mar 10, 2011
    Last edited: Mar 10, 2011

    philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #2
    try testing with a 4gb file and 1920 x 1080 10 bit with disable file system cache checked. my test shows a pair of western digital 3tb hdds in a 6tb raid
     

    Attached Files:

  3. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #3
    Glad to see it got you and your company to do this... :D:D:D. ;) :p

    As per the listed figures, Yes, it's a result of the cache. Disable the cache, and push the file sizes up, and see what happens. The numbers will still be decent, and it show what the disks themselves are actually capable of on their own.

    But the cache is really nice to have, and frees up system resources quicker - there's some involvement system wise, as data has to be transferred from system memory over the PCIe bus to the card (disks will continue to write after the file was sent to the card, and stored in the cache). System memory to cache, then to disk is what's really happening here, rather than have to sit in system memory longer while the disks complete the entire write.
     
  4. JulianBoolean, Mar 11, 2011
    Last edited: Mar 11, 2011

    JulianBoolean thread starter macrumors regular

    Joined:
    Aug 14, 2010
    #4
    Okay,

    Here is the requested testing, (system cache disabled, and larger test files) still really curious as to why the read speeds are way low and the write speeds are way high. 3 SSDs R0 should be just south of 750 Mb/s. FWIW in my work flow, write speeds are way more important than reads speeds, but still curious.
     

    Attached Files:

  5. Honumaui macrumors 6502a

    Joined:
    Apr 18, 2008
    #5
    hey :) glad to see it all going and such

    been busy with kids and life and retouching :) ahhh the fun

    cant wait to hear some real world feefback how the thing is helping etc.. and what other think in the company of the bump if it was worth it for those large files :)
     
  6. cutterman macrumors regular

    Joined:
    Apr 27, 2010
    #6
    Try 8GB or 16GB file size for more realistic measurements. The Areca's cache is still artificially increasing the write speed.

    FWIW, based on my own use of this benchmark, I am not sure that it accurately measures pure sequential disk throughput. It seems to provide numbers lower than other benchmark programs (like HDtach). I wonder if the data buffer is small to simulate reading and writing of video frames.
     
  7. nanofrog, Mar 11, 2011
    Last edited: Mar 11, 2011

    nanofrog macrumors G4

    Joined:
    May 6, 2008
    #7
    It was to show you how the cache influences the performance for the same test (identical parameters otherwise, such as frame size).

    In this particular test, it's still not 100% as the file sizes differed between this round and the previous the tests (1st run = 1GB, 2nd run = 4GB). But it's not really necessary to re-perform either (run them at the same file size; cache enabled/disabled respectively) to show the performance increase generated by that large a cache.

    As per what's going on, I think cutterman's on the right track (algorithm is based on video, and given the really high write figures, it seems the card's cache is still functioning for this particular measurement; Disable Cache = disk cache). The card's cache is only used for writes, not reads, and isn't disabled via a SATA command, so it's still active.

    You could pull the 4GB DIMM from the card, and give that a run (not tried this, so I can't say for sure if it would even operate without a DIMM). But it would be one certain way to get cache out of the loop for a test run. ;)
     

Share This Page