Resolved ATV3 NIGHTMARE: Showing only Computers and Settings

Discussion in 'Apple TV and Home Theater' started by mortonapple, May 2, 2014.

  1. mortonapple, May 2, 2014
    Last edited: May 13, 2014

    mortonapple macrumors newbie

    Joined:
    May 2, 2014
    #1
    I have been fighting my ATV (3. gen) for over a week. Google search reveals that this is a common problem, but none of the suggested solutions have worked for me.

    My Apple TV shows only Computers and Settings in the home menu. I updated to the latest firmware a while ago, and it worked flawlessly for several weeks. Suddenly one day I only got Computers and Settings.

    I have tried the following (nothing has worked):
    • Restoring Apple TV through WiFi
    • Restoring Apple TV through ethernet cable
    • Restoring Apple TV through USB-cable in latest iTunes version on both Win7 PC and MacBook running Mavericks
    • Using both automatic and manual IP-settings on both WiFi and ethernet
    • Setting DNS to 8.8.8.8
    • Using different routers
    • Tried changing regional settings to both USA and my home country
    • Connecting my iPhone after a restore to transfer network setup via Bluetooth
    • Doing system resets with the remote
    • Doing system resets by selecting Settings --> General --> Reset
    • Doing system resets by unplugging all the cables for over 5 minutes
    • Resetting my modem, router and switch
    • Let the ATV go to screensaver and then wake it up
    • I have tried the suggested solution to change the iTunes store loaction, but the list is blank
    • Confirmed that my ISP and router have the required ports open (http://support.apple.com/kb/ht2463)

    Other symptoms:
    • AirPlay works fine and normal
    • Internet connection works, since I can update to the latest firmware (both WiFi and ethernet)
    • ATV can't update time and date automatically (get the spinner icon trying to connect)
    • Home Sharing won't connect (get error that Apple ID can't be found)
    • Connecting to iCloud on ATV sometimes works
    • Other devices on the same network works perfectly

    THE SOLUTION:
    I did the two following things, not sure what fixed my problem:
    • Moving the ATV away from other items on my setup, such as reciever, router/modem, Blu-Ray etc. in case of some interference
    • Connected the ATV to another ISP (use friend, neighbor etc.) and it worked as normal, then connected it back to my own ISP
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    This is what you'll see if the Apple TV doesn't have an internet connection. Does it have an IP address? Have you tried restarting your router/modem or both?
     
  3. mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #3
    Yes, as described in my original post. I have a working IP, and I have tried resetting everything. :-(
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    Oops, I missed that. How about a different DNS?
    It may just be broken.
     
  5. mortonapple, May 2, 2014
    Last edited: May 2, 2014

    mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #5
    It seems I have 3 DNS addresses. Tried all 3 with manual IP-settings. Not working. :(

    EDIT: To clearify, the DNS addresses are working, but changing them doesn't fix my problem.
     
  6. westrock2000 macrumors 6502

    Joined:
    Oct 18, 2013
    #6
    Are you using the DNS supplied by your ISP?

    Try 8.8.8.8 and see if that helps. I had a similar problem

    http://forums.macrumors.com/showthread.php?t=1701033
     
  7. mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #7
    Thank you. Looks like we had a similar problem. Air play works fine, but I can't connect to iTunes and the ATV freezes on the spinner icon when trying to set date and time.

    I tried to change the DNS to 8.8.8.8, but unfortunately it didn't work.


    I have also tried changing router setup and settings, different routers and I have also been in contact with Apple support. They suggest it might be a hardware problem (since I have tried everything there is to try, and the problem appeared out of the blue).

    I'm gonna try setting up the ATV on another ISP. If there is still a problem, I'm gonna try replacing the ATV in as a guarantee case, or simply buy a new one.
     
  8. mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #8
    UPDATE:
    I have now tested on another ISP. To my surprise, the ATV worked just fine. That means I can exclude hardware problem, and it seems it has something to do with my network settings at home.

    Strange thing is, i have an iPhone, iPad, Mac mini and a Samsung smart TV – all connected to the same network, and everything works just fine except the ATV.
     
  9. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #9
    Possibly a config issue on your router, or with ISP port blocking. http://support.apple.com/kb/ht2463 shows the ports used; but there's really nothing unusual there - the only Internet communication ports should be 53, 80, 123, and 443 and it's unlikely any of those would be blocked. 3689 and 5353 are only used within your local network, not over Internet. See if resetting your router clears something up?
     
  10. stocklen macrumors member

    Joined:
    Sep 25, 2013
    #10
    OP, I had a similar problem.

    My AppleTV was working fine, then stopped. Similar symptoms to how you describe. Connection fine, IP address fine, but little to no connectivity to internet or streaming.

    Took it back to apple, paid money to get it replace out of warranty. Got home to find it still wasn't working (similar to you proving it worked elsewhere and not at home).

    I discovered that it was all down to proximity to my new Xbox one. I had it on the shelf right next to the xbox at the far right rear. There was something strange there causing some considerable interference and erratic behaviour from the AppleTV.

    I moved the appleTV to the left hand side of the Xbox, and as far away as I could get it (only about 5 cms away) and this was sufficient to get it all working again.

    So, have you moved it at home recently or introduced a new item nearby? It might well be down to some kind of interference. Mine certainly was.
     
  11. mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #11
    Thank you for sharing link.

    Yes, I have previously been in contact with my ISP. They don't block any of these ports, and I have logged in to my router to check, but nothing should be blocked.

    I have restarted my router several times, but will try again once I get home from work.

    This problem is driving me insane. Especially since I use the tiny remote to enter my Apple ID and passwords over 9000 times (Remote App doesn't work without Home sharing).

    ----------

    Wait, what?! I have not been moving around any objects before or after my problem appeared. But when you mention it, I do have all my stuff stacked in one shelf (modem/router, Airport Express, ATV, TV-reciever, a Samsung Blu-Ray and TV on the shelf above).

    If THIS is the solution, I don't know what to believe anymore. But fingers crossed, I will try this once I get home! :-D
     
  12. stocklen macrumors member

    Joined:
    Sep 25, 2013
    #12

    Well, all I can tell you is that I had no problems before (even with Xbox one present), then I re-organised my AV equipment on a new stand. From that moment I had the similar problems to you. Its only after going through all the pain of troubleshooting and changing the appleTV, that I realised what the problem was.

    Not saying its your issue, as if it worked before, and you haven't moved anything it should still work unless you have introduced something new or moved things.

    I would CERTAINLY recommend moving it away from the other things as a test and see if the proximity fixes the problem.

    Best of luck let us know how it goes.
     
  13. grockk macrumors 6502

    grockk

    Joined:
    Mar 16, 2006
    #13
    I've had a similar issue with Apple TV and an LG bluray player.
     
  14. mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #14
    Guys, you know what? I got my ATV to work! I feel both enraged and a sense of sweet relief! Thank you for all the input.

    Good thing I didn't buy a new ATV. I did the two following things:
    • Tried to move my ATV away (as far as the HDMI cable would allow) from other items on the shelf
    • Connected the ATV on another ISP, and got it to function normally, before I connected it again to my own ISP

    I don't know what of these two things that fixed my ATV. It seems somehow by connecting it to another ISP it flushed away the problems i experienced. Or maybe it was the interference by the other devices. But I have placed the ATV back in the shelf among the other items (Airport Express, tuner, reciever, router), and I have no problem now.

    I will update my OP in case others have the same problem. Thank you! :)
     
  15. imac wannabe macrumors regular

    Joined:
    Sep 1, 2011
    Location:
    Appleton, WI
    #15
    Great news! Thanks for taking the time to fill us in as well as those in the future who may encounter this##.

    Paul

     
  16. mortonapple thread starter macrumors newbie

    Joined:
    May 2, 2014
    #16
    That's the same answer I got from Apple support. Turned out not to be true(!).

    If you have tried everything on my list, did you also try my solution: Set up the ATV on a different ISP?

    You should seriously give it a try. You might be surprised! :)

     
  17. locust76 macrumors 6502a

    Joined:
    Jan 23, 2009
    #17
    Maybe you have an IPv6 internet connection at home and your friend has IPv4?

    I have both at home (Dual Stack), and my Apple TV doesn't seem to work with IPv6.
     
  18. rritterson macrumors 6502

    Joined:
    Jul 10, 2008
    Location:
    DC USA
    #18
    I was going to suggest this as I read the thread. IPv6 support in some routers is extraordinarily flaky, yet ATVs seem to prefer IPv6 over 4 if given the opportunity. Several years ago, I used to have connection drops every hour or so until I disabled IPv6. Currently, it has worked just fine but I'm on a different router.
     
  19. locust76 macrumors 6502a

    Joined:
    Jan 23, 2009
    #19
    Really? My ATV (gen 3) doesn't even pick up an IPv6 address (and I can't even manually configure one), while everything else on my network picks up IPv6 addresses just fine (I run SLAAC and DHCPv6), and iTunes on my PC won't ever find the ATV via AirPlay because I have IPv6 enabled.
     
  20. rritterson, Jun 3, 2014
    Last edited: Jun 3, 2014

    rritterson macrumors 6502

    Joined:
    Jul 10, 2008
    Location:
    DC USA
    #20
    Apple makes it hard to determine the IPv6 addresses of ATVs and hard to determine the mac addresses of known IPv6 hosts via Airport Utility.

    But, when I enable the ATV as an airplay speaker, I see IPv6 connections on the daap port using netstat on the mac, which leads me to believe it is IPv6 enabled and prefers it as a protocol.
     

Share This Page