Audio stuttering problem in El Capitan while using built-in video camera

Discussion in 'MacBook Pro' started by mjwalkermusic, Feb 25, 2016.

  1. mjwalkermusic macrumors newbie

    Joined:
    Dec 16, 2015
    Location:
    Windermere, FL
    #1
    Hi, I've been using my new MacBook Pro 15-inch 2015 model to Livestream and perform music over the internet.


    Unfortunately, I've been having issues with the audio crackling. At first, I thought it was something specific to Wirecast, the application I use.


    But the same problem also happens when I open "Photo Booth" while making music.


    I use Ableton Live to record / play live. It works fantastic on its own. It's only when I open up an application that uses the built-in camera that the audio starts to stutter. Any ideas for solutions?


    I'm using the latest version of El Capitan. I've also tried deselecting "App Nap" for Ableton Live, but the issue still happens.

    Thanks,


    Michael
     
  2. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #2
    Sounds like you're hitting a CPU limit. Open up Activity Monitor when you're doing it and see what happens when you open Photo Booth at the same time as playing music. See if the stuttering coincides with periods of very high CPU use.
     
  3. mjwalkermusic thread starter macrumors newbie

    Joined:
    Dec 16, 2015
    Location:
    Windermere, FL
    #3
    Thanks for your response, Joe. After opening up Activity Monitor and viewing the history, the CPU still has plenty of room when it crackles. Any ideas?

    When I increase the buffering size in Ableton, it reduces the problem, but then there's too much latency to perform the music well. Theoretically, the Macbook Pro should be more than powerful enough to handle this. My old 2010 Macbook Pro was able to, and this one is WAY better.
     

Share This Page