Auto contrast - is this a new thing in Sierra?

Discussion in 'macOS Sierra (10.12)' started by Toutou, Oct 3, 2016.

  1. Toutou macrumors 6502a

    Toutou

    Joined:
    Jan 6, 2015
    Location:
    Prague, Czech Republic
    #1
    A few days after I had upgraded to Sierra I noticed my rMBP's screen looks a little washed out when dimmed. I've always kept it on lower brightness when possible, as my eyes can get a little sensitive, so I'm pretty sure this is a new thing.
    When the display is dimmed, the OS seems to be trying to counter that by lowering the contrast, so the darkest parts don't get too dark. After you quickly turn the brighness all the way up, the contrast gradually returns to normal, over five or six seconds.
    Also, this behavior goes away with automatic brightness disabled.

    So, is this a new thing? If not, how long has it been there?
     
  2. SuperHamster macrumors member

    SuperHamster

    Joined:
    Nov 18, 2015
    Location:
    Cambridge
    #2
    I noticed the same thing since the Sierra upgrade, was wondering if it was time to get a new eye examination.
     
  3. Toutou thread starter macrumors 6502a

    Toutou

    Joined:
    Jan 6, 2015
    Location:
    Prague, Czech Republic
    #3
    I don't get it. How am I supposed to do any color sensitive work if they're ****ing with my contrast without even telling a word?
     
  4. Eduardboon macrumors 6502

    Joined:
    Jul 17, 2012
    #4
    Having the same issue on a 2016 Macbook Pro. It's incredibly annoying. In El Capitan you could turn this off by toggling "Ambient Light Compensation" but on Sierra there is no such option, it is coupled with automatic brightness. It sucks and makes things incredibly dull and gray, especially on lower brightness settings.

    I tend to work on photographs and this really messes with everything. When I create a "perfect" image it looks way too dark on a normal screen because my mac found it necessary to wash out the colors. Especially noticeable with the colourful touchbar right underneath the gray screen.
     
  5. Toutou thread starter macrumors 6502a

    Toutou

    Joined:
    Jan 6, 2015
    Location:
    Prague, Czech Republic
    #5
    I just disabled automatic brightness. No regrets btw, I don't miss it at all.
     
  6. Reality4711 macrumors 6502

    Reality4711

    Joined:
    Aug 8, 2009
    Location:
    scotland
    #6
    Thank you for that. It has been gently bugging me without me realising it.
     

Share This Page