iPad mini Automatic contrast ruins my iPad Mini 4

Discussion in 'iPad' started by WashupDawg, May 10, 2016.

  1. WashupDawg macrumors regular

    Joined:
    May 26, 2010
    #1
    Hello

    I was very happy with my iPad Mini 4 until I discovered the terrible effects of iOS automatic contrast adjustment. This is not the same as brightness.

    The problem is that the contrast is adjusted on the fly, making the screen's black levels adjust all the time. It is extremely irritating in full screen mode with dark scenes where you have subtitles that pop up from time to time. My only solution right is to NOT use full screen. Because when you have something that is white (such as in Youtube comment section or Twitch chat), the contrast will not fluctuate to same extent.

    Can automatic contrast be disabled if I jailbreak the device?

    It's monumental shame that this software feature completely ruins a great display for video playback...
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    You must be referring to one of two things.

    Auto brightness. Or nightshift.

    The mini 4 did not get a true tone display so it can't be that.

    Auto brightness can be turned off in settings > display & brightness.

    Nightshift is I the same settings.
     
  3. WashupDawg thread starter macrumors regular

    Joined:
    May 26, 2010
    #3
    The automatic contrast has nothing to do with brightness, True Tone or Nightshift. I don't even use automatic brightness.

    The effect is that the software automatically adjust contrast when depending on what you view. When you have a lot of black on the screen, the screen will dim slightly. When you have a lot of white, the screen will light up slightly.

    So when you have a dark scene in a video and suddenly a white subtitle pop up, the black level will suddenly light up in a distracting way.
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    Sounds like you have one of the accessibility features enabled then because by default iOS does not do that
     
  5. maclancer macrumors regular

    Joined:
    Jun 13, 2008
    Location:
    Philadelphia, PA
    #5
    You are correct... I have the iPad mini 3 and I do not have the issue he is referring too. It's definitely an accessibility setting on.
     
  6. WashupDawg thread starter macrumors regular

    Joined:
    May 26, 2010
    #6
    And which specific feature could that be?
     
  7. journeyy macrumors regular

    Joined:
    Sep 11, 2013
    #7
    Most people don't notice it. but it's there. It annoys me on my Mini 2. The contrast is being adjusted in dark scenes when watching videos
     
  8. silverblack macrumors 68030

    silverblack

    Joined:
    Nov 27, 2007
    #8
    General -> Increase contrast -> turn all 3 settings OFF
     
  9. Skika, May 10, 2016
    Last edited: May 10, 2016

    Skika macrumors 68030

    Joined:
    Mar 11, 2009
    #9
  10. kameradhund macrumors newbie

    Joined:
    Sep 16, 2014
    #10

    i have the same problem and there is nothing one can do about. the only thing that helps a little bit is to turn on (!) assistive touch. i read about this somewhere and tried it. the automatic contrast adjustment is gone BUT you will have the virtual home button always distracting you instead. so: one problem gone, another problem there haha. but try it for your self please.
     
  11. Ffosse macrumors 65816

    Joined:
    Nov 5, 2012
    #11
    I always set my brightness manually on the iPad Mini 4.

    And nightshift is pointless in the Summer with 6 hours of permanent twilight (during which I'm asleep).
     
  12. iOSUser7 macrumors 6502a

    iOSUser7

    Joined:
    Jun 23, 2014
    #12
    It's not Night Shift, auto-brightness, accessibility or anything like that, we all have this feature it's built in every iOS versions (since iOS 7 I believe). Some people just don't notice it, some others does. Personally, even if I notice it every time it happen, it never bothered me at all.

    But anyway, OP I don't think you can disable it and I'm not sure someone even bothered to make a jailbreak tweak to disable that feature. Though, you could probably disable it by jailbreaking and tweaking yourself the OS, if you have some knowledge.
     
  13. ZEEN0j macrumors 65816

    ZEEN0j

    Joined:
    Sep 29, 2014
    #13
    I find this on my 6 and air 2. I don't notice it all the time and it's worse in some videos than others. Best way to test is a dark video in any app in full screen. Then go to app switcher and the contrast will be very bright and take maybe a second to readjust.
     
  14. spiderman0616 macrumors 68040

    spiderman0616

    Joined:
    Aug 1, 2010
    #14
    I found this annoying on my iPad mini 3. I haven't noticed that happening on my 9.7" Pro yet.
     
  15. maclancer macrumors regular

    Joined:
    Jun 13, 2008
    Location:
    Philadelphia, PA
    #15
    I have the iPad mini 3 and does not bother me. You just have to set it or turn the thing off.
     
  16. untitledartists macrumors newbie

    Joined:
    Jun 28, 2011
    #16
    I also think there is definitely something going on with a sort of dynamic auto contrast for video playback.
    I never saw this in iPad 3 with ios6, but with an IPad Air 2 (iOS 8/9) it was very visible. Changing from dark scenes to bright scenes and vice versa changed the overal brightness quit noticeable and sometimes even choppy.
    With an iPad Pro 9.7 it is much better. The transitions from automatic contrast adjustments are smooth, but I still visible for my eyes. I do not see it from scene to scene, but overall when playback video.
    I have to say, that I mostly see this behavior with the Netflix app. So it could be possible that only this app is adjusting contrast for video playback. (IMO I saw this also system wide using iOS10)
    For exampe when I watch an Star Trek TNG episode on Netflix, capitan Picards bold head always is too contrasty. The highlights are blown out and are completely white. When I touch the screen that the playback controls become visible the contrast changes immediately and capitan Picards bold head get a smooth gradient of the previously only white highlights. This is the way I think the picture should look like! When the playback controls become invisible again the contrast increases slightly after few seconds and highlights can clip again.
    It is more visible when night shift is on and true tone is enabled. Disabling auto brightness, true tone and night shift and enabling them again helps a bit, but there is still a difference in contrast between fulll screen video playback with or without playback controls.
    So in my opinion the video playback on iOS is slightly with too much contrast.
    I spot blown highlights which should not be blown out quickly, and absolutely hate every dynamic contrast enhancement and image enhancements in all modern TV screens.
    I now nobody cares, 9 from 10 people do not notice what I described on iOS (10), but still I see it all the time....white blobs on Cpt. Picards bold head.....
     
  17. WashupDawg thread starter macrumors regular

    Joined:
    May 26, 2010
    #17
    I will give you points for resurrecting a thread that was last updated on May 28 2016 :D

    I think Apple improved the auto-contrast. It seem a lot less aggressive than it was back in 2016.
     
  18. Jensend macrumors regular

    Joined:
    Dec 19, 2008
    #18
    The auto-contrast is as bad as ever. It may just be a little smoother at switching between different amounts of contrast.

    I can’t believe how infrequently this issue is discussed here. I have to put the stupid assistive touch button on the screen so I don’t have to deal with the blown out highlights.

    I have an iPad Pro 10.5”. They talk about how well calibrated the screen is and how it supports higher color gamut and such, then they ruin it with software tricks.
     
  19. canesalato macrumors 6502a

    canesalato

    Joined:
    Jan 31, 2010
    #19
    It’s horrible and impossible to disable...for some (dumb) reason
     

Share This Page