Automatic login not working?

iBlazed

macrumors 68000
Original poster
Feb 27, 2014
1,593
1,224
New Jersey, United States
For some reason when I go into Login Options and try to enable Automatic login, it won't let me. The drop down menu to toggle between on and off is just greyed out. Any ideas? I hate having to type in my password all the time
 
  • Like
Reactions: rgare2

Dj64Mk7

macrumors 65816
Sep 15, 2013
1,161
322
For some reason when I go into Login Options and try to enable Automatic login, it won't let me. The drop down menu to toggle between on and off is just greyed out. Any ideas? I hate having to type in my password all the time
In the left-hand corner, there is a padlock icon. Click it, and enter your password. You will then be able to change the Automatic login setting.
 

salsachip4

macrumors newbie
Jul 10, 2014
1
0
Automatic Login Fixed

Here was the fix I used.

Under Security & Privacy I changed my login password to something other than my apple ID password.

Then I went back into Users & Groups Login Settings and I was able to enter my auto login password and it was set and ready to go.
 

iBlazed

macrumors 68000
Original poster
Feb 27, 2014
1,593
1,224
New Jersey, United States
Funny, Apple doesn't seem to think it's an issue...
Not sure how being logged into iCloud on my Mac has anything to do with autologin when starting my computer or waking from sleep.

Jason ****08-Jul-2014 10:08 PM

Summary:
When going into User Preferences>Login Options and after unlocking the padlock with my password, the option Automatic Login menu is greyed out and won't let me switch it On. Then, when going into Security and Privacy the "Disable automatic login" checkbox does not even appear. Sometimes a grey box appears in its spot, sometimes nothing at all.

Steps to Reproduce:
No steps, it's always like that. Restart doesn't help.

Expected Results:
Automatic login should be enabled, no password upon boot up.

Actual Results:
Nothing.

Version:
10.10 (14A283o)

Notes:


Configuration:
mid-2013 Macbook Air

Attachments:
'Screenshot 2014-07-08 18.12.46.png' and 'Screenshot 2014-07-08 19.10.45.png' were successfully uploaded.
Apple Developer Relations10-Jul-2014 11:14 AM

Engineering has requested the following information in order to further investigate this issue:

Do you have icloud login enabled ?

Please provide your response or results by updating your bug report.

Please compress any bundled files (e.g. nested folders) prior to uploading.
Jason ****10-Jul-2014 05:45 PM

Yes, I am logged into iCloud in system preferences.
Apple Developer Relations14-Jul-2014 12:07 PM

Engineering has determined that this issue behaves as intended based on the following:

Autologin is not available for iCloud accounts.

We are now closing this bug report.

If you have questions regarding the resolution of this issue, please update your bug report with that information.

Please be sure to regularly check new Apple releases for any updates that might affect this issue.
Jason ***14-Jul-2014 07:44 PM

Not sure what my iCloud account has to do with logging into my Mac at bootup or when awaking from sleep. I always had auto login enabled prior to this.
 

swindlenz

macrumors member
May 18, 2013
57
0
FileVault is on and your mac in encrypted. This is why the option is not there.

http://forums.macrumors.com/showthread.php?t=1746422

Turn off FileVault and it will appear again. If I am following correctly. This happened with an update, and it asked you, and you did it, but you didn't realise what that meant. Like me.

Your mac cannot be allowed to automatically login with FileVault encryption enabled.
 

iBlazed

macrumors 68000
Original poster
Feb 27, 2014
1,593
1,224
New Jersey, United States
FileVault is on and your mac in encrypted. This is why the option is not there.

http://forums.macrumors.com/showthread.php?t=1746422

Turn off FileVault and it will appear again. If I am following correctly. This happened with an update, and it asked you, and you did it, but you didn't realise what that meant. Like me.

Your mac cannot be allowed to automatically login with FileVault encryption enabled.
Ahh this did it! Amazing you were able to tell me this and Apple's developers were not.
 
  • Like
Reactions: Shmooly

iBlazed

macrumors 68000
Original poster
Feb 27, 2014
1,593
1,224
New Jersey, United States
Even with file vault disabled, it still won't auto login when waking from sleep. Apple has reopened the bug report and I'm still going back and forth with them.
 

mmomega

macrumors 68040
Dec 30, 2009
3,220
1,415
DFW, TX
Apple isn't going to tell you to disable a security feature to enable a convenience feature.

Either way, I am trying to figure this out as well.
Auto-Login works fine on my iMac that was upgraded from Mavericks with autologin already enabled.
My MBA is a clean install.
 

mmomega

macrumors 68040
Dec 30, 2009
3,220
1,415
DFW, TX
Ok, I got it to work just now .

Here are the steps I took

From System Preferences -> Security & Privacy -> General
Unlock the Lock in the lower left corner

I had to make sure all 3 options are not ticked, the 1st option, Require Password after sleep or screen saver begins was initially ticked.
I ticked all options and then un ticked them all.

Filevault
FileVault is disabled, but already was

System Preferences -> Users & Groups -> Login Items
I disabled automatic login and re-enabled it and entered the account password password

Clicked the lock to make changes, restarted and it auto-login worked.

**What the devs were asking was if you were using your iCloud account information to sign in to your computer. This is a new option.**
 

Attachments

Last edited:
  • Like
Reactions: Rahrooma

ABC5S

Suspended
Sep 10, 2013
3,395
1,597
Florida
Found a easier way if one is using your iCloud passcode as your log in passcode. Yosemite doesn't like this, and I had to change my log in passcode to something different than my iCloud. Easy to do..

Security and Privacy > General > Change Password > Now just change the password other than your iCloud password, but remember the second one. Now you can uncheck disable auto log in....
 

Attachments

viizi

macrumors regular
Dec 2, 2010
226
68
Found a easier way if one is using your iCloud passcode as your log in passcode. Yosemite doesn't like this, and I had to change my log in passcode to something different than my iCloud. Easy to do..

Security and Privacy > General > Change Password > Now just change the password other than your iCloud password, but remember the second one. Now you can uncheck disable auto log in....
worked, thanks
 

g8keeper22

macrumors newbie
Oct 26, 2014
1
0
I was having the exact same problem. Changing my user password to something OTHER than my iCloud account password cleared everything up. Annoying, but at least it works. THANKS!
 

madisongeeks

macrumors newbie
Feb 22, 2015
1
0
we see this issue frequently when setting up new macs. one of the most common reason we see it greyed out, is because the user has no password set for their user account.

and of course, most unix / linux system frown on this. so before you can do other options, like auto login... set a password. even if it needs to be simple. (say for grandma, etc)

:cool:
 

Matty B

macrumors newbie
Apr 1, 2015
1
0
Automatic Log In

@ System Preferences / User Groups - I found this when searching the "question marks" (bottom R corner)

"When FileVault is enabled, automatic login is disabled".

I gather that's why it's greyed out, as it was on my Macbook Air.

Read the "question mark" @System Preferences / Security & Privacy / Fire Vault. I suggest you read this carefully and decide if disabling Fire Vault is right for you.

Cheers,

Matt
 

Hugh Jas

macrumors newbie
Aug 30, 2016
1
0
I confirm that the below fix works: basically MacOS doesn't let you use automatic login as long as your login password is the same as your iCloud password, so as long as you choose a separate password for the MacOS login, you can do any changes you want (eg. Automatic login will be available).

Automatic Login Fixed

Here was the fix I used.

Under Security & Privacy I changed my login password to something other than my apple ID password.

Then I went back into Users & Groups Login Settings and I was able to enter my auto login password and it was set and ready to go.