Automatic login not working?

Shmooly

macrumors newbie
Dec 25, 2016
1
0
I confirm that the below fix works: basically MacOS doesn't let you use automatic login as long as your login password is the same as your iCloud password, so as long as you choose a separate password for the MacOS login, you can do any changes you want (eg. Automatic login will be available).
I actually tried that and it still didn't work. I finally had to turn off File Vault ("decrypt" my data, which seems kinda scary), and then, FINALLY, I can choose an account for automatic login. Crazy.
 

Sykopig

macrumors newbie
Nov 18, 2019
1
0
For some reason when I go into Login Options and try to enable Automatic login, it won't let me. The drop down menu to toggle between on and off is just greyed out. Any ideas? I hate having to type in my password all the time
what worked for me is I unchecked disable automatic login then checked it back on again it asked me for password again then it was working again.