AW waking me up before alarm because it's time to stand up?

Discussion in 'Apple Watch' started by BlankStar, Jul 12, 2018.

  1. BlankStar macrumors 6502a

    BlankStar

    Joined:
    Aug 13, 2004
    Location:
    Belgium
    #1
    AW Series 0 with latest WatchOS installed. iPhone X with iOS 12 Developer Beta 3.

    So I've been using the bedtime feature since iOS 12 and usually wake up at 0630Hr but yesterday I went to bed later and set bedtime to wake me up at 0700Hr so I could sleep 30 minutes longer.
    At 0650Hr my Apple Watch woke me because it was time to stand up for my circle. It stole ten minutes of precious sleep from me!

    Normally the Apple Watch copies the DND-status of the iPhone, but bedtime is a different kind of DND than the regular one.

    Now the question: do people with WatchOS Beta 5 (and thus newer Apple Watch than mine) have had this behavior? Or does the WatchOS 5 respect the "new" DND-mode?
     
  2. Lennyvalentin macrumors 65816

    Lennyvalentin

    Joined:
    Apr 25, 2011
    #2
    I've had kind of the opposite problem - because I've set auto-DND to engage before I usually go to bed, I don't get the bedtime reminder on my wrist. This is an irritating sort of first-world catch-22... :) My non-optimal solution was to move the time DND engages ahead sufficiently so that my bedtime reminder will go through, but that meant that notifications for messages and emails and whatnot ring and ding through speakers of my iDevices until after midnight, which is bad if I go to bed earlier than usual, as I might wake up again and have my sleep disturbed.
     
  3. Newtons Apple macrumors Core

    Newtons Apple

    Joined:
    Mar 12, 2014
    Location:
    Jacksonville, Florida
    #3
    I put mine on the charger while sleeping and it never makes a peep!
     
  4. DNAppleGold macrumors 6502

    Joined:
    Apr 9, 2009
    #4
    Did you ever get a useful reply or figure out a solution. I have the same problem
     
  5. BlankStar thread starter macrumors 6502a

    BlankStar

    Joined:
    Aug 13, 2004
    Location:
    Belgium
    #5
    Nope, but I haven't had it since then. Got me a Series 4 now, so on WatchOS 5.

    I turn on theater mode now before I go to bed so it doesn't light up when I fight out WW3 in my dreams :)
     
  6. matrix07 macrumors 601

    matrix07

    Joined:
    Jun 24, 2010
    #6
    Must be a bug. It’s beta after all. I don’t have this behavior on my S3 with OS5.
     
  7. BlankStar thread starter macrumors 6502a

    BlankStar

    Joined:
    Aug 13, 2004
    Location:
    Belgium
    #7
    Had this on WatchOS4 non-beta and was asking if people with 5.0 beta had it ;-)
     
  8. Jason Honer Suspended

    Jason Honer

    Joined:
    Aug 13, 2018
    Location:
    Boston MA
    #8
    Use theatre mode.
     
  9. BlankStar thread starter macrumors 6502a

    BlankStar

    Joined:
    Aug 13, 2004
    Location:
    Belgium
    #9
    Someone didn't read the thread before replying ;-)

    But it's a good suggesting, since I'm already using it :)
     
  10. Banglazed macrumors demi-god

    Banglazed

    Joined:
    Apr 17, 2017
    Location:
    Cupertino, CA
    #10
    I normally put mines on DND and theater mode so I will not get any vibration or any bright light when I am trying to sleep.
     

Share This Page

9 July 12, 2018