Bad Picture Stuttering on Apple TV4K...I'm losing my mind here!

billiam86

macrumors newbie
Original poster
Sep 25, 2017
7
2
Hey everyone,

New to the forum, so hopefully I'm in the right place!

A little setup: I got my Apple TV 4K on Friday. Previously I was using 3rd generation Apple TVs in the living room and my office, and have a 4th generation in the bedroom. The only 4k TVs in the house are in the living room and my office, however the newer TV is in my office and has HDR while the living room doesn't. That being said, I still wanted to put the new 4k Apple TV in the living room.

So I hooked it up to my Vizio in the living room (Vizio d58u-d3) and it defaulted to 4K SDR 60hz. Great! Everything was running fine...until I started to play HD movie files (mp4s) from the computer home sharing app (which is the reason why I have Apple TVs in every room so that our movies can go throughout the apartment). The movies were choppy for lack of a better term. I must have changed the video to every possible setting and while having it at 4K SDR 24hz helped with the movies, that meant that things on Netflix, MLB Network and WWE Network now were all coming in at what looked like 24fps.

I never had any issues with my old Apple TVs being able to handle the HD movies and things like MLB Network and WWE Network without getting choppy and showing each in their appropriate frame rate. What am I doing wrong here? Do I need better HDMI cables? Am I just screwed? I tried turning on the film mode but that didn't seem to fix the problem.

One last bit of information: I moved the 4K Apple TV to the newer Vizio in my office (Vizio E55-E2) and it defaulted to 4K HDR 60hz and I didn't have this issue at all. I even tried putting the 4th generation 1080p Apple TV in the living room and while that one says 1080p 60hz, again, I didn't have this issue at all. Does the Apple TV 4K just not play well with my living room Vizio? Any suggestions or help would be greatly appreciated. Thanks!
 

Poontaco

macrumors regular
Feb 2, 2014
239
154
Hey everyone,

New to the forum, so hopefully I'm in the right place!

A little setup: I got my Apple TV 4K on Friday. Previously I was using 3rd generation Apple TVs in the living room and my office, and have a 4th generation in the bedroom. The only 4k TVs in the house are in the living room and my office, however the newer TV is in my office and has HDR while the living room doesn't. That being said, I still wanted to put the new 4k Apple TV in the living room.

So I hooked it up to my Vizio in the living room (Vizio d58u-d3) and it defaulted to 4K SDR 60hz. Great! Everything was running fine...until I started to play HD movie files (mp4s) from the computer home sharing app (which is the reason why I have Apple TVs in every room so that our movies can go throughout the apartment). The movies were choppy for lack of a better term. I must have changed the video to every possible setting and while having it at 4K SDR 24hz helped with the movies, that meant that things on Netflix, MLB Network and WWE Network now were all coming in at what looked like 24fps.

I never had any issues with my old Apple TVs being able to handle the HD movies and things like MLB Network and WWE Network without getting choppy and showing each in their appropriate frame rate. What am I doing wrong here? Do I need better HDMI cables? Am I just screwed? I tried turning on the film mode but that didn't seem to fix the problem.

One last bit of information: I moved the 4K Apple TV to the newer Vizio in my office (Vizio E55-E2) and it defaulted to 4K HDR 60hz and I didn't have this issue at all. I even tried putting the 4th generation 1080p Apple TV in the living room and while that one says 1080p 60hz, again, I didn't have this issue at all. Does the Apple TV 4K just not play well with my living room Vizio? Any suggestions or help would be greatly appreciated. Thanks!
It sounds like either your TV or HDMI cable don't like 4K at 60hz.
Obviously, I would try another cable to rule it out. After that, I'm not sure.
Have you run the cable checker/tester on the Apple TV?
Have you double-checked all of your TV's settings?
Do you need to be connected to the HDMI 1 input?
 

billiam86

macrumors newbie
Original poster
Sep 25, 2017
7
2
I ran the cable checker and it didn't appear to be any problems, but I ordered a new HDMI highspeed cable just to be sure. Should be here today.

I'm not sure what other settings on the TV could be affecting it, especially since it's never had a problem before.

As far as the HDMI input, for this particular TV (Vizio d58u-d3) I think the only way it will work is through the HDMI 5 port which I have it plugged in to
 

Poontaco

macrumors regular
Feb 2, 2014
239
154
I ran the cable checker and it didn't appear to be any problems, but I ordered a new HDMI highspeed cable just to be sure. Should be here today.

I'm not sure what other settings on the TV could be affecting it, especially since it's never had a problem before.

As far as the HDMI input, for this particular TV (Vizio d58u-d3) I think the only way it will work is through the HDMI 5 port which I have it plugged in to
OK. Good luck with the new cable. If I think of anything else, I'll let you know.
 

billiam86

macrumors newbie
Original poster
Sep 25, 2017
7
2
UPDATE: the new HDMI cable didn't do anything to fix the problem. I'm truly bamboozled as to why it doesn't stutter on my Vizio E55-E2 but it just can't seem to get it together on my Vizio d58u-d3
 
  • Like
Reactions: tonyr6

Poontaco

macrumors regular
Feb 2, 2014
239
154
You're running it in 4K SDR, correct?
Have you tried switching the YPbPr color space from 4:4:4 to 4:2:2?
What about the RGB High and Low settings?
[doublepost=1506431698][/doublepost]I just did some research on that TV, and apparently it can only do 4K at 60hz with a YPbPr color space of 4:2:0.
Running at 4:2:2 will limit you to 30hz (or24hz). And 4:4:4 is not supported at all.
 

billiam86

macrumors newbie
Original poster
Sep 25, 2017
7
2
You're running it in 4K SDR, correct?
Have you tried switching the YPbPr color space from 4:4:4 to 4:2:2?
What about the RGB High and Low settings?
[doublepost=1506431698][/doublepost]I just did some research on that TV, and apparently it can only do 4K at 60hz with a YPbPr color space of 4:2:0.
Running at 4:2:2 will limit you to 30hz (or24hz). And 4:4:4 is not supported at all.
So does that mean I'm just out of luck?
 

cynics

macrumors G4
Jan 8, 2012
11,586
1,885
I do not own or have I used a Vizio TV so bare with me. However set the ATV back to 4k SDR 60HZ (you are in the US correct?) and in the TV setup find an option for "Reduce Judder". If its a slider (not just on/off) increase it step by step until you are happy.

Than try playing 60hz content and see if too much of a "soap opera" effect for you.

Let me know if this helps or not.
 

AFEPPL

macrumors 68030
Sep 30, 2014
2,644
1,570
England
Sounds more like a wifi issue, have you tried over ethernet as a test?
Have you tried it on another TV?
Have you scaled back the output?
 

cyb3rdud3

macrumors 65816
Jun 22, 2014
1,382
473
UK
Sounds to me exactly what the core issue is of the Apple TV 4K and why I cancelled my order. Forcing everything to be output at the same refresh rate and HDR setting is just madness...
 
  • Like
Reactions: George Dawes

anticipate

macrumors 6502a
Dec 22, 2013
535
290
Most Vizio 4K TVs (I have one) only have one 60hz capable port. I have a PS4 running for gaming on that port, so the ATV is on a 30 Hz port. Video is fine but the interface is a little slow and choppy as a result. Other boxes like the Roku they switch to 1080 for the interface (which causes another set of HDCP issues...) but it's smooth.
 

cynics

macrumors G4
Jan 8, 2012
11,586
1,885
Sounds to me exactly what the core issue is of the Apple TV 4K and why I cancelled my order. Forcing everything to be output at the same refresh rate and HDR setting is just madness...
This isn't an uncommon practice. Personally I'm going to get one, throughly test it and then return it within the 14 day return window if I don't feel it works for me.

The biggest factor on this forum is the TV used. A newer high end TV can cope with most of the complaints. Another big factor is peoples sensitive to various visual "distractions". For example I wanted a movie at a friends house on his HTPC and the judder was so bad I found it unwatchable, he had no idea what I was talking about....

I have the same concern as you however mostly because my TV's are great at upscaling 1080p SDR. If the ATV can't do that as well the image will appear worse (easy to see by setting it back to 1080@60). Probably pick one up this weekend and see how it goes.
 

brentsg

macrumors 68040
Oct 15, 2008
3,485
855
UPDATE: the new HDMI cable didn't do anything to fix the problem. I'm truly bamboozled as to why it doesn't stutter on my Vizio E55-E2 but it just can't seem to get it together on my Vizio d58u-d3
You could have easily purchased another cable that won't work too. If you didn't get a Premium Certified cable then it might not be up to par.
 

billiam86

macrumors newbie
Original poster
Sep 25, 2017
7
2
Sounds more like a wifi issue, have you tried over ethernet as a test?
Have you tried it on another TV?
Have you scaled back the output?
My apple TV is hardwired and so is the computer, so it's definitely not a wifi issue. It must be a TV issue
 
  • Like
Reactions: George Dawes

Poontaco

macrumors regular
Feb 2, 2014
239
154
So does that mean I'm just out of luck?
Can you not set the color space to 4:2:0?
My Apple TV gives me the option.
[doublepost=1506518410][/doublepost]Also; My Vizio has a "Pure Cinema" toggle that is supposed to help with 24hz material.
Is that an option on yours?
 

billiam86

macrumors newbie
Original poster
Sep 25, 2017
7
2
Can you not set the color space to 4:2:0?
My Apple TV gives me the option.
[doublepost=1506518410][/doublepost]Also; My Vizio has a "Pure Cinema" toggle that is supposed to help with 24hz material.
Is that an option on yours?
My TV has a film mode which I set to auto....still stuttering
 

MrGAC

macrumors newbie
Sep 23, 2014
3
1
I am having a similar issue. The arial screensaver, iTunes 4K HDR movies, Netflix all skip when playing 4K HDR @ 60 hz. I am using the apple suggested HDMI cable. I spent 1.5 hours on the phone with Apple support and we couldn't figure it out. He opened a tech support ticket and said that there would likely need to be a fix applied in the form of a software update to correct the issue. He believes the TV and Apple TV are not compatible. The last time I had an issue like this it took over a year to fix. Looks like a return is in my future.
 
  • Like
Reactions: George Dawes

dahn

macrumors newbie
Aug 30, 2017
1
2
I know this is an old thread, but I just encountered this problem on my 4K ATV w/ Samsung UN82MU8000 TV. My solution was to go into the video settings and to set Frame Rate Matching to ON. Perfectly smooth pans now on both Planet Earth II (4K) and Ozark (4K).
 

mikeymike0

macrumors newbie
Jun 25, 2019
1
1
I know this is an old thread, but I just encountered this problem on my 4K ATV w/ Samsung UN82MU8000 TV. My solution was to go into the video settings and to set Frame Rate Matching to ON. Perfectly smooth pans now on both Planet Earth II (4K) and Ozark (4K).
And here we are at June 2019 and I have just bought an LG OLED65C9 and tried Avatar movie on 4K ATV with juddering on the panoramic scenes of climbing up the vines of the floating rocks to get to the banshee rookery...tried your advice and it stopped, thank you for solving my problem..
 
  • Like
Reactions: BODYBUILDERPAUL

CBlakeston

macrumors 6502
Jan 31, 2008
444
113
I just encountered this on the first Back to the Future. For whatever reason turning Quick Start off fixes it completely. At least when you encounter it playing iTunes movies.

Go to Settings/ Apps/ iTunes/ Quick Start - ‘turn off’. but you must remember to turn it back on after otherwise no 4k or HDR.
 
  • Like
Reactions: kristoffer4

kristoffer4

macrumors 6502a
Jan 17, 2006
997
131
Denmark
I just encountered this on the first Back to the Future. For whatever reason turning Quick Start off fixes it completely. At least when you encounter it playing iTunes movies.

Go to Settings/ Apps/ iTunes/ Quick Start - ‘turn off’. but you must remember to turn it back on after otherwise no 4k or HDR.
Great. I will try this.
 
  • Like
Reactions: CBlakeston

Tuzanor

macrumors newbie
Dec 13, 2019
1
0
For the record, I had some pretty annoying "stuttering" coming from my 4k apple TV. What finally fixed it for me was disabling the various "sharpening" and other video enhancements that the TV itself was doing and was enabled by default. This was on a Samsung TV.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.