Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Aerdon

macrumors member
Original poster
Jun 19, 2010
37
32
I have a badge app icon with the number '4' on my iMessage App store. I have no apps requiring update and cannot figure out what this is trying to tell me. Does anyone know what this means and how to remove it? Thanks in advance!


IMG_6575.PNG
 

alex2792

macrumors 65816
Jun 13, 2009
1,126
2,973
Have you tried rebooting? That usually resolves updates being stuck on my iPad.
 

maurihamm

macrumors member
Nov 7, 2015
42
22
I had the same problem but found a fix, this is what I did:

Go to iMessage, then under the applications bar tap More...
Tap edit, and enable all iMessage applications, even those you’re not going to use at all (in my case the culprit was Shazam). Then tap OK.
Now in the applications bar you’ll see a little blue dot next to the culprits, just tap on them and the problem will be solved. Now you can disable the apps you’re not going to use.
Let me know if this helped!
 

Attachments

  • CBE8C1DD-BBE9-4140-AD04-F3279441AC14.png
    CBE8C1DD-BBE9-4140-AD04-F3279441AC14.png
    680.8 KB · Views: 976
  • Like
Reactions: Ike_gold

Aerdon

macrumors member
Original poster
Jun 19, 2010
37
32
I had the same problem but found a fix, this is what I did:

Go to iMessage, then under the applications bar tap More...
Tap edit, and enable all iMessage applications, even those you’re not going to use at all (in my case the culprit was Shazam). Then tap OK.
Now in the applications bar you’ll see a little blue dot next to the culprits, just tap on them and the problem will be solved. Now you can disable the apps you’re not going to use.
Let me know if this helped!

Thanks! I was just about to try this and went into iMessage. The badge number was gone all on it's own. I'll try this in the future if it happens again.
 
  • Like
Reactions: maurihamm

Ike_gold

macrumors newbie
Dec 17, 2017
1
1
I had the same problem but found a fix, this is what I did:

Go to iMessage, then under the applications bar tap More...
Tap edit, and enable all iMessage applications, even those you’re not going to use at all (in my case the culprit was Shazam). Then tap OK.
Now in the applications bar you’ll see a little blue dot next to the culprits, just tap on them and the problem will be solved. Now you can disable the apps you’re not going to use.
Let me know if this helped!
Thanks for this fix... It was bugging me to death
 
  • Like
Reactions: maurihamm
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.