chris_chris

macrumors newbie
Original poster
Nov 6, 2018
2
0
Adaptive Noise Canceling of my Beats Studio 3 works fine while listening to music. But when making phone calls the background noise seems to be amplified by the headphones. I use them wireless.

Factory reset or latest firmware does not help.
Apple support could not help me / they did not know about this issue.

Im am working in a busy office. I expected noise from the outside is reduced while making calls.
I guess the Beats guys think I need to hear my own voice while making calls - but I am used to talk while wearing headsets since the old Sony Walkman days...

Do you have the same experience?
Is there any fix to enable ANC while making phone calls?
Or at least to have the passive canceling without amplified background noise?

Thank you.
 
Last edited:

chris_chris

macrumors newbie
Original poster
Nov 6, 2018
2
0
I think it is a problem with headphones, because good headphones are not like this, you should buy high-quality headphones as the handset of the phone.
this is a 250 EUR product by Apple --> so I expected "high quality"

Do other Beats Studio user have an explanation / solution to my issue described above?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.