Blu ray not working??

Discussion in 'Mac mini' started by ivnj, Jun 13, 2012.

  1. ivnj macrumors 65816

    Joined:
    Dec 8, 2006
    #1
    I got an external blu ray from ebay. The external shows "the spy next door" on my samsung np-rv515-a01us. But on my mac mini and my dads macbook pro it just spins and doesn't even show on the desktop. Even regular dvd doesn't work. Its not broken or it won't show in my windows 7 laptop. But mac for some reason refuses to work. And my regular external dvd burner also usb works. So why not the blu ray.
     
  2. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #2
    blu ray does not work on mac without special software. most of us run windows on the mac in bootcamp then run cyberlink blu ray soft ware
     
  3. ivnj thread starter macrumors 65816

    Joined:
    Dec 8, 2006
    #3
    Yes but just reading a disc should work shouldn't it. I can't play blu ray (even though they have software like "mac blu ray" and "aurora") but I should at least be able see it on the desktop shouldn't I. Or at least a regular dvd or even the fedora 16 i burned on windows. Works on windows. Why not mac.
     
  4. Wondercow macrumors 6502a

    Joined:
    Aug 27, 2008
    Location:
    Toronto, Canada
    #4
    You're correct that, if it's a drive that the Mac OS recognizes, the disc should mount on the desktop. As I understand it, not all drives are compatible and may not be recognized by the system. When I got mine I researched compatible drives and bought one that is confirmed to work on Macs.

    Check your drive on Google.
     
  5. MadTester macrumors regular

    MadTester

    Joined:
    Mar 24, 2012
    #5
    If you have Titanium (with blueray add on) it should be ok if you play through that software (i've not tried it however)... just a thought... you could also try VLC.. not sure if that has BlueRay support though.....:D
     
  6. iPhil macrumors 68040

    iPhil

    #6
    The VLC app does support Blu-ray encrypted playback but you'll need these lil files first and read thru that thread for more info etc.. :eek:
     
  7. ivnj thread starter macrumors 65816

    Joined:
    Dec 8, 2006
    #7
    I fixed it. My hub on my mini was the problem. After plugging it into the side of the monitor (it has 4 usb ports on the side) it showed up on my desktop. I guess the hub was not supplying enough power.
     

Share This Page