Bluetooth: Can't turn off OR can't turn on

Discussion in 'MacBook Pro' started by helfo, Apr 14, 2009.

  1. helfo macrumors newbie

    Joined:
    Mar 29, 2009
    #1
    Hi,

    I have a problem with my 17'' MBP unibody:

    1) Bluetooth is ON:

    I can't turn it off. The checkbox is inactive.

    But I can turn it off, if I choose "Share my internet connection for other units". (I don't know, if this is the right text in english, because my OSX is in german)

    2) Now Bluetooth is OFF:

    But I can't turn it on, because the checkbox "ON" is inactive.

    It turns only on, if I choose "New Unit"(?). Then there is a new window, that says, that this is only possible if Bluetooth turns on. If I say OK, bluetooth turns ON.

    Back to 1)

    What's the problem. Why is this f* checkbox for turning bluetooth on and off inactive?

    This is not a hardware problem, because I can have stable bluetooth connections.

    I did a smc and am pram reset. But it doesn't help.

    Can you help me?

    helfo
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Seems you did the right steps. my only advice left is to contact Apple and see what they have to say about it.

    Maybe a hardware issue, you never know.
     
  3. helfo thread starter macrumors newbie

    Joined:
    Mar 29, 2009
    #3
    1. I've noticed, that mbp plays a short (perhaps error-)sound (funk.aiff) when I open the Bluetooth Preferences first-time after booting.

    2. I've download a bluetooth widget from here:

    http://www.apple.com/downloads/dashboard/networking_security/bluetoothswitch.html

    After installing this widget and using it imidiatly I could turning bluetooth on and off. But using it the next time, it doesn't work anymore. Strange.

    -->
    This is not a hardware problem, because I can have stable bluetooth connections.

    Perhaps something is setup to use bluetooth & OS X is blocking changes due to that set connection...
     
  4. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #4
    Then a clean install of the OS might I suggest?
     
  5. helfo thread starter macrumors newbie

    Joined:
    Mar 29, 2009
    #5
    After doing a clean install (with deleting partition frist) the problem is still there. Hmmmm...

    Perhaps a driver issue with new MPB 17?

    Anybody out there with a new MBP 17 having this problem?
     
  6. helfo thread starter macrumors newbie

    Joined:
    Mar 29, 2009
    #6
    Did another clean install, but before I reseted smc. Now it works!
     
  7. RhiannonUndead macrumors newbie

    Joined:
    Sep 23, 2010
    Location:
    California
    #7
    my checkbox is also inactive all of the sudden, and i just reinstalled 10.5 on my imac. i'd love to hear what is going on with it. i see no reason for ONLY that box to be inactive. all the other sharing options work fine. :| help lol.
     
  8. CMFJ macrumors newbie

    Joined:
    May 25, 2012
    #8
    I have recently run into a similar problem with bluetooth being in limbo on my 15" MBP running 10.6.8.

    I tried to turn bluetooth off using the bluetooth dropdown in the menu bar.
    According the drop down, Bluetooth was still active. However, nothing would pair. In Bluetooth preference, the "on" button would not allow turning bluetooth on. When I tried to set up a bluetooth device, I received a prompt telling me that I needed to turn bluetooth on. I clicked the button to do so, but nothing would pair. Repeating the process gave the same prompt, ie bluetooth was not on.

    I tried repairing disk permissions and the performing the daily, weekly, and monthly maintenance scripts. No change.

    The solution to my problem was this
    1. allow the battery to drain to zero and the laptop to go into hibernate mode.
    2. plug in and revive by quickly pressing power button

    Bluetooth then responded to turning on and off.
     
  9. Medic278 macrumors 6502a

    Medic278

    Joined:
    Feb 1, 2012
    Location:
    New York
    #9
    I had the EXACT same problem as you. Do a shut down then restart it solved my problem 1 2 3. Hope this helps!
     

Share This Page