Bluetooth dropping somewhat randomly

Discussion in 'iMac' started by psapp, Jun 7, 2018.

  1. psapp macrumors newbie

    Joined:
    Jun 7, 2018
    #1
    Hello,

    I recently bought a 21.5" iMac (2017) after selling my last Mac in 2011 (MacBook). I love it, however, I've noticed that from the time I bought it, a couple of months ago, I've been having weird bluetooth drops, it tends to have the highest chance of happening right after waking up the machine or starting up VMware fusion. Sometimes the keyboard and mouse reconnect and other times they don't so I have to use the power button to restart the machine (I'll be getting a wired mouse tomorrow so I can use it to try resetting bluetooth when it happens).

    Anyone else having these issues? Should I contact AppleCare about it?

    Thanks!
     
  2. psapp thread starter macrumors newbie

    Joined:
    Jun 7, 2018
  3. nambuccaheadsau macrumors 68000

    nambuccaheadsau

    Joined:
    Oct 19, 2007
    Location:
    Nambucca Heads Australia
    #4
    Do yøu have a hands free or cordless phone nearby on the desk etc.?
     
  4. psapp thread starter macrumors newbie

    Joined:
    Jun 7, 2018
    #5
    No, just my cell phone. I'm assuming this isn't a common problem?
     
  5. campyguy macrumors 68040

    Joined:
    Mar 21, 2014
    Location:
    Portland / Seattle
    #6
    Enable BT coexistence mode... Enabling it on 50-odd Win PCs and Macs in my company fixed it, permanently. Enabling it on any wireless routers that you have access to and have that capability will help as well.
    See my post: Keyboard goes crazy
     
  6. psapp thread starter macrumors newbie

    Joined:
    Jun 7, 2018
  7. Guy Clark Suspended

    Guy Clark

    Joined:
    Nov 28, 2013
    Location:
    London United Kingdom.
    #8
    Try removing the devices from the macOS Bluetooth Preferences Pane and pairing them again.
     
  8. psapp thread starter macrumors newbie

    Joined:
    Jun 7, 2018
    #9
    Just wanted to give an update. I used the command in the referred post and it seems to have fixed my issue, no bluetooth drops since. Thank you very much, it seems crazy that this wouldn't be enabled by default.
     

Share This Page