Bootcamp - Win 7 ISO with both 64bit and 32bit

Discussion in 'Windows, Linux & Others on the Mac' started by bmouthboyo, Mar 25, 2013.

  1. bmouthboyo macrumors member

    Joined:
    Feb 4, 2013
    #1
    Hi guys,

    I have an image of Windows 7 that is an ISO with both 64 bit and 32 bit versions. When I try and load this in bootcamp it gives me the message about needing 64 bit. Anyone know a workaround?

    Thanks
     
  2. iSayuSay macrumors 68030

    iSayuSay

    Joined:
    Feb 6, 2011
    #2
    It's actually easy to install Windows 7 on Bootcamp if you already have All in One ISO (one contains both x86 and x64 installation).

    1. Only use Boot Camp Assistant on your Mountain Lion to download drivers to your iMac.

    2. Get Boot Camp Assistant 4.0 (yours is 5.x.x) from a Mac with OSX 7. It's located on Applications/Utilities. Do not overwrite the previous BCA app file.

    3. Run the Boot Camp 4.0 .. Mount your Windows ISO file, and prepare a 8GB thumb drive to make a bootable USB drive.
    Follow the step as usual.

    Yep, Boot Camp 5.0.1 is piece of crap for enforcing x64 Windows ISO file.
     
  3. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #3
    There is another way without using Bootcamp.

    Open Disk Utility, click on the USB stick where you want the ISO to be restored, then click on the restore tab, next choose the image from resource and last click the restore button, that's it, you don't even need bootcamp to download the drivers, there are plenty of places where you can download those, and, you don't need Bootcamp either to resize the partitions, you again can do this with Disk Utility.

    Bootcamp is for "Dummies"
     
  4. iSayuSay macrumors 68030

    iSayuSay

    Joined:
    Feb 6, 2011
    #4
    Yep that's one other way around. But I couldn't even restore my Windows 7 ISO using DU.
    So I thought since BootCamp Assistant 4 supports 32 bit Win7, I gave it a try and boom the very same ISO file now can be copied to the flashdrive.
     
  5. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #5
    Yeah, I had my troubles with DU in ML, never had those problems on 10.5.8, especially restoring seems to get me Errors, if I do the same with the same image on my old PB it will restore.
     
  6. bmouthboyo thread starter macrumors member

    Joined:
    Feb 4, 2013
    #6
    I am very disappointed this is not easier, so far the MAC dream isn't living up to all people made it to be. Out of date incompatible programs and needless hoops to jump through for basic tasks.

    All 3 of my ISO images will not work as it seems the MAC doesnt like them having 32 in them. I tried getting boot camp assistant 4 and cannot find a copy anywhere. I tried using disk utility but it doesnt accept me dragging the ISO's into the source field "error 254". Tried mounting the iso but no way of selecting the installation files.

    I am basically stuck now. Apple seem to be unable / unwilling to fully suport this feature and it is a real shame.

    I cannot get the 64bit only ISO it wants. Im lost
     
  7. iSayuSay, Mar 26, 2013
    Last edited: Mar 26, 2013

    iSayuSay macrumors 68030

    iSayuSay

    Joined:
    Feb 6, 2011
    #7
    There lies our problem. I also couldn't find a copy of Boot Camp Assistant 4 anywhere on the internet. Not even on torrent sites and such. Maybe people just don't bother since it's available by default on each OSX.

    So ask for a copy of BCA 4 from a Mac which still has OSX Lion in it, once again it's located on Applications/Utilities and weighs around 15MB. This tiny file will help you a lot more than any Windows ISO you can find.
    Works as charm for me for all in one Windows ISO, maybe even for 32 bit. BootCamp Assistant 5 is craptacular indeed.

    Try it, you'll thank me later and please come back to confirm whether this method works for you or not. It'll help some stuck people later, who googled and find this thread. :D
     
  8. falkas macrumors newbie

    Joined:
    Jun 25, 2013
    #8
    The other posts have good advice. I know this is a couple months later and it might not help the original poster out, but it could help someone in the future.

    It is possible to use the Windows 7 ISO with both x86 and x64 on the same install file. Bootcamp 5 will see this as a x86 install file though and won't allow it to continue. To fix this just follow these steps.

    1. Open a Finder window.

    2. Navigate to Applications>Utilities

    3. Control Click or Right Click on Boot Camp Assistant and select "Show Package Contents"

    4. Open the Contents folder

    5. Drag the file "info.plist" to your desktop (I also recommend saving it in another place as well in case you want to revert to the original)

    6. Open info.plist on your desktop with a text editor

    7. Find the field labeled as below:
    <key>32BitSupportedModels</key>
    <array>
    <string>MacBook7,1</string>
    <string>MacBookAir5,2</string>
    <string>MacBookPro10,1</string>
    <string>MacPro5,1</string>
    <string>Macmini5,3</string>
    <string>iMac12,2</string>
    </array>

    8. Time to find what your Mac is. Click the Apple in the top left hand corner and select About This Mac
    -Click More Info...
    -Click System Report...
    -Under Hardware Overview, look for Model Identifier and copy it

    9. With your Mac's Identifier copied, go back to your open info.plist file create a string at the TOP of the entries. So if your Mac identifier was "iMac13,2" then it would look like this:
    <key>32BitSupportedModels</key>
    <array>
    <string>iMac13,2</string>
    <string>MacBook7,1</string>
    <string>MacBookAir5,2</string>
    <string>MacBookPro10,1</string>
    <string>MacPro5,1</string>
    <string>Macmini5,3</string>
    <string>iMac12,2</string>
    </array>

    10. Save and close info.plist. Drag info.plist back into the Contents folder and select replace. (You may have to authenticate and enter your admin password).

    11. Start Bootcamp and it should allow you to use your Disk/USB with both versions. I wouldn't recommend installing the x86 (32 bit) version of Windows 7, but this will allow you to get to the point of the installation to select x64 (64 bit) if you have an ISO file with both 32 bit and 64 bit combined. Hope this helps.
     
  9. Augustine864, Jun 27, 2013
    Last edited: Jun 27, 2013

    Augustine864 macrumors regular

    Joined:
    Mar 26, 2013
    #9
    I just had a Bootcamp fail two days after getting my first MacBook.

    I went through the Bootcamp assistant process but when it rebooted to install Win7, it just came to a black screen with a flashing command line cursor. I couldn't boot back to anything at all until I did a hard restart and held down the "option" key to select the MacOS SSD.

    Now I have 90GB dedicated to a partition that I can't install to. What is my next step? When I restart is says no bootable device detected even though I have an external disc drive connected via USB with a win7 install disc in it.

    *UPDATE

    I deleted the partition and set the MacBook to boot from OS X again. Still not sure how I'll go about boot camping after this. I must have done something wrong, I just don't know what.
     
  10. AdamFerguson macrumors newbie

    Joined:
    Jun 27, 2013
    #10
    Thankyou!





    You were spot on when you said that you may help someone in the future. I've spent the last few days trying to get over this problem and your answer actually fixed it. It took a little while to get the whole thing to work as I wasn't sure if the file needed to be renamed the same as the previous file (I think it did) and I wasn't entirely confident on the editing of the text but your instructions were very clear and I'd like to say a big thank you. I created an account just to pass it on. So, once again, cheers.
     
  11. kateraldo macrumors newbie

    Joined:
    Jul 31, 2013
    #11
    Thanks!

    Thanks Falkas! I also register on the web only to say thanks! You help me to install windows on a mac mini after the hole day looking how can I fix the problem of this new bootcamp. Sorry my english. From Argentina, THANKS!
     
  12. polbit macrumors 6502

    polbit

    Joined:
    Sep 18, 2002
    Location:
    Texas
    #12
    Ok, I'm trying this fix with no success. I have a MacBookPro8,2. I have modified the content of Info.plist file for Bootcamp Assistant in both Contents and MacOS directories to show:

    Code:
    <key>32BitSupportedModels</key>
    	<array>
    		<string>MacBookPro8,2</string>
    		<string>MacBook7,1</string>
    		<string>MacBookAir5,2</string>
    		<string>MacBookPro10,1</string>
    		<string>MacPro5,1</string>
    		<string>Macmini5,3</string>
    From the Hardware Identifier:

    Code:
    Hardware Overview:
    
      Model Name:	MacBook Pro
      Model Identifier:	MacBookPro8,2
    Yet when I'm trying to use my Windows 8 All-in-One image burned onto a real DVD-R, I keeping getting the "You need 64-bit version...

    Any ideas?
     
  13. mikeljcarr macrumors newbie

    Joined:
    Aug 13, 2013
    #13
    I have the same problem. Followed the directions and got further than before but ended up at the same black screen with a blinking cursor. Any thoughts?
     
  14. PabloNeirotti macrumors newbie

    Joined:
    Aug 24, 2013
    #14
    Weird. Make sure BootCamp is not open. Then do edit the file as indicated. Once done, open the info.plist file again from the Contents folder, and check if changes were actually applied. It may be some permissions issue with your text editor or copying on Finder.

    Once you make sure changes are indeed being applied on the file, open Bootcamp again and try.
     
  15. ImShane macrumors member

    Joined:
    May 29, 2007
    #15
    falkas thanks so much without your guide i would be completely lost as there is nowhere i found on the net for this help :)

    Now just incase a few people got into extra problems i will point out what i also got into difficulty with.

    1.Make sure not to have any extra external harddrives connected besides the one with your drivers and/or the windows installation on it, otherwise once you get to the format/partition part of the windows installation you will get an error saying this ''Setup was unable to create a new system partition or locate an existing system partition'' and you wont be able to proceed.

    2. If at any stage during the windows installation you need to quit you will then need to start all over again, and by that i mean you will need to re-partition your computers harddrive to just one partition by erasing and formatting the bootcamp partition and creating one partition like it was before you started this procedure.

    Also, you need to do the exact same with the external harddrive you put your drives and support software on during the bootcamp process, so format that back to its original state.

    Because if you done do all this you wont be able to use your keyboard/mouse once windows is finally installed. Allot of people get in trouble here and think you need to install the drivers from 'Load Drivers' at the installation part, but if its done correctly and like i suggested you wont need to, it will install everything on its own.

    So basically if you need to restart the process,reformat your main drive back to one partition, then wipe your external, format it again back to its original format and install windows on it along with the support software and proceed to install bootcamp. So i basically ticked the 3 options and done it all at once.

    Hope this helps, its what finally got it up and working for me!
     
  16. HToad macrumors newbie

    Joined:
    Nov 1, 2013
    #16
    Does anyone know if Mavericks has made this impossible? I followed the directions exactly, however I can't seem to load the Bootcamp Assistant after I make the change. It just give me an error and won't load. Any suggestions?
     
  17. nttalie macrumors newbie

    Joined:
    Nov 7, 2013
    #17
    I'm having the same issue, I've tried everything and nothing seems to work :(
     
  18. slamno7 macrumors newbie

    Joined:
    Nov 24, 2013
    #18
    Mavericks

    Thanks falkas and others- to get this to work in mavericks you need to codesign the app with the changes. It should look something like:

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app/Contents/info.plist

    to sign the file that changed
    then

    sudo codesign -fs - /Applications/Utilities/Boot\ Camp\ Assistant.app

    to sign the app. I don't really know the ins and outs of this particular code signing process that apple is using (probably a good thing) but this worked for me
     
  19. dev.jac macrumors newbie

    dev.jac

    Joined:
    Nov 28, 2013
    Location:
    CABA
    #19
    :) This worked FLAWLESSLY! Thanks!
     
  20. lioskyyy macrumors newbie

    Joined:
    Dec 1, 2013
    #20


    Hello people,
    I use a Macbook pro with Mavericks.
    I have my version of Windows 8.1 Iso (Microsoft.Windows.8.1.Pro.Enterprise.VL.All.in.On e.German MCU) this:

    Special features of this release:
    When booting the DVD you can between the Professional and Enterprise editions VL (both as x86 and x64 version on the DVD) to select. The Windows is already activated automatically v9.0.6.20131120 Stable Edition during setup by KMSpico. Simply boot up, install, and look forward to an activated Windows only DVD.


    I have a problem because? that the program Boot Camp does not want to install? because it shows that there is no 64bit version is.
    Although both version it is.

    How can I version with Boot Camp 8.1 in this Windows Bootable Usb make and then install?

    I have to change this guide plist with Boot Camp, but the problem then:
    Bootcamp can not open ...
     
  21. pruthvee macrumors newbie

    pruthvee

    Joined:
    Dec 2, 2013
    Location:
    MN
    #21
    I am new to Macrumors; so if I am posting this question in a wrong section, my apologies.

    My questions however is - I am planning on installing Win 7 Professional on my iMac. I recently purchased the OEM version of 64-bit Windows 7 Professional and was wondering if it is any different from the full retail version. I do understand the concept of OEM being only usable for one installation or one motherboard. My only concern is if there are any performance issues or other compromises/hindrance in installing OEM version as opposed to full retail version? If so, what are they? (any issues from space consumption to programs running fluidly... )

    I'd greatly appreciate the communities time and efforts in answering my questions.

    Thank you.
     
  22. xcodeSyn macrumors 6502a

    Joined:
    Nov 25, 2012
    #22
    You probably should've started a new thread for your question instead of asking here since it's not related to the topic. There is no performance difference but the OEM version has no customer support from Microsoft. Personally I'd not buy the OEM version because I tend to change hardware faster than I switch OS. If this is not the case for you, then OEM would be fine if you don't need any customer support.
     
  23. Nostalgia macrumors member

    Joined:
    Feb 13, 2013
    #23
    wait what, care to elaborate?

    what´s all that sudo/codesign stuff? where do i do that? how?

    i don´t understand. i did what falkas posted but bootcamp doesn´t open up. i suppose you have the solution to make it work on mavericks, however i don´t understand how to do it.

    cheers
     
  24. vols, Dec 19, 2013
    Last edited: Dec 19, 2013

    vols macrumors regular

    Joined:
    Jun 25, 2013
  25. raedcolour macrumors newbie

    Joined:
    Dec 24, 2013
    #25
    all those sudo design thingy just open up terminal and paste it in. however im also facing the same problem. boot camp cant be opened up after editing the plist :-/ i'm stuck.

    ----------


    i also had the same problem: boot camp not opening up after editing the info.plist. what i did was just place back the original plist into the folder and it opened right up. hope this helps
     

Share This Page