bought a 1.1.2 iphone..want to unlock it

Discussion in 'Jailbreaks and iOS Hacks' started by eddies1j2, Nov 23, 2007.

  1. eddies1j2 macrumors newbie

    Joined:
    Jul 3, 2007
    #1
    Ok, i just bought an iphone and it is 1.1.2 and i want to unlock/unblock it , i want to use any sim because i wont use at&t. so i saw various posts about downgrading but im not sure if those only work for upgraded 1.1.1 to 1.1.2 or they work with a 1.1.2 out of the box.. i only have a pc with windows so i dont know which guide. i just want an easy way to downgrade to 1.1.1 and then use the jailbreakme.com website

    thanks in advance
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    First of all, I and many people here will suggest you NOT to downgrade if you bought an iPhone with 1.1.2 installed since these new phones have a different bootloader in them. You can try and risk it (there are many guides around) however, it is more important to wait a couple of days until a user friendly way appears.
     
  3. ouchiko macrumors member

    Joined:
    Nov 28, 2007
    #3
    Is their any news on this? Just got a 1.1.2 out of the box itouch and I did try the methods currently out there to down-grade the firmware. Alas, none of these methods work (I think) if 1.1.2 is preinstalled.

    I tried 1.1.1 3A109a and 1.0.2 1C28 using iTunes retore but each failed and a 1.1.2 re-do was required. Anyway, would be good to know what progress is happening..

    Thanks

    Edit:: Running an IP scan on the device brings up port 21 as open.
     
  4. Jeuk macrumors newbie

    Joined:
    Nov 27, 2007
    #4
    From what I've read of these forums, so far, you cannot unlock the 1.1.2 iPhone as of yet, and most of us with out of the box 1.1.2s are desperately waiting for a way to use our sim cards on it.

    However, downgrading to 1.1.1 is possible, I know because I've done it with an out of the box 1.1.2 I bought yesterday.

    Basically, the guide didn't work for me, but here's what I did:

    1. Boot in restore mode (1.1.2 restore mode has a picture of a cable going into an itunes logo with a disc).
    2. shift-click restore in itunes and select the 1.1.1 ipsw file that's everywhere.
    3. wait until it finishes, and itunes will give you an error.
    4. ***This is where the guide stopped working for me. It said to use iphuc32, but everytime I entered a command the thing died. Someone in the thread said they used iBrickr, and so I thought I would give it a shot. While still in restore mode, right after given the error in itunes, press okay. Then go to ibrickr, and press boot my iphone. If everything is working, you should see your background turn red, and your iphone should boot into 1.1.1.
    5. From there, use the guide's method of getting to safari and going to jailbreakme.com, etc.

    This is what's worked for me, but it seems that different people are having different results, so who knows.

    Though, no SIM cads other than AT&T can be used for now.

    Good luck.
     

Share This Page