iPhone Calls on other devices not working when iPhone is off

Discussion in 'iOS 11' started by Bill Av, Nov 4, 2017.

  1. Bill Av macrumors regular

    Joined:
    Oct 21, 2006
    #1
    I did a clean install of iOS 11 on my iPhone, a clean install of Watch OS 4 on my 2nd Gen Apple Watch and a clean install of High Sierra on my iMac. I'm not getting calls on my iPad and Apple Watch when my iPhone is turned off (the iMac receives the calls and shows a notification, but it doesn't ring). The calls go through properly to all my devices when my iPhone is turned on, and everything is connected to the same Wi-Fi. My iPhone is set up properly; I have the message "Allow other devices signed in to your iCloud account to make and receive calls even when your iPhone is not nearby" in the settings.

    I've done everything Apple's instructions say to do. I've even logged out of iCloud on every device and signed back in on each. I'm using Verizon - is there something that they might need to do? For the Apple Watch, is it possible that this feature has been dropped now that there's a LTE Apple Watch?
     
  2. Mlrollin91 macrumors G5

    Mlrollin91

    Joined:
    Nov 20, 2008
    Location:
    Ventura County
    #2
    I’m almost positive your phone has to be on. Even for WiFi Calling your phone needs to be on for other devices to work.
     
  3. Bill Av thread starter macrumors regular

    Joined:
    Oct 21, 2006
    #3
    It depends on your wireless carrier; some support it, others don't. It's worked for me in the past; I turn my iPhone off at night, but I could make/receive calls on my iPad/Mac/Apple Watch.

    Even now, it sort of works on my Mac. I can make outgoing calls, but it doesn't ring on incoming calls - but I get a notification saying that a call is coming in, and I can answer it.
     
  4. Sorig macrumors regular

    Joined:
    Nov 2, 2017
    #4
    How do you even expect to recieve any calls at all if your phone is off?
     
  5. Bill Av thread starter macrumors regular

    Joined:
    Oct 21, 2006
    #5
  6. Sorig macrumors regular

    Joined:
    Nov 2, 2017
  7. Feenician macrumors 603

    Feenician

    Joined:
    Jun 13, 2016
    #7
    T-Mob support it without the iPhone being near or even on for sure. I guess Verizon do too.

    When you switch it on on the Mac, does it appear to be activating at least? Do you get the message about the E911 address?
     
  8. Bill Av thread starter macrumors regular

    Joined:
    Oct 21, 2006
    #8
    Yep. I received the warning on the Mac and iPad (repeatedly, since I've gone through this couple of times in the past week).

    I seem to have had a breakthrough. I was able to make an outgoing call from the Apple Watch. I couldn't receive incoming calls on the AW, and the iMac showed the notification, but didn't ring. I just put my iPhone into Airplane mode, then turned off Bluetooth. My iMac and Apple Watch both started to ring.

    The iPad is still not able to make/receive calls on it's own. I kept it on iOS 10, though. That might be a factor, even though the requirement is for iOS 9.
     
  9. Feenician macrumors 603

    Feenician

    Joined:
    Jun 13, 2016
    #9
    I just switched it off and then on again on my iPad to check and I was able to make and receive calls without the phone on. I’m on T-Mob and all iOS 11 though, so two differentiating factors there. Not much help to you I’m afraid.
     
  10. Bill Av thread starter macrumors regular

    Joined:
    Oct 21, 2006
    #10
    Thanks, though :).

    I just reset my network connections on the iPad for the third time. This was the first time that it asked for the 6 digit pin after I enabled Wi-Fi calls, so that's something promising. It still doesn't work, but I think I'll let it sit for a while. Maybe some internal switching has to go on Verizon's or Apple's end for it to kick in.
     

Share This Page

9 November 4, 2017