camera app in ios10 is the worst ever!

jfc723

macrumors newbie
Original poster
Jan 9, 2015
20
2
Im sure this might get merged somewhere with one of many threads regarding this issue. But what is apple doing messing with a perfectly working app!!!

It is so frustrating. Now I only use this garbage to actually make calls only now!

2 iphones 5s and 1 iphone 6 were upgraded to ios 10 and now there camera app is not working properly.

2 new iphone 7 with the same issue
 

Jayson A

macrumors 68000
Sep 16, 2014
1,798
1,102
My camera app works perfectly. Not sure what the issues are.

I'm pretty sensitive to issues, so if I'm not having issues, then you know it surely isn't a problem.
 

leesweet

macrumors demi-god
Feb 1, 2009
1,044
239
Northern Virginia, USA
Exactly. Only change to mine (7 plus) was the addition of the new portrait mode (and I'm on 10.1PB2). But beside that, same as always. I assume else there are no changes.
 

st8fan19

macrumors newbie
Jun 10, 2009
18
0
Michigan
Wait what? Literally the only change that was made was moving the front facing camera button to the bottom where it is more reachable.
 

Feenician

macrumors 603
Jun 13, 2016
5,180
4,788
Hilarious hit and run apropos of nothing.

Only frustration I have with the camera app (and it's quite a long standing one) is switching modes and it only really happens when I'm trying to capture something quickly and have a serious case of ham hands. In that case I tend to tap when I'm trying to swipe the mode selector (or vice versa) and that inevitably results in the mode selector going the opposite direction I intended. It's probably the only thing I ever do with the phone where I'm genuinely in too much of a rush to interact properly.
 
  • Like
Reactions: Enygmatic

Enygmatic

macrumors 6502a
Jan 27, 2015
733
698
Various
Hilarious hit and run apropos of nothing.

Only frustration I have with the camera app (and it's quite a long standing one) is switching modes and it only really happens when I'm trying to capture something quickly and have a serious case of ham hands. In that case I tend to tap when I'm trying to swipe the mode selector (or vice versa) and that inevitably results in the mode selector going the opposite direction I intended. It's probably the only thing I ever do with the phone where I'm genuinely in too much of a rush to interact properly.
I used to have this same issue - the tiny text of the various Modes can seem unnerving when you're in a hurry. What's always helpful for me is remembering that you just have to swipe anywhere on the screen - not just that tiny area where it says 'Photo', 'Video', etc.
 
  • Like
Reactions: Feenician

0970373

Suspended
Mar 15, 2008
2,726
1,406

aristobrat

macrumors G5
Oct 14, 2005
12,244
1,312
Can you be more specific?
Trying to reverse engineer this from his previous posts, he was activate in a thread about how the camera app sometimes lags. So maybe that? This is when you open the iOS camera app and the screen doesn't update with what the camera is pointing at.

I've had that happen once or twice out of a few hundred times that I've used the iOS 10 camera app so far. One of the times was extremely frustrating though. The area I live in unexpectedly (to the point that most of the local TV meteorologists officially apologized for missing it) got the effects of hurricane Matthew. At my house (which is newer, so this was our first major storm) super-strong wind gusts would push outside water under french doors and into the house. I needed to get a video of this happening to show the builder. These wind gusts were random, and sometimes 15-20 minutes apart. Tried to take a video when it happened, and the camera opened up to a blurred screen and wouldn't refresh. Force-quiting the app and going back in didn't fix it. Fixed itself about 30 seconds later, but I missed what I needed to record.

Someone linked to a video of the lag in this post. Most of the video is how to create the lag, skip to the very end to see the actual effect.
 
Last edited:

jfc723

macrumors newbie
Original poster
Jan 9, 2015
20
2
Trying to reverse engineer this from his previous posts, he was activate in a thread about how the camera app sometimes lags. So maybe that? This is when you open the iOS camera app and the screen doesn't update with what the camera is pointing at.

I've had that happen once or twice out of a few hundred times that I've used the iOS 10 camera app so far. One of the times was extremely frustrating though. The area I live in unexpectedly (to the point that most of the local TV meteorologists officially apologized for missing it) got the effects of hurricane Matthew. At my house (which is newer, so this was our first major storm) super-strong wind gusts would push outside water under french doors and into the house. I needed to get a video of this happening to show the builder. These wind gusts were random, and sometimes 15-20 minutes apart. Tried to take a video when it happened, and the camera opened up to a blurred screen and wouldn't refresh. Force-quiting the app and going back in didn't fix it. Fixed itself about 30 seconds later, but I missed what I needed to record.

Someone linked to a video of the lag in this post. Most of the video is how to create the lag, skip to the very end to see the actual effect.
well someone here pays attention..

lets stop pretending and ignoring threads just because your iphones "works flawlesly" then why are you here??

there was been several posts regarding this issue. camera app lag. Have never used ios 9 but from the searched ive done it all started then.

there is an extremely annoying lag when you open up the camera app. You have to wait from 10 to 20 or more secs to be able to take a picture... and for those who think "wait take a picture and move on with life" really? then whenever I want to take a pictures of my kids doing something spontaneous I should run home and get me camera out and attach lenses and what not... because the moment will wait there for me???

there is another addition issue with the iphone 7 plus app also.

it used to be plain and simple.. none of that bs live photos and what not. click slide and take picture.. sharp and fast. Now its just like im using an android device.
 
  • Like
Reactions: LoveToMacRumors

simonsi

macrumors 601
Jan 3, 2014
4,849
716
Auckland
...You have to wait from 10 to 20 or more secs to be able to take a picture...
I've never seen that with any iOS release on any phone, longest I have ever waited is sub 1second.

I'd suggest you take it for service, if that was something specific to the app I'm sure there would be widespread reports (ie in the millions affected given the number of iOS10 installs there must be by now).

If all five of your devices are doing the same delayed startup then that is wierd but I'd take them all for service and see what Apple say, again, if that was iOS the internet would be aflame with it and Samsung Note 7 fires wouldn't be getting any airtime...
 

idoccurt

macrumors regular
Aug 25, 2006
131
15
Im sure this might get merged somewhere with one of many threads regarding this issue. But what is apple doing messing with a perfectly working app!!!

It is so frustrating. Now I only use this garbage to actually make calls only now!

2 iphones 5s and 1 iphone 6 were upgraded to ios 10 and now there camera app is not working properly.

2 new iphone 7 with the same issue
Not liking it at all...Something is up with the software
 

jfc723

macrumors newbie
Original poster
Jan 9, 2015
20
2
I've never seen that with any iOS release on any phone, longest I have ever waited is sub 1second.

I'd suggest you take it for service, if that was something specific to the app I'm sure there would be widespread reports (ie in the millions affected given the number of iOS10 installs there must be by now).

If all five of your devices are doing the same delayed startup then that is wierd but I'd take them all for service and see what Apple say, again, if that was iOS the internet would be aflame with it and Samsung Note 7 fires wouldn't be getting any airtime...

are you not aware of all the issues with ios10? just look at the forum!!
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
47,529
16,035
are you not aware of all the issues with ios10? just look at the forum!!
Many things are not something everyone experiences. Various things are bugs here and there, although even many of those might not be things that all kinds of people really run into (even if they are there) for one reason or another.
 
  • Like
Reactions: simonsi

jfc723

macrumors newbie
Original poster
Jan 9, 2015
20
2
But Ive still not had any camera app issues, ever on any iDevice. The word for describing everyone elses reported problems as your own is "hysteria".
Ive never had any issues with the camera app either and ive owned all damn iphones. Does that mean that there can't be any?

do a search on the forums and there are many threads regarding the camera app issues in ios10 and ios9.
 

simonsi

macrumors 601
Jan 3, 2014
4,849
716
Auckland
Ive never had any issues with the camera app either and ive owned all damn iphones. Does that mean that there can't be any?

do a search on the forums and there are many threads regarding the camera app issues in ios10 and ios9.
Sorry, YOU have never had any issues but you opened this thread??? Are you wasting everyone's time just posting issues other people have had???

All I'm saying is that IF they were truly a fundamental flaw in the iOS10 Camera app then the internet would be on fire with it, its a feature most users use a lot of the time. A tiny number of reports here does not to me imply there is that widespread problem (and ONLY 35 documented incidents have caused Samsung's woes with the Note 7). My experience (and yours it seems???) is of zero camera app issues across iOS10/9/8/7 and iPhone 3GS/4S/5S/6 and multiple devices across the family. Different experiences lead to different views which is why I suggested getting the devices looked at. Your (alleged) report of 10-20 SECONDs to open the App is quite outrageous performance if true and I'm sure Apple would want to look at those devices - I wouldn't expect a single iPhone user to put up with that for a minute.

Why not post a video of the 10-20sec delay?