Can iTunes Be Removed from High Sierra?

Discussion in 'macOS High Sierra (10.13)' started by jtbrown, Mar 13, 2018.

  1. jtbrown, Mar 13, 2018
    Last edited: Mar 13, 2018

    jtbrown macrumors newbie

    Jan 7, 2011
    I've been having a weird problem* with iTunes on my late 2013 iMac (OS 10.13.3) that I suspect I might be able to fix by deleting and reinstalling the app. However, I can't delete iTunes, because when I try to put it in the trash I get a message that says “iTunes” can’t be modified or deleted because it’s required by macOS. I have tried to get around this in the following ways, each of which was suggested by various posts I've found online, but none of which has worked for me; in each case, I was unable to delete iTunes and got the error message quoted above when I tried to put it into the trash:

    1) Rebooting my iMac.

    2) Running Disk First Aid (which found no problems with the hard drive).

    3) Selecting "get info" for iTunes and changing the "privilege" for "everyone" to "Read & Write"

    4) Enabling and logging in as the root user.

    5) Booting in recovery mode and using Terminal to disable SIP.

    I should also mention that I have downloaded iTunes from Apple and reinstalled it without deleting the existing copy of the app first, but this did not correct the problem I am trying to fix.

    I'd be grateful for any help anyone can supply – or if there is simply no way to remove iTunes when running High Sierra, then I'd appreciate being informed of that so that I can stop wasting my time and effort.

    Thanks in advance,
    Todd Brown

    *In case anyone is interested, or has advice on this particular issue, the problem is that for months now I cannot use iTunes to play any video file whose "media kind" is labeled "music video." The files in question are mostly .mp4 files, though some are QuickTime movies; a few were purchased from the iTunes Store but the vast majority were not. All will play fine in QuickTime, and all will play in iTunes if I change the "media kind" to "TV show" or "movie." Copies of the same files will play within iTunes on my MacBook Pro, using the same version of iTunes and the same MacOS.

    Edit: On the off chance that someone runs across this thread while looking for a solution to the same problem I've been experiencing with iTunes, please note that deleting and reinstalling the app did NOT in fact resolve the issue.
  2. jbarley macrumors 68040


    Jul 1, 2006
    Vancouver Island
    Open a terminal window and enter the following...
    "sudo rm -rf "
    Note the space after -rf, then drag the iTunes icon from the Applications folder and drop it in the Terminal window to complete the command,
    finally enter your password and"Enter" and it should go away.
  3. jtbrown thread starter macrumors newbie

    Jan 7, 2011
    Thanks, but I just tried that and got a very long string of text in which each line ended with "Operation not permitted". Should I turn off SIP and try again, maybe?
  4. jbarley macrumors 68040


    Jul 1, 2006
    Vancouver Island
    That's really odd because as I always do, I tried the command myself before I posted and it worked perfectly.
    Then I did a restore of iTunes from time Machine.
    You sure iTunes or anything that uses (relies on) it was not running in the background?
  5. jtbrown, Mar 13, 2018
    Last edited: Mar 13, 2018

    jtbrown thread starter macrumors newbie

    Jan 7, 2011
    iTunes itself definitely wasn't running, but I'm not 100% sure about "anything that uses (relies on) it," as I don't know what else would be using iTunes. I'm going to try it again now with SIP disabled.

    Edit: I just followed the procedure you recommended after disabling SIP, and it worked – though it turns out that deleting and reinstalling iTunes did not, in fact solve the problem I was trying to solve. In any case, thanks very much for your help!
  6. dianeoforegon macrumors 6502a


    Apr 26, 2011
    Testing in a new User will quickly tell you if the problem is system wide or if it's your User's folder that contains the problem.

    You can use the Guest User or create a new User for testing.


    Go to System Preferences --> Create a New User in Users & Groups.
    Switch to the New User by logging out/in or use Fast User Switching.
    You can skip logging in with an Apple ID unless you need to test iCloud apps. Hit continue then skip.

    Only default Apple apps will be in the Dock in the new User. Go to Applications to open other apps you might want to test.

    Do you still see the issue?

    If yes, then the problem is with your base files or it could be hardware related.
    If no, then the problem is in your User's folder.

    More Info:
  7. dcmaccam macrumors member

    Sep 14, 2017
    West Coast of Scotland
    Have you tried installing iTunes version to see if that helps
  8. jtbrown thread starter macrumors newbie

    Jan 7, 2011

    Thanks so much, dianeoforegon – I followed your directions and was able to determine that the problem is in my user's folder (that is, the files played properly within iTunes in a newly created user account). This seems like a potentially useful piece of information, but I have no idea how to proceed – any advice on how I might further isolate and/or correct the problem? Also, do you think reverting to iTunes 12.6.3, as dcmaccam suggested, is worth a shot?
  9. vkd macrumors 6502a


    Sep 10, 2012
    I used to have an app that changed file type associations, which seems to be what you need to do. Either that or do a bit of internet searching and you will see how to do it.
  10. 1252 macrumors member


    May 14, 2018
    If I remove iTunes (12.7) from Mac no other functionality will be affected ???
    Just discovered Waltr (Original) it's fantastic - iTunes it's a dinosaurs...
  11. Fishrrman macrumors G5


    Feb 20, 2009
    You probably don't want to "remove" iTunes by deleting it -- even if you don't use it.

    As you discovered, "the problem" may not be iTunes itself, but instead could be related to something you added (either to iTunes folder or elsewhere) while you were logged in.

    That's why creating a new (empty) user account will run "without the same problem".

    It's going to be "up to you" to do the detective work to find out what the "offending" piece of software is...
  12. Moly B Denim, Aug 5, 2018
    Last edited: Aug 5, 2018

    Moly B Denim macrumors newbie

    Moly B Denim

    Aug 5, 2018
    Cleveland, OH, USA
    I have a similar problem, but with a different manifestation. I'm running High Sierra on a late 2009 vintage iMac, and had a problem with the latest update of the OS. I ended up restoring from a backup, but now iTunes is misbehaving. All the music is in the screen view, but the formatting is cutting off the album and song info. The "about iTunes" window displays the required text, but it is all run together and overlaid on itself. There are no labels for the left-side windows showing playlists, etc., and the information window at the top that displays the song information is also not formatted well. I tried the Guest User approach suggested, but since I'm running File Vault the Guest is allowed access only to Safari. I'm thinking I will probably have to trash iTunes and reinstall it by disabling SIP and deleting iTunes. Having little experience with such seemingly severe actions, I'm reluctant to try it. Does anyone have any other suggestions? Thanks to all. (Edited to upload a couple screen shots.)

    Attached Files:

Share This Page