can no longer rename files in Preview?

Discussion in 'macOS Sierra (10.12)' started by edjusted, Mar 1, 2017.

  1. edjusted macrumors member

    Sep 10, 2010
    Does anyone else have this problem? It started happening for me as of 10.12.2.

    It used to be that when you have a file (e.g. a JPG) open in Preview, you could click on the file name in the window header and edit the file name. But now, if you try this and close the file or quit Preview, it no longer works. Previously, the file would've been renamed accordingly, but currently, the file name never gets updated.

    I already filed a bug report with Apple back in 10.12.2 but it's not fixed yet. Is anyone else having this problem or have a workaround?
  2. 1024724 macrumors member


    Apr 4, 2016
    Just tried it out and you're absolutely right. Interesting note though, if you add a tag the name change sticks... Ugh, c'mon Apple.

    You'd think I'd be used to Apple's sh!tstorm by now, and I am, mostly, but I'm still so incredibly fascinated by how updates keep changing and/or breaking "standard" or "fundamental" components in the OS.
  3. mailbuoy macrumors member


    Jan 16, 2014
    Davidsonville, MD
  4. FreakinEurekan macrumors 68040


    Sep 8, 2011
    Eureka Springs, Arkansas
    No issues here either, works fine in 10.12.3 and didn't have problems in 10.12.2 either.
  5. DeltaMac macrumors 604


    Jul 30, 2003
    Also works here for me with Preview in 10.12.4 beta
    No need to do anything with tags, either.
  6. edjusted thread starter macrumors member

    Sep 10, 2010
    Argh. I tried the tag trick, but it still doesn't work for me. I deleted Preview's preferences and still no go. BUT I created a new user and it *does* now, to figure out what's wrong with my main User acct...sigh...
  7. vrBrew Suspended


    Mar 3, 2017
    High life, High times
    works for me in mavericks, el capitan, and sierra.
  8. edjusted thread starter macrumors member

    Sep 10, 2010
    I found the cause! Whew...

    The cause turned out to be a hidden setting in ~/Library/Preferences/.GlobalPreferences.plist
    If NSAutomaticWindowAnimationEnabled is set to NO, then the problem occurs. If I turn it back to YES or delete that setting, renaming files in Preview *works* again.

    For those of you using something like TinkerToll or Onyx, the hidden setting is in the General area and is called "Animate opening windows".

    Very strange that a cosmetic setting should cause this kind of problem.
  9. 1024724 macrumors member


    Apr 4, 2016
    I always have the BS animations turned off. How in the hell did you track that one down?
  10. edjusted thread starter macrumors member

    Sep 10, 2010
    Lots and lots of trial and error and lucky guesses, starting with noticing that deleting the *entire* Preferences folder fixes the problem, but deleting all the individual files *didn't*, and eventually making the leap that files starting with a period don't show up.
  11. genr17 macrumors newbie

    Mar 6, 2008
    Many thanks for figuring out this issue! I was indeed able to fix it with the terminal command:
    defaults write NSGlobalDomain NSAutomaticWindowAnimationsEnabled -bool YES

Share This Page