Cannot access any Google site - help?

ozone

macrumors 6502
Original poster
Feb 18, 2004
437
31
Ontario, Canada
Hi... need some help. Today, for whatever reason, my MBP cannot access any Google site from any browser using Firefox or Safari. No Google search, no GMail, no YouTube. I either get cannot establish secure connection or connection reset error messages. I can access just about any other site however.

I can't figure out why this suddenly happened. I'm pretty sure my computer is up-to-date. I tried clearing histories, cookies, etc. My iPad can still access various Google sites, as can a desktop.

Note: I'm not at my usual location, but Google was accessible last night, so I don't know what's changed today.

I see this has happened before to others, but not lately.

Any suggestions?
 

Kissmyne

macrumors 6502
Apr 21, 2015
354
48
Make sure date and time are correct.

Change DNS server setting to rule out a DNS issue(if you need a server to connect to 8.8.8.8 and 8.8.4.4 are google public DNS servers)

Let me know if this resolves the issue for you.

If it doesn't please provide the version of OS X you are using as well as whether or not you are able to ping "www.google.com" using the network utility.
 

ozone

macrumors 6502
Original poster
Feb 18, 2004
437
31
Ontario, Canada
Odd... before I had a chance to try any suggestions... all Google sites are accessible again. I'm in a location that has hi-speed service, but I suspect it's limited (rather remote town). I was wondering if limited access was the reason, but I can't figure why it would only affect Google sites.