carolineg

macrumors newbie
Original poster
Dec 7, 2017
1
0
I have an iMac (20-inch, early 2009) running OS X El Capitan version 10.11.6

My programs are constantly closing unexpectedly and for example, with Pages, when I reopen it, the last 5 documents I had open also open.

When I try to do the Free Upgrade in the App Store to macOS High Sierra I get a message that says:

"We could not complete your purchase.
"This version of macOS 10.13.2 cannot be installed on this computer."

It doesn't give any reason on why it cannot be installed and when I click on Learn More it just goes to a page that talks about all the features available on the update.

Thanks in advance
 

Nermal

Moderator
Staff member
Dec 7, 2002
19,147
1,624
New Zealand
10.13 requires a "late 2009" or newer machine (same with 10.12). I believe that 10.11.6 is the latest that's officially supported on your machine.

I have no idea about your Pages issue.
 
  • Like
Reactions: carolineg

Fishrrman

macrumors Core
Feb 20, 2009
22,218
8,266
El Capitan is about "as far as you really want to go" on a 2009 iMac.

Your Pages problems may be related to something else...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.