"Cannot Connect to Cellular Data" Error on iPhone 4S (AT&T)

Discussion in 'iPhone' started by KPOM, Nov 3, 2011.

  1. KPOM, Nov 3, 2011
    Last edited: Nov 3, 2011

    KPOM macrumors G5

    Joined:
    Oct 23, 2010
    #1
    I'm frequently getting the "Cannot Activate Cellular Data Network" error, or otherwise can't access data on my iPhone 4S (AT&T). I'm sure a lot of it is because my office has a fairly weak AT&T signal (Midtown Manhattan). However, what's odd is that even after I get back into a strong signal area, it often won't connect to data unless I reset the network settings.

    Also, I'm finding it difficult sometimes to connect to data even when the 3G light is on and it shows 4 bars (or an RSCP in the -70 to -80 range in Field Test [enter *3001#12345#* and press "Call" on the keypad]). It will attempt to connect, or to download a message, only to time out later or just keep fetching unsuccessfully.

    Does this sound like I have a defective cellular data modem, or is it just AT&T being AT&T in NYC? My Blackberry was able to connect from the same office, so in theory the UMTS data signal is there and strong enough.
     
  2. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #2
    I'd call them to make sure all the settings are correct on their side. I've had slow data and no data in NYC, but not "Cannot Connect ..." issues.
     
  3. zekesc macrumors newbie

    Joined:
    Nov 3, 2011
    #3
    Similar Issue

    I live in central Minnesota about an hour north of Minneapolis and have had very good 3G coverage from AT&T for the last couple of years. I have, however, started noticing that my iPhone 4S consistently seems to lose its 3G signal and that when it does have the signal the data is much slower than normal. Additionally, I've noticed that my phone is having difficulty connecting to the few ATT wifi hotspots around town when in the past its automatically connected to them. By no stretch of the imagination am I in a densely populated area and only started noticing it after upgrading to the 4S but its appeared to get worse and worse in the last week... a call may be in order.
     
  4. KPOM thread starter macrumors G5

    Joined:
    Oct 23, 2010
    #4
    I was about to do just that, but now it looks fine again. Perhaps its because its the evening and there is less network traffic in Midtown? I'll monitor it and give AT&T a call if it acts up again.

    Anyway, what's the fastest speed you have gotten in the city? On Speedtest, I'm lucky to get above 1-2Mbps.
     

Share This Page