Canon EOS Utility

Discussion in 'Digital Photography' started by ill0gical0ne, Jan 3, 2008.

  1. ill0gical0ne macrumors 6502

    Joined:
    Jun 17, 2007
    #1
    I'm looking for Canon's EOS Utility because I lost my CD. I've searched everywhere and I have yet to find a copy. There's not a version available for download on Canon's website either... they're all just upgrades.

    Can someone upload it?
     
  2. scotthayes macrumors 68000

    scotthayes

    Joined:
    Jun 6, 2007
    Location:
    Birmingham, England
    #2
    have you tried downloading the updater and installing it? It's a 18.7MB file so it may be the full version.
     
  3. juanster macrumors 68020

    juanster

    Joined:
    Mar 2, 2007
    Location:
    toronto
    #3
    yeah that's what i was thinking too..
     
  4. JFreak macrumors 68040

    JFreak

    Joined:
    Jul 11, 2003
    Location:
    Tampere, Finland
    #4
    Damned! I got interested and tried to find the EOS utility download from Canon's messy website. Didn't find it, but instead I found there's a newer firmware available for my 40D and I'm torn between keeping my settings (which would mean not upgrading the firmware) or upgrading and re-setting everything. Oh, well — if it ain't broken...?
     
  5. ill0gical0ne thread starter macrumors 6502

    Joined:
    Jun 17, 2007
    #5
    In order to use the updater, you must have at least version 1.0... however, I found my CDs.
     
  6. pvellacott macrumors newbie

    Joined:
    Jul 22, 2007
    #6
    I lost my disk and I just phoned up their UK customer service number and the guy emails me the application.
     
  7. kopred macrumors newbie

    Joined:
    Nov 2, 2007
    #7
    any chance you could email it to me?

    I phoned up customer services but they said i'd have to purchase a cd!:mad:
     
  8. nthpro macrumors newbie

    Joined:
    Mar 12, 2008
    #8
    I too am screwed!

    I too am looking for the EOS utility. It seems like you should be able to download it for free...seeing as it only can help you if you have purchased a Canon camera. If someone does e-mail it to anyone here that person should torrent it.
     
  9. jerryrock macrumors 6502

    jerryrock

    Joined:
    Sep 11, 2007
    Location:
    Amsterdam, NY
    #9
    What you are proposing is against the forum rules:

    Warez/Serials/Keys. Do not post software serial numbers or keys or refer people to specific websites or software whose purpose is to break or bypass software licensing methods, distribute cracks, or obtain or use commercial software or media in violation of its license and/or for copyright violation. Do not ask for or give such help.
    :eek:
     
  10. taylorwilsdon macrumors 68000

    taylorwilsdon

    Joined:
    Nov 16, 2006
    Location:
    Bay Area
    #10
    Afaik it only helps people who would legally own the software anyways... Its included with every canon slr camera, and thats all it works on.
     
  11. jerryrock macrumors 6502

    jerryrock

    Joined:
    Sep 11, 2007
    Location:
    Amsterdam, NY
    #11
    Apparently you missed the part about the phone call to customer service who advised the poster he would have to purchase a cd.

    The EOS updater requires the original cd inserted in the cd drive to install. This is a form of copyright protection.
    ;)
     
  12. nutmac macrumors 68040

    Joined:
    Mar 30, 2004
    #12
    Although rule is a rule, since the software can only be with Canon EOS SLRs, and the software comes with every EOS SLRs, I don't understand the upgrade restriction. Canon should just mirror full version of EOS Utility (among other software) on their website.
     
  13. antirem macrumors newbie

    Joined:
    Jan 6, 2009
  14. PoloJankins macrumors newbie

    Joined:
    Jun 4, 2010
    #14
    Thanks for the work around. I tried it today because I lost my CD as well and it worked. The work around essentially takes you through a series of steps to delete the file update.plist which makes the application act as if it were the original program from the CD and not an update.

    When I got to the step that says "Delete update.plist", and hit delete nothing happened...so I had to drag it to the trash can. Once I did that and then double clicked on the original EOS Utility Application the program installed itself right away.

    Thanks a bunch.
     
  15. BWolfgang macrumors newbie

    Joined:
    Mar 11, 2011
    #15
    Simple Solution

    Download the updater, delete the file:
    UpdateInstaller.app/Contents/Resources/update.plist

    Run UpdateInstaller

    Thats It

    Credit to this guy:
    http://www.dfguo.com/?p=24
     
  16. anc2514 macrumors newbie

    Joined:
    May 8, 2011
    Location:
    Frisco, Tx
    #16
    The guy from Canon I just got off the phone with actually suggested this approach...
     
  17. johnnj macrumors 6502a

    Joined:
    Dec 11, 2008
    Location:
    Not here
    #17
    I had the same problems when I got my 1DsMk2, which came with no disks.

    I couldn't get the hack to work on the Mac version but there was a similar technique for Windows, so I did that in a Parallels VM. To add further annoyance, it wouldn't work on the latest version, just an earlier one. But then the update worked normally.

    As mentioned before, this whole thing was stupid because you can only use the utilities with Canon cameras.
     
  18. maestro72x macrumors newbie

    Joined:
    Sep 12, 2009
    #18
    - Show Package Contents of the UpdateInstaller
    - Show Package Contents of the SDI.bundle
    - delete the Contents/Resources/update.plist
    relaunch the UpdateInstaller.
    Works w/o CD
     
  19. jplew macrumors newbie

    Joined:
    Jul 25, 2011
  20. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #20
  21. SmokeMonster, Aug 1, 2011
    Last edited: Aug 1, 2011

    SmokeMonster macrumors newbie

    Joined:
    May 26, 2010
    #21
    yeah I'm getting an error message when I run EOS Utility in Lion :-(

    GLORIOUS DAY! edited to follow forum rules, but a fix for Lion is out there! follow the link where it says simple solution... trying to be cryptic and not throw anyone under the bus but it's all in there at the bottom...
     
  22. efamilia macrumors newbie

    Joined:
    Aug 9, 2011
    #22
    Can you provide more info on the Lion fix? Msg me directly if you'd like. Thanks!
     
  23. mackmgg macrumors 65816

    mackmgg

    Joined:
    Nov 2, 2007
    #23
    I have no idea what fix SmokeMonster knows about, but version 2.8 works fine in Lion. 2.9.x and 2.10.x won't launch, but the older versions are fine. It's no longer on Canon USA's site, but it's on the Canon Asia site: http://support-sg.canon-asia.com/contents/SG/EN/0200104504.html
     
  24. belsoff macrumors newbie

    Joined:
    Aug 14, 2011
    #24
    i would really like to know how to solve this. I have recently bought a canon 60d and i can'y download my pics. i tried version 2.8 like mackmgg said, but it didn't work.

    i hating lion!!!!
     
  25. Keleko macrumors 68000

    Joined:
    Mar 26, 2008
    #25
    You don't need the Canon EOS utility to download your pictures from a 60D. iPhoto and Aperture can all read them in directly. You can also just copy the .CR2 files from the memory card itself if you plug it into the Mac. I haven't used the Canon EOS Utility for a few months, even before Lion came out.
     

Share This Page