Canon LiDE25 scanner driver problem

Discussion in 'macOS' started by Julien, Jun 21, 2008.

  1. Julien macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #1
    Can't get a Canon LiDE25 scanner to work on my parent's iMac. It's running 10.5.3 and when I try to run Canon Toolbox I get the following message.

    "The necessary file could be missing, damaged, or the settings are incorrect. Reinstall the scanner driver."

    I'm using the driver and Toolbox software straight from the Canon Driver site (listed as 10.5 compatible). Have tried every combination of installing with software first and last, scanner plugged in and not plugged in with same results. Also I have a Canon LiED60 hooked to my mac pro with no problems (I was running 10.5.2 at the install time).
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
  3. TheReef macrumors 68000

    TheReef

    Joined:
    Sep 30, 2007
    Location:
    NSW, Australia.
    #3
    I assume the driver is in the drivers folder of Canoscan toolbox, could you possibly try installing the driver in Photoshop (if you have it) and maybe that would help narrow down the problem from there. (Canoscan problem vs driver problem)
     
  4. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #4
    Didn't know anything about Image Capture.:eek: Just tried on mine and it will Preview (scan) and make all changes but the {SCAN} button is grayed out. So I can't use it to actually scan to a file (how do I get it to scan?). I will see if her iMac reconizes it in Image Capture later today or tomorrow (have to do Screen Share with my mom).


    She doesn't (nor do I) have Photoshop. On my computer I looked in Applications\Canon Utilities (is this the location you're talking about?) and there are only 5 files, the program (CanoScan Toolbox 5.0) and 4 Readme.rtf files. I don't remember if I (had to) installed the driver or just the Toolbox software.
     
  5. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #5
    Just did Screen Sharing and She only has 2 files in Applications\Canon Utilities (Toolbox and one read me). Were is the driver going to?

    I tried Image Capture and it says no device found. I then went to Menu-Devices-Browse Devices and found the scanner. When I selected it I get the same message:

    "The necessary file could be missing, damaged, or the settings are incorrect. Reinstall the scanner driver."

    Then Image Capture crashes.
     
  6. TheReef macrumors 68000

    TheReef

    Joined:
    Sep 30, 2007
    Location:
    NSW, Australia.
    #6
    I don't think image capture works with these canon scanners, you'll need to use Canoscan toolbox. Make sure the driver for your scanner is in the folder Canoscan Toolbox 4.1>Plug-Ins.
     
  7. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #7
    Are you saying there should be a sub folder in the Canon Utilities folder named Plug-Ins? There is not one (or any other sub folder) on mine (or my mom's) and the Canon scanner works fine on mine. A Spotlight search on my Mac for Plug-Ins reviles only 3 folders with the name Plug-In in them (Internet Plug-ins, Disabled Plug-Ins and Internet Plug-ins (again)). What is the name of the driver file and I will try and a Spotlight search for it on mine and my mom's.

    Also we have Toolbox 5.0, which is the latest.
     
  8. pjpoon macrumors newbie

    Joined:
    Jul 19, 2002
    #8
    Reinstall driver

    Had a thought but realized after re-reading your initial post you've already downloaded and reinstalled the software
     
  9. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #9
    Many times in many combinations with driver first, software first, scanner plugged and unplugged, plus using the Canon driver removal tool with lots of Mac resets.
     
  10. karl878 macrumors member

    Joined:
    Dec 8, 2005
    Location:
    CA
    #10
    I don't own a Lide 25, I was looking into getting the Lide 90 when I saw your question. So, since I was looking at specs, I looked at the Lide 25's. If I read Canon's site correctly, the software versions you want for the CanoScan Lide 25 to work with OS X 10.5 are:

    CanoScan Toolbox for OS X (4.934X) - software utility
    ScanGear CS (11.030X) - driver

    - Karl
     
  11. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #11
    Those are the only ones I see available and the ones I used.

    I have a legacy LiDE70 that uses Toolbox 5.0.1.2 for some reason.
     
  12. masteroflondon macrumors regular

    Joined:
    Sep 17, 2007
    Location:
    London, UK
    #12
    I have the Lide 35 and had problems getting it to work on 2 iMacs. I did the obvious, install drivers then toolbox. Then I tried, as I think they suggest, the toolbox and then the drivers. It still did not work and I never knew what solved it, on either mac, but I tried a few times and it did get there in the end.

    The toolbox still complains about no drivers sometimes, and I have to quit something related to it in the process list of the Activity Monitor before retrying, at which point it works again.

    I recently found VueScan, https://www.hamrick.com/, free trial and $40 for standard version, which appears to work much more reliably than the toolbox and offers other benefits, but I have not tried it extensively yet.
     
  13. deep macrumors newbie

    Joined:
    May 18, 2007
    #13
    Same problems here

    I'm having the exact same problems here with my new Canon Lide 25. When I use Viewscan, it actually does start up the scanner, but never actually completes the scan (or preview). I'm going to try to contact Canon, but I'll bet they won't have a solution.
     
  14. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #14
    Please post what you find out.
     
  15. tweakers_suck macrumors regular

    Joined:
    Feb 7, 2005
    Location:
    Los Angeles, CA
    #15
    PhotoStudio

    Did your scanner ship with photostudio software on the install cd? If so, does that work?

    This is a copy of my Canoscan installer log file:


    Wednesday, January 17, 2007 8:17 PM Beginning installation.
    CanoScan Toolbox Installer
    Type of Install: Easy Install
    Creating the installation folder: Macintosh HD:Applications:CanoScan Toolbox 4.9
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:.DS_Store
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:AliasSet
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:basicj.ocr
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:CanoScan Toolbox X
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:cnpajaoc_carbon.shlb
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:cnrebcco_carbon.shlb
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:cnrebcre.tbl
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:cocr_carbon.shlb
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:pafcv2_carbon.shlb
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:pCat_carbon.shlb
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:Readme.rtf
    Installed Macintosh HD:Applications:CanoScan Toolbox 4.9:segment_carbon.shlb
    Wednesday, January 17, 2007 8:18 PM
    The installation is complete.

    I use this same scanner of three Macs (Intel iMac, PowerMac G4, and a PowerBook G4).
     
  16. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #16
    I never use install CD-ROM's since they usually contain outdated drivers/software and lots of bloatware. I always go to the Internet site to download the latest drivers/software with any new install. The scanner will not work with Photo Studio (or any other program) anyway because the scanner driver itself is not installing or working correctly. To top that off the LiDE25 is at my parent's house (which is 250 miles a way) and I'm doing Screen Sharing to troubleshoot.

    My theory is that the driver install program (maybe not the driver itself) in not compatible with the latest OS X update (10.5.3).

    Can anyone tell me the name of the driver file and where it should be located? Could I just move the driver to he correct folder and it work?
     
  17. tweakers_suck macrumors regular

    Joined:
    Feb 7, 2005
    Location:
    Los Angeles, CA
    #17
    Scan Gear Starter 1.1E folder

    I also have a folder called "Scan Gear Starter 1.1E" in the Appliction folder which contains the following:

    basicj.ocr
    pafcv2_carb.lib
    Readme.rtf
    ScanGear Starter 1.1E
    SGStarter.ini


    Do you have this folder?
    Also, why not try the installer CD that came with the scanner. At this point it is worth the effort to see if it works. I don't recall too much junk, but if there is you can delete it later.

    best of luck to you.
     
  18. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #18
    I'm sure she doesn't have that folder and I KNOW I don't (so it's not necessary for OS X since mine works without it) and even did a Spotlight search to see if any files or folders were on my system called ScanGear. Did a Google search and it appears to be a Windows TWAIN driver and not related to OS X.

    As far as the install CD goes, I doubt they could find it anyway.
     
  19. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #19
    Have you found out anything? I need to get this scanner installed for my parents.
     
  20. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #20
    Just downloaded/installed 10.5.4 on their iMac and still get the same driver error message. I'm at a loss at what to do.:confused:
     
  21. scaredpoet macrumors 604

    scaredpoet

    Joined:
    Apr 6, 2007
    #21
    For what it's worth, I have been unable to get an LIDE30 scanner to work properly, for similar reasons. Regrettably, Canon's OS X driver support for their scanners is HORRIBLE. :(
     
  22. nikoneko macrumors newbie

    Joined:
    Jul 20, 2008
    #22
    Canon Lide 25 Solution

    I have the same problem for months and I found the solution
    there is 2 version of the driver lide25osx11030en.dmg from canon
    the diference is the date release.

    On the US website is from Dec 6 2007, this one does not work
    on some others non-US websites you will find a Dec 10 2007 and this one does work with OSX 10.5.4 and Image capture from apple.
     
  23. Julien thread starter macrumors G3

    Julien

    Joined:
    Jun 30, 2007
    Location:
    Atlanta
    #23
    Thanks, I'll give this a try tomorrow night. Do you have a link to where the newer version can be downloaded?
     
  24. isamguy0 macrumors newbie

    Joined:
    Jul 21, 2008
    #24
    finally

    Wow, ridiculous, but solved (for me).
    I'm running OS X 5.2 with Intel Duo and my Canoscan liDE25 scanner has refused to work for months - lack of driver.
    I took the advice above and, from the main Canon global site, navigated to the same driver-downloads page for the liDE25 in various countries.

    The various countries have different updated versions of
    lide25osx11030en.dmg (the en being ENglish language)
    France's most recent works!
    lide25osx11030fr.dmg (the fr being FRench language)

    don't bother with
    United States (en.dmg)
    Australia (en.dmg)
    Germany (de.dmg)

    The one from Hong Kong looked promising as far as being the most recently updated, but the French one is working (although I get notifications in French) on Image Capture.

    SAWEEET
     
  25. nikoneko macrumors newbie

    Joined:
    Jul 20, 2008
    #25
    Canon Lide 25 Solution - note

    There is a english version "working" just look for it, I want to put it here but is illegal. Sorry
     

Share This Page