CanoScan LiDE 100 driver issue

Discussion in 'macOS' started by Pathguy, Oct 4, 2010.

  1. Pathguy macrumors newbie

    Oct 4, 2010
    Hi all-
    Frequent visitor to MacForums, but first post - ever.
    I finally and reluctantly upgraded to Snow Leopard last month (required after I got AirPort Express... but I digress). My printer (Brother 2520HN), USB 2.0hub (an old GE one) and scanner (aforementioned CanoScan LiDE) stopped working, likely due to lack of new drivers.
    I have been able to (somewhat) fix the printer, albeit with reduced printing options (no double sided prints, multiple pages per side, etc. - it works, but I'm now using a lot more paper), and got a new USB hub that works. The scanner is still OOC.
    I have looked on the Canon web site for updated drivers - none for Mac OS, and under FAQ it notes that they know there is a problem and will be releasing a new driver - "Thank you for your patience." Um... how many months/years do I have to be patient?
    I put in the scanner install disc to reinstall the old driver, only to be informed that it (the disc) is not supported by my OS.
    The Apple support site shows that the CanoScan LiDE 100 is supported by Snow Leopard. I put in the Snow Leopard install disc and downloaded all the optional items (supposedly all the other drivers), which seems to have worked for some people. After 45 minutes and a reboot... It still doesn't work. I also tried deleting and reinstalling the printer and scanner (also recommended by several sites). It (the scanner) still doesn't work.

    Any thoughts before I vent?

    Commence venting-
    I switched to Apple 3 years ago and have/had never looked back. My top two reasons: Blue Screen of Death and peripheral driver problems. Until Snow Leopard, I have not had a single issue. I had heard of issues with Snow Leopard, hence my delay in getting on board early (until forced). Ironically, one of the touted features of Snow Leopard is to FIX driver issues by continually looking for new/updated drivers. I know Apple has to support thousands of peripheral devices, fine, but when everything worked before and now doesn't, there's a problem (granted, I have a lot peripherals and most work fine - 3 cameras, 2 iPhone 4s, iPod classic, iPod touch, color printer, external hard drive, and a digital CamCorder in addition to the non/reduced functioning scanner and B&W laser printer).

    I know it's long, but short compared to the time I have already spent on this. I want stability and compatibility - we're batting about 0.500, now.
    Thanks to anyone who made it this far, just for reading, and I hope someone can help-
  2. DewGuy1999 macrumors 68040


    Jan 25, 2009
  3. Scalfani macrumors member

    Aug 2, 2007
    I had the same problem. Deleting the canon software and then reinstalling the driver and software from the canon site worked for me on 10.6.4. The buttons no longer work on the scanner, but manually opening the canon software works to scan.
  4. Pathguy thread starter macrumors newbie

    Oct 4, 2010
    Image Capture, Software

    Wow - thanks for the rapid replies!

    It does show up in Image Capture. I clicked on it it, there was a brief moment where the scanner bar moved (false hope), and then it gives me the same, "Failed to open a session on the device" that I get under System Preferences when I attempt to open the scanner (it shows up there, too).

    I don't see any Mac OS software/drivers on the Canon web site... I've looked around for some time and only see the frustrating FAQ answer thanking me for my thin patience while they update their software. Am I missing something? I'm not so egotistical as to rule it out.

    I don't think I have any other Canon software to delete (using a Spotlight search).
    Of note, I have also tried MP Navigator EX. The program also recognizes the presence of my scanner. When I click on "Scan" with the "Use the scanner driver" box unchecked, I get the rainbow ball for a minute and am then notified that it can't communicate with the scanner.

    Again - thanks for the replies and suggestions. Thus far, no joy.
  5. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Did you see these Drivers and Software on the Canon site:

    CanoScan LiDE100: Drivers & Software

    Choose Operating System: Mac OS X
    Drivers Date Posted File Size

    ICA Driver Ver.1.5.0s (Mac OS X 10.6) 07/15/2010 8.32MB

    LiDE 100 Scanner Driver Ver. 14.8.4 (Mac OS X 10.3/10.4/10.5/10.6) 04/16/2010 10.84MB

    Software Date Posted File Size

    Solution Menu Ver. 1.4.0 (Mac OS X 10.3/10.4/10.5/10.6) 01/05/2010 .69MB

    MP Navigator EX Ver. 2.0.4 (Mac OS X 10.3/10.4/10.5/10.6) 03/17/2010 30.15MB

    MP Navigator EX 2.0 Opener (Mac OS X 10.6) 09/23/2009 .22MB
  6. Pathguy thread starter macrumors newbie

    Oct 4, 2010
    I clicked the link to the site - it's the same one I've been trying. Under "Drivers" it has the following message:

    No drivers are available for this selection. This operating system may not require a driver or, in the case of older operating systems, may no longer be supported.

    The pull down menu for selecting an OS has Windows 7, Windows 7 x64, Windows Vista, and Windows Vista x64. Where did you copy the information about the drivers in your post from? Sorry if I seem thick-headed, I generally consider myself more savvy.

    I looked at scanners on the Apple store web site (if I do decide to get a new one, which would be a complete waste). The CanoScan LiDE 200 is listed there, and has been almost universally panned for this same issue (lack of Snow Leopard support). It looks like a select few have been able to get it to work, but not most. Again, if Apple is going to list it in their store, it should be readily supported. I blame both companies.

    Any further thoughts or suggestions are appreciated.
  7. Lordedmond macrumors regular

    Oct 24, 2008
    Tilchestune UK
    The lide 200 works flawlessly here with a iMac and MBP under SL fully up to date, with the Canon drivers ( buttons work fine ) and the in built drivers from Apple it will install automatically
  8. Blue Velvet Moderator emeritus

    Jul 4, 2004
  9. DewGuy1999 macrumors 68040


    Jan 25, 2009
    As Blue Velvet mentioned, that drop down menu should have a scroll bar on the right side, OS X is the very bottom selection in that menu, once you select OS X, the list of drivers and software (that I posted above) should appear in the area below it. I couldn't figure out a way to get a direct link to the results on that page. If it still doesn't show up could you try a different browser.
  10. Pathguy thread starter macrumors newbie

    Oct 4, 2010
    Got the drivers, but...

    Thanks to everyone for the support and feedback.
    I found the drivers right where DewGuy1999 and BlueVelvet said they should be... I'm starting to doubt my competence, now, since it seems so obvious.

    I installed the driver (newer one, icaosx150s.dmg, 8.32 MB posted on 7/15/10), but I still can't scan.
    The scanner still shows up in System Preferences, but now I don't see it in MP Navigator or ImageCapture.
  11. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Don't doubt your competence, Canon's web site is terrible and I've experienced it in the past where all of the page wasn't loading. So, it's quite possible that when you were there before that something wasn't working right and it wasn't all there to be seen.

    It's possible that you may not have all the necessary parts, maybe you could try downloading and installing the other selections listed on Canon's site and see if that helps any.
  12. normnode macrumors newbie

    Oct 9, 2010
    Driver Failure After Upgrade

    I upgraded to SL recently, and since then, my CanoScan LiDE 200 has been useless. I downloaded and installed the updated driver from Canon's site, but it still doesn't work.

    Investigating a bit further, I found a post on Apple's site, and was reminded that it was the workaround that fixed a similar problem when I first bought the scanner!. Here are the instructions that helped me out the last time:

    The only problem is that the driver has a bug... but here is a workaround. The driver looks for certain files with extension ".dat", which are stored as ".DAT", and it you have case-sensitive file system it will say that "Cannot write or read file". To fix this, you should open a terminal and give these commands:

    cd /Library/Printers/Canon/IJScanner/Resources/Parameters/CNQ4807
    sudo ln -s CNQ4807.DAT CNQ4807.dat
    sudo ln -s CNQ4807M.DAT CNQ4807M.dat
    sudo ln -s CNQ4807N.DAT CNQ4807N.dat
    sudo ln -s CNQ4807P.DAT CNQ4807P.dat
    sudo ln -s CNQ4807R.DAT CNQ4807R.dat

    Enter your password when required.

    This solved the problem on a Mac OS X 10.5.7. I really hope that someone form Canon will read this and include this fix in the next driver version..

    Needless to say, the same instructions don't cut it any more. Just for experimentation's sake, I created the symlinks for the files that are in that directory - with the new driver, the file names are different - but it had no effect.

    A case-sensitive file system is far from an aberration. Canon should be more on the ball.
  13. DewGuy1999 macrumors 68040


    Jan 25, 2009
    I don't believe that by default OS X uses a case sensitive file system.
  14. Pathguy thread starter macrumors newbie

    Oct 4, 2010
    Tried the drivers

    Thanks to all so far for the help-
    I tried downloading both drivers and reset the printer/scanners each time followed by a restart. I still can't scan... The case sensitive driver issue is intriguing, but doesn't seem to work.

    Again, just to be sure, I searched the Support section on the Canon web site re: Snow Leopard Canoscan drivers and got the same message:

    "When upgrading the OS from Mac OS X v10.5.x to Mac OS X v10.6 (Snow Leopard), due to the OS specifications, the scanner driver is deleted.

    Download the scanner driver supporting Mac OS X v10.6 and install it.

    However, the scanner driver supporting Mac OS X v10.6 is being prepared.

    Please wait for our software release information. Thank you for your patience."

    Sigh... It's good to know that the LiDE 200 has the same problem. It is just so ironic (in a very bad way) that a major issue Snow Leopard was designed to fix has actually been created.
  15. streamflyer macrumors newbie

    Nov 8, 2010
    Lock switch on bottom of scanner

    I banged my head against the wall when I figured out the solution to my problem: There is a switch on the bottom of the scanner which was in the "lock" position. I got the message "failed to open a session on the device". I switched the switch to the "unlocked" position and - voilà - it works!

    How in the name of ... should one figure this out???
  16. jeetendra1 macrumors newbie

    Nov 22, 2010
    Hey thanks a ton buddy ! This is how I figured out (i.e., by reading this post of yours) while googing about this same problem :)
  17. bencallis macrumors member

    Oct 21, 2007
    Wow thanks so much. Same problem here! What is the need for a lock switch under the device?!
  18. asher123 macrumors newbie

    Apr 26, 2013
    I've installed every updated drive and software, and still get the same "failed to open a session on the device"

    i'm close to throwing the device out the window
  19. DewGuy1999 macrumors 68040


    Jan 25, 2009
  20. asher123 macrumors newbie

    Apr 26, 2013
    Yup. It was working a week ago. Now it won't. Nothing changed, no software updates or anything else.
  21. DewGuy1999 macrumors 68040


    Jan 25, 2009
    Have you shut down and restarted your Mac since the scanner has been non-functional? Sometimes that will fix random things like this.
  22. MacScore macrumors newbie

    Jun 28, 2013
    CanoScan 4400f - is this the same as LiDE?

    Sorry for the stupid question - I have problems running my scanner CanoScan 4400f Flatbed scanner here in Europe, after updating to OS X.6.8 on my (admittedly pleistocene era) 2007 MacBookPro.
    I posted this query in another thread, which seemed to be relevant, but I see I should have come here first.
    Is the Canon Scanner Lide that everyone is talking about here, the same (basically) as my CanoScan 4400f? If so, then it seems as if my problem is shared by many.
    I have tried re-installing the driver and software - with the help of Canon support - but the most recent version they said they were linking me to, and which should be compatible with OS X.6.8, was _NOT_ a newer version than the CanoScan Toolbox 5 I already have.
    Any solutions? I completely sympathise with the upthread comment - close to throwing ALL devices out the window.
    Thanks in advance.
  23. DewGuy1999 macrumors 68040


    Jan 25, 2009
    The CanoScan 4400f is not the same as the LiDE series. Looking at the Canon USA site, it appears that there are the following pieces of software that are needed for your scanner:

    4400F Scanner Driver Ver. 12.13.3a (OS X 10.5/10.6/10.7/10.8)
    CanoScan Toolbox 5.0 Opener (OS X 10.6/10.7/10.8)
    CanoScan Toolbox Ver. (OS X 10.2/10.3/10.4/10.5/10.6/10.7/10.8)

    This should help with uninstalling the driver/software if you want to try again with the above files:

    Uninstalling / reinstalling the Driver and/or Software (4400F, 8600F, LiDE 600F, LiDE70)

    Did you download and install all of these? I believe that your scanner will also work with Image Capture that's included with OS X, have you tried that as well? Are you getting any error messages or is it just not showing up?
  24. mooblie macrumors 6502


    Apr 23, 2009
    The Highlands, Scotland
    Try the free trial of VueScan:

    It says the Canon 4400f (and just about any other scanner) works with it.
  25. MacScore macrumors newbie

    Jun 28, 2013
    Thank you so much for the reply! yes, in consultation with the Canon support line over here, I _did_ deinstall and reinstall all of those (either from the internet; or from my original software CD; or both...). But still, it would not work.
    I had some success with Image Capture (also bundled with the CanoScan) for about an hour, but then it, too, quit in mid-scan.
    My solution so far: took my scanner to my boyfriend's; installed all drivers and software on his Sony Vario; and worked there. Not ideal for me! I would really like to get to the bottom of _why_ Snow Leopard seems to be incompatible with certain Canon scanners.. I was seriously contemplating buying a new computer, but that seems like overkill.......
    I appreciate your help.


    Thank you for the suggestion. When I get my scanner back home - see upthread - I will try VueScan too, and report results on this forum.

Share This Page