Can't access an old Aperture library

jhall1jax

macrumors newbie
Original poster
Sep 2, 2006
22
5
I've been away from Macs for a few years but just picked up a new 5K iMac on sale. I never stopped using iPhones so I have an "active" Photos library.

I have an old Aperture library I want to access. I double-clicked it and the library was upgraded to work in Photos, but I elected to not import the photos into my main ongoing library. I just wanted to access a few pictures.

All worked great until I closed Photos for the day, then tried to re-open that old Aperture library later. Of course Photos switched back to my main library. Double-clicking on the old library just gives "The content of the Aperture library has already been migrated to Photos. Open Photos to view your library..." message. But opening Photos shows my main library not this one. And I cannot import this library either. And since it's been upgraded to work in Photos, I doubt finding an old Mac with Aperture would work either.

Any ideas? Thanks.
 

ApfelKuchen

macrumors 68040
Aug 28, 2012
3,576
2,221
Between the coasts
If the Aperture library was "migrated" there is now a new, separate Photos library. As noted, you can hold the Option key while opening Photos, or you can go into Finder to locate and open the Photos library that was created.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.