Can't access any external portable hard drive unless I restart

Discussion in 'MacBook' started by printrenori, Mar 29, 2016.

  1. printrenori macrumors newbie

    Joined:
    Oct 29, 2011
    #1
    I bought my rMB used in February, along with the Apple USB-C HDMI multiport adapter, Apple USB-C VGA multiport adapter, and Apple USB-C to USB adapter. For a long time, I could access my two fairly new external portable hard drives just fine if I plugged them in via one of these adapters. But recently, I cannot access either of my two external drives with any of the three adapters. The drives start whirring when I plug them in, and their light goes on, but they just don't show up in Finder and Disk Utility. The only way to fix it is to restart the MacBook. It's not a huge bother, but it's definitely an inconvenience, as I use my drives for many things. I don't know when exactly this started happening, but I think it was around the time I updated to OS X El Capitan 10.11.4.
     
  2. izaac_cc, Mar 29, 2016
    Last edited: Mar 29, 2016

    izaac_cc macrumors newbie

    Joined:
    Mar 29, 2016
    #2
    I have been having the exact same issue! Been using a Samsung M3 portable drive and a Kingston DataTraveler 16 GB Micro Duo Type C USB 3.1 Gen 1/USB 3.0 Flash Drive.

    The problem only seems to arise after leaving the computer asleep for a few hours. I bought the official Apple USB A to C adapter to see if it fixes the problem but no luck. Tested it with a Superdrive and mouse and keyboard which all worked fine whilst the flash drive and HDD wouldn't even show in the USB section of system information. I contacted support, did an SMC reset, reinstalled the OS and took it into the Genius bar today who confirmed the problem but couldn't figure out what was causing it.

    As mentioned restarting the machine makes the problem go away but then it comes back so they said it must be software related.

    I've gone back to 10.11.3 which seems to be holding up fine in the meantime but everyone I spoke to through Apple Support seemed stumped.
     
  3. printrenori thread starter macrumors newbie

    Joined:
    Oct 29, 2011
    #3
    Oh man, that's disconcerting. I guess I'll just wait and hope that Apple fixes it in the future.
     
  4. burgman macrumors 65816

    burgman

    Joined:
    Sep 24, 2013
    #4
    Have you tried unplugging the adapter, connecting the hard drive then plugging in the adapter? This is how Apple says to do it.
     
  5. IowaLynn macrumors 6502a

    IowaLynn

    Joined:
    Feb 22, 2015
    #5
    Same thing happened and also using Apple HDMI adapter.

    Also those pesky messages about hdd not ejected properly.

    Makes me miss Windows 10, but not enough to go back, but scared for the HFS* directory
     

Share This Page