Can't CLICK on notifications - is it just me?

Discussion in 'macOS Sierra (10.12)' started by benface, Sep 22, 2016.

  1. benface macrumors member

    Joined:
    Feb 28, 2012
    #1
    Since upgrading to Sierra, every time I have a new notification (for instance Messages or Mail are the most common, but also Slack and other apps), I try to click on it but nothing happens. It used to close the notification and bring up the app, but now it doesn't do anything and it's really annoying; I have to manually switch to the app to see the message/act on it. Is this a bug, or by design? Anyone else has this issue?
     
  2. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #2
    Not just you, I noticed this as well on my 5K iMac. A bit annoying.
     
  3. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #3
    I saw that earlier today, so you're not alone. It must be a bug.
     
  4. Starfia macrumors 6502

    Starfia

    Joined:
    Apr 11, 2011
    #4
    I've had some of these too – I'd only just noticed this evening.
     
  5. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
  6. benface thread starter macrumors member

    Joined:
    Feb 28, 2012
    #6
    Apparently it's not happening on all Macs, as my girlfriend's 5K iMac doesn't have this problem. (Also judging by the lack of replies to this thread and the fact that I couldn't find anything about this issue online...)

    I myself don't have any problem with notifications on iOS 10.
     
  7. Tarek macrumors 6502

    Joined:
    Jun 25, 2009
    Location:
    Cairo, Egypt
    #7
    I have only just tried with Facebook notifications and it works fine so I am not sure if it's a common problem or if you're just unlucky.
     
  8. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #8
    Yeah, it was present in 10.0.1, but seemingly was fixed in 10.0.2.
     
  9. j4cq macrumors newbie

    j4cq

    Joined:
    Sep 29, 2016
    #9
    This is happening to me too on my MBP - has anyone had any luck fixing this?
     
  10. UntitledImage macrumors regular

    UntitledImage

    Joined:
    Oct 2, 2015
    Location:
    Tampa, FL
    #10
    Same here, it isn't constant though. Sometimes it works, sometimes it doesn't. Also noticed I can't click to enlarge photos in the photos app sometimes. Wondering if it's some kind of click or double click speed issue?
     
  11. benface thread starter macrumors member

    Joined:
    Feb 28, 2012
    #11
    Interesting. I did notice an annoying difference in the behaviour (compared to previous versions) when double-clicking on text to select it, at least in some applications such as Sublime Text. It occurs for instance when some text is already selected and I want to select the whole thing instead. It used to be that I could click on the selected text once to unselect it, and then double-click to restart the selection process. But often the unselect fails now and I have to click somewhere else to "start over" because the double-click doesn't work either... Anyway probably a subtle difference that I'm not yet used to and not a bug, but I'm wondering if it could be related.
     
  12. KoolAid-Drink macrumors 65816

    Joined:
    Sep 18, 2013
    Location:
    California
    #12
    Okay, I take it back. It was seemingly fixed in 10.0.2., but sometimes it comes back.

    As for macOS, haven't really tried it but seems okay so far?
     
  13. dadiduekappa macrumors regular

    dadiduekappa

    Joined:
    Mar 15, 2013
    Location:
    Naples - Italy
    #13
    Same here. Click on a notification banner cause notification disappear but the mac not open Facebook or Twitter pages on Safari.
    Anyone figured how to fix this?
    --- Post Merged, Oct 9, 2016 ---
    Just figured out! Delete and add again Facebook and Twitter account from your mac and notifications started working again!
     
  14. remembrancenn macrumors newbie

    Joined:
    Dec 24, 2013
    #14
    I have exactly same thing with notifications and images preview. Some times it work, but some times not. (usually not)
    I was thinking it will fixed with 10.12.1 but it is not...
    Have someone solution?
     
  15. flapjacksnbuttah macrumors newbie

    flapjacksnbuttah

    Joined:
    Dec 29, 2016
    Location:
    Savannah, GA
    #15
    Happening to me and a buddy suggested that it might be due to an external mouse (turning off my magic mouse seems to fix it). So definitely seems like a bug.
     
  16. jer77od macrumors newbie

    Joined:
    Apr 17, 2011
    #16
    This seems to sorta kinda work. It does work but it seems the triple or quadruple click seems to only work. I might play with my double click settings. Will post again if I find out but other fixes would be appreciated. Until then, this seems to be a temporary fix. I have also been having this issue and it's driving me crazy. I even reformatted and put on a clean OS (not because of this) and the issue remained. The biggest issues for me is WhatsApp, Goofy, and the Mac Messenger.
     
  17. breadadams macrumors newbie

    breadadams

    Joined:
    Mar 16, 2016
    #17
    It seems that even with magic mouse turned on, using the built in trackpad to click on a notification opens it.

    It just doesn't open from external mouse clicks.

    Weird :confused:
     
  18. mmerritt macrumors newbie

    mmerritt

    Joined:
    Apr 26, 2017
    #18
    Exactly what is happening to me, really annoying.
     
  19. h9826790 macrumors 604

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #19
    I found that double click works.
     
  20. sguilliard macrumors newbie

    sguilliard

    Joined:
    Jul 4, 2017
    #20
    Has there been any resolution to this? I have the same problem: clicking notifications (such as email) works from the trackpad on my MBP but not from the external magic mouse... :-(
     

Share This Page