Can't connect to iPhone using Fugu or WinSCP...

Discussion in 'Jailbreaks and iOS Hacks' started by mr.stinki, Mar 8, 2008.

  1. mr.stinki macrumors 6502

    Jan 25, 2008
    I've tried reinstalling open SSH, but i still can't connect, this is what i'm using:

    Host name: my IP address
    User Name: root
    Password: alpine

    This is what i get on fugu:

    ssh: connect to host ###.###.###.### port 22: Connection refused

    And this is what i get on WinSCP:

    network error: Connection refused.

    I'm running firmware 1.1.3 if that helps...
  2. jav6454 macrumors P6


    Nov 14, 2007
    1 Geostationary Tower Plaza
    Use iBrickr
  3. matrage macrumors newbie

    Mar 31, 2008
    I fixed this problem here is how

    I was having quite the problem as of late. After going crazy installing applications and games. I tried to move some ROMs over to my touch but i could never connect via SSH I would always get Connection refused error and it would never let me connnect. I know the touch was on the network because I could ping it but could never connect to it. This was driving me nuts as I could do it on my 8 GB but now I have a 16 so I was going insane. Then yesterday my installer stopped installing apps. I would choose something to install it would download the source, install it and then I would never see any of the apps I downloaded. Convinced it was the 1.14, but after some digging around I found a fix that solved both of these problems.

    “The memory space on the iPod Touch/iPhone is broken into two partitions - the first partition contains the operating system/firmware/applications and is FIXED at only 300MB. The second partition contains your media (music, videos, settings, etc.). What you need to do is free space on your first partition and/or move your applications to your second partition.” - DerekVOF from iLounge

    This was how I solved the problem with the help of boss tools. Boss tools will move your apps to the second partition where there is lotsa room. I am sure this would work on a iphone as well

    1. Uninstall all installed apps. (Drag yes I know)
    2. Download Boss Tool repo source
    3. Run boss tool
    4. Select Free Space
    5. Move Fonts
    6. Move Ringtones
    7. Move Apps
    8. Restart device
    9. Install OpenSSH
    10. Finished

    After doing all this, everything was fine! My installer worked again I was no longer getting the mind numbing connection refused error when I tried to connect via SSH.

    I have a feeling SSH requires some space on the 300 MB partition when it initially connects and when it cant find any it refuses the connection

    Now time to play RBI Baseball on my touch!

Share This Page