Resolved Can't connect to my website externally anymore!

Discussion in 'Mac OS X Server, Xserve, and Networking' started by tevion5, Jan 17, 2014.

  1. tevion5, Jan 17, 2014
    Last edited: Jan 26, 2014

    tevion5 macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #1
    I host a website from my mac at the address www.snoviet.com. I have been doing this for around a year now. However I am building a completely different site and wish to replace the current one.

    I was trying to network with an OS 9 machine recently and went into terminal with a few "sudo" commands (http://support.apple.com/kb/ht4700) that directly affected networking. I have since restored the defaults as per a guide on Apples own support page, but I suspect it it since then that I am no longer able to connect. It was working perfectly only 3 days ago but now its just broken! :(

    I can connect to the site from any computer in my local network via my "macbook.local" address. Therefore Server.app must be hosting the site properly but something else is blocking it form being seen externally. I have tried "ping'ing" my domain and my external IP registers always, meaning my DNS is fine. All ports are open for website as per Server.app requires.

    One funny thing is that I think my extreme has recently forgot all it's other ports to open as I have a few open usual for other services, but all I see currently is JUST my website, which does not work externally.

    - I am running Mac OSX 10.9.1.
    - I am using the Mavericks Sever App (v.3)
    - My site address is www.snoviet.com
    - My external IP is 86.43.85.255
    - I can connect locally.
    - I have an AirPort Network with x1 Airport Extreme and x3 Airport Express.

    This setup usually works without issue and has been for nearly a year.

    I would be delighted for any help at all, I'm really annoyed because I have no idea what to do. Everything "seems" to be fine separately but it just doesn't work :confused:
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #2
    Use your time machine setup to backup to previous setting that worked?
     
  3. mac8867 macrumors 6502

    Joined:
    Apr 5, 2010
    Location:
    Saint Augustine, FL
    #3
    First off, that is not your external IP address... the last octet of 255 is a "broadcast" octet. Check your IP address again with whatsmyip.org and get the correct address.

    1. Verify you can connect to your site with the external IP address. (I bet you cant). This would be the url: http://86.43.85.xxx

    2. If you can not get the site to open with that URL, then, the issue is in your router configuration, not your server. You have not set up the port forwarding to the INTERNAL IP address of your server properly. You need to open your Airport Utility app and set port 80 to forward to the server.

    3. If you can get to the site with that URL, then the issue is with your domain registrar. You need to go to their administration site and set your DNS record to point to the 86.43.85.xxx address.
     
  4. tevion5 thread starter macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #4
    Thanks for the reply, you seem to know what you're talking about.

    Yes I am aware my URL is not my IP, I have of course tried both and gotten the same result. It loads for too long and then says it can't context the server.

    I did suspect it was the router at fault alright, so your suspicion is good to here. The strange thing is though that I set it all up Server.App and an AirPort Extreme so all the port string should go automatic. An when I go to airport utility I can see port 80 and another one are open for "Website".

    Any ideas? Maybe reset my AirPort Extreme?
     
  5. HenryAZ macrumors 6502

    HenryAZ

    Joined:
    Jan 9, 2010
    Location:
    South Congress AZ
    #5
    That blanket statement is true if the mask for the subnet is /24. If the subnet is masked at /16, for example, then his address could very well be correct, as only 86.43.255.255 would be the broadcast. Any address of the form 86.43.xxx.255 would be routable, as long as xxx is not 255,.


    ; <<>> DiG 9.9.4-P2 <<>> www.snoviet.com
    ;; ANSWER SECTION:
    www.snoviet.com. 3209 IN CNAME snoviet.com.
    snoviet.com. 1366 IN A 86.43.85.255
     
  6. edjs macrumors newbie

    Joined:
    Jun 15, 2012
    #6
    Is the router explicitly set to forward ports 80 and 443 to the server's IP address on the LAN?
     
  7. tevion5 thread starter macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #7
    Resolution!

    I factory reset my Airport Extreme and set it up from scratch. Reinstalled Server.app and set up as new. Then I went to airport utility and manually entered ports 80 and 443 and.....

    Eureka! :D

    This worked for me so if anyone finds them self in the same situation, give it a shot. :)
     
  8. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #8
    Sure that IP is unchanged? Did you buy a static IP address? IP addresses can be unchanging for a long time and then suddenly change if you didn't pay for a static one.
     
  9. tevion5 thread starter macrumors 68000

    tevion5

    Joined:
    Jul 12, 2011
    Location:
    Ireland
    #9
    I of course have a static IP, and external DNS tests always arrived at my home. It wasn't the DNS, or the IP or Server.app. Just an airport extreme that needed to be reset for some reason! :)
     

Share This Page