Can't get calls to forward to ipad

Discussion in 'iOS 9' started by kmichalec, Jul 22, 2015.

  1. kmichalec, Jul 22, 2015
    Last edited: Jul 22, 2015

    kmichalec macrumors 6502a

    Joined:
    Aug 14, 2010
    #1
    I have both my iPhone 6 and my iPad Mini 2 on iOS 9 public beta 2. But for some reason, I cannot get my phone to forward calls to my iPad like is supposed to happen in Continuity. I don't even have any settings under FaceTime on my iPad for any call forwarding options. Both devices are on T-Mobile, but at the moment, both are even on the same wifi network at the moment, and still not luck.

    And yes. "Allow calls on other devices" is turned on in the phone settings, and both the iPhone and iPad are logged into the same iCloud.

    And under Allow Calls On, down below, the only option it shows is Apple Watch with a toggle on. Isn't it supposed to show all devices logged into the same iCloud account here with an option to turn each on/off?

    Any ideas? Am I missing something?
     
  2. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #2
    On your phone Settings > Phone > Calls On Other Devices. Make sure your iPad is listed in there.
     
  3. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #3
    It's not listed (I was just updating my original post to state that, ironically).

    Any idea why it would be showing there?
     
  4. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #4
    No matter what I try, I cannot get the iPad to show up as a device on the iPhone under the Calls On Other Devices section. The only thing that shows up for me is my Apple Watch.

    Has anyone else been able to get their iPad to show up here along with their Apple Watch?
     
  5. techiegirl macrumors 6502a

    techiegirl

    Joined:
    Sep 7, 2007
    #5
    My iPad is listed on my iPhone and I still can't receive calls on my iPad.
     
  6. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #6
    Still can't get the ipad to show up on the iPhone as apotential device to forward calls to. Attempting to reset and reload the iPad to see if that does anything.
     
  7. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #7
    Even more interesting. I unpaired my Apple Watch from my phone. When I did, the Settings->Phone->Calls On Other Devices section completely disappeared from my phone. Now not only do I not have the Allow Wifi Calls under the Facetime settings on my iPad, but now the whole Calls on Other Devices section is gone from the iPhone.

    Both are running iOS 9 Public Beta 2, both logged into the same iCloud account.

    WTF???
     

    Attached Files:

  8. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #8
    Did you verify on the iPad in settings-facetime that "Calls from iPhone" is on?

    If so, log out of iCloud on your phone and iPad and login again and check.
     
  9. kmichalec, Jul 24, 2015
    Last edited: Jul 24, 2015

    kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #9
    Hi gsmornot,

    That setting is not there on the iPad either. That line is completely missing. It was there on iOS 8.4, but has disappeared upon the upgrade to iOS 9 Public Beta 2.
     

    Attached Files:

  10. kmichalec, Jul 24, 2015
    Last edited: Jul 24, 2015

    kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #10
    Deleted. Accidentally double posted. (How do you delete a post in the new forum format??)
     
  11. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #11
    Ok. Strange. I logged out of iCloud, iMessage and Facetime explicitly on both my iPhone and my iPad again, then did a soft reset (Home + Power) on both devices. Upon coming back up, logged into iCloud on both devices, then iMessage on both devices, and then finally Facetime on both devices. Upon completing these steps, now the settings are there on both devices, and I can now turn on my Apple watch and iPad mini as devices calls are allowed to forward to and it all seems to work. Very strange.

    Thanks for the help from everyone!
     
  12. gsmornot macrumors 68030

    gsmornot

    Joined:
    Sep 29, 2014
    #12
    You did it. I wanted to suggest this but I felt like I would sound like the first step in every manual. logout and reboot. It worked though, and glad it did. Now you can ignore your iPad when it rings like I do. I have my phone or watch closer nearly every time and just take the call on one of those but do like the option. :)
     
  13. kmichalec thread starter macrumors 6502a

    Joined:
    Aug 14, 2010
    #13
    Thanks gsmornot.

    The strange thing was, I did log out of iCloud on both my iPhone and iPad, and rebooted both before, but it didn't fix it. It wasn't until I logged out of iCloud AND Facetime and iMessage on both and rebooted that it worked.

    I'm sure the novelty of the call forwarding will wear off eventually too. At this point, it was more about the principal of getting it working. I'm hoping with WatchOS 2, the Watch will be able to break away from the phone as long as the watch can connect to the internet via wifi. For example leave my phone in the car while at the gym, and just wear the watch hooked up to the gym wifi. That would be convenient...
     

Share This Page