Cant get past Blue screen in Mac mini 10.6.8

Discussion in 'Mac mini' started by Rangdrol, Aug 10, 2012.

  1. Rangdrol macrumors newbie

    Rangdrol

    Joined:
    Mar 26, 2008
    Location:
    Montreal, Quebec
    #1
    Started having problems with Time Machine. Then Finder.app died.

    I got this message:

    "The application Finder.app can't be opened. -10810."

    As a result, I couldnt see any of my icons on my desktop, including my hard drive, and external drive, and had already replaced finder.app.plist and then found a fix by pasting this in Terminal:

    /System/Library/CoreServices/Finder.app/Contents/MacOS/Finder & disown

    This seemed to work, bringing my icons up, and all seemed well, and then I rebooted but have not been able to log back into system.

    None of Startup key combos work, at all. Only Single User mode, and I cannot load Install DVD either.

    Holding Option key allows me to connect to Airport?? and shows me an icon of my Hard Drive with an arrow beneath the icon. Clicking on the hard Drive starts up system, but again, hangs at blue screen.

    When I first rebooted after running Applejack, I got this message: Waiting for DSMOS...

    This, according to a reader, means "Dont steal Macintosh Operating System" and is Apple system proprietary software of some sort. This is not a stolen Mac Mini (late 2010) even though it is made in China. Seems like something Apple puts in its computers.

    I tried a fix by Carl Norton of Fix-KB.com, entering this string in Terminal:

    sudo chown root:admin /

    The returned message was: sudo: can't open /etc/sudoers: Resources temporarily unavailable

    I then tried to empty trash, a fix, : sudo rm -Rf ~/.Trash/* and got this message: "sudo: can’t open /etc/sudoers: Resource temporarily unavailable."

    Then tried another fix: sudo audit -t

    I tried another repair by trying to delete Finder preferences in Single-User Mode: /sbin/fsck -fy

    Again, blue screen, so tried another attempt with : /sbin/mount -uw /

    And again, another attempt: rm /Users/shortname/Library/Preferences/com.apple.finder.plist


    and: rm /Users/shortname/Library/Preferences/com.apple.sidebarlists.plist

    I read that "A Safe Boot deletes the dynamic loader shared cache at (/var/db/dyld/). A cache with issues may cause a blue screen on startup, particularly after a Software Update. Restarting normally recreates this cache."

    However, I have done several Safe Boots, (Holding down the Shift key on reboot) and nothing happens.

    Shift, Command-V did absolutely nothing.

    In reading, it appears that the problem MAY be linked to "launch services in OSX" and in particular with Snow Leopard, which is what I am running 10.6.8, then I tried this fix, entering this string by Topher Kessler on CNET reviews.

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed -rfv -all user, system, local

    This then spit out this:

    lsregister [OPTIONS] [ <path> ... ]
    [ -apps <domain> [,domain] ... ]
    [ -libs <domain> [,domain] ... ]
    [ -all <domain> [,domain] ... ]

    -kill Reset the Launch Services database before doing anything else


    (and then it continued to pump out what looked like instructions to the codes. I did a shutdown -h now, and then restarted and nothing happened, I am still stuck on a blue screen.

    I wonder if any of you have used these strings, which are supposed to repair the issues with "launch services:?

    rm -i ~/Library/Preferences/com.apple.LaunchServices.plist

    rm -i ~/Library/Preferences/com.apple.LaunchServices.QuarantineEvents

    rm -i /Library/Caches/com.apple.LaunchServices*


    The first command and second strings asked me for a confirmation so I entered "y" for yes, and it gave me:

    "rm: /var/root/Library/Preferences/com.apple.LaunchServices,plist: Read-only file system"

    I don't know if that means it removed them, and it is confirming, or if it is telling me it cannot remove them because they are read-only files?

    Entering the third string gave me "No such file or directory"

    I then rebooted to see if this had fixed my problem. It did not.

    I have noted that there are other issues:

    When i open Terminal, the prompt is no longer $, but is :/root#.

    I've been using Apple since 1986, and I have always been able to at least reboot or reinstall from startup disks, but not in this case.
     
  2. philipma1957, Aug 10, 2012
    Last edited: Aug 10, 2012

    philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #2
    So you have a 2010 mac mini with snow leopard disks and you had a time machine. You are clever enough to do all that terminal command entry.

    Are you clever enough to have a clone backup on an external hdd?

    Because that is the best way you to fix your machine. If you don't have a clone you will need a friend with a clone of a 2010 snow leopard install. I have a 2010 mac mini and it has become really difficult to do a fresh install from the included disks . I have 2 clones one with the 10.6.4 fresh install and one with the 10.6.4 fresh install upgraded to 10.6.8 via the apple update. I Hope some one can give you a hdd with a clone to boot your machine. Good luck.
     
  3. Rangdrol thread starter macrumors newbie

    Rangdrol

    Joined:
    Mar 26, 2008
    Location:
    Montreal, Quebec
    #3
    Hi agian


    Thanks again, Phillip.

    I don't have a clone disk, I never thought I would need one because I've always been able to fix most any problem with original install disk. However, I'm now forced to use my G4 laptop with 10.3.9 because I threw away my 4.0 CD.

    In any case, I am hoping that upgrading to Snow Lion will do the trick. Thanks for your help, again.
     
  4. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #4
    let me know If you get it working.

    If you can't get it to work pm me.
     
  5. shankar803 macrumors newbie

    Joined:
    Mar 9, 2013
    #5
    Blue screen

    I started my Mac usually. The normal gray screen with Apple logo appears, followed by the loading wheel's antics. I get past them without any glitch (I believe). Then the screen remains gray for a few seconds minus the logo, and changes into the Blue screen, and this is where my problem comes. I'm stuck at the Blue screen, and the desktop never loads.

    Interestingly the screen flashes between blue and gray and back once, after which my Mouse Cursor appears, and I'm able to move it around, however without anything to click but the blank Blue screen.

    I did not backup my data. What do I do now? Can I recover my data?
     

Share This Page