Can't get SSD in new Mini working

Discussion in 'Mac mini' started by ndriver182, Feb 8, 2012.

  1. ndriver182 macrumors 6502a

    Joined:
    Jun 26, 2007
    #1
    I've got a 120gb OWC Electra SSD that I was using on an older Mac Mini just fine. I removed the SSD a month or two ago when I sold the Mini. I just received my new i7 Mini and bought the iFixit dual hard drive kit to install the SSD as my primary drive so I could use the 500gb default drive for storage. The first thing I did was open the Mini to install the drive before even booting up the machine for the first time. The install physically went fine. When I booted up the computer is when I started having issues.

    OSX loaded up and told me it found a drive it couldn't read (the SSD) and told me that it had to be initialized. No big deal since I was going to wipe it anyway and restore it with a Time Machine backup I'd made previously. I entered disk utility and noticed that when I told it to partition the drive, it would get about half way then just tell me it was partitioning and would take "X" number of minutes. The problem is the time frame wouldn't decrease, but rather increase minute by minute by minute and then the computer would even eventually go to sleep after being inactive. Clearly something is not right.

    I then noticed that instead of the drive being a GUID partition format, it was set up as an MBR. The disk partition (disk0s1) is also showing in red letters. It tells me that the drive does not have a valid partition table. I have no idea how that happened since I never used it in a Windows machine or dual booted with that drive. It was an OSX only drive. I now seem to be having an issue where I'm unable to format the drive to a GUID partition table in the "Options" menu on the partition tab of disk utility. It just hangs during the process. It partitions, but then it says it is waiting for the disk to become available and just hangs there forever until you eventually have to force quit disk utility.

    Interestingly, there are random times when I have somehow been able to seemingly get the drive formatted as GUID and I can even access it in OSX. Then when I reboot the computer into recovery mode to attempt a new Lion install, the drive shows up as MBR again. Then I somehow manage to get it to be GUID again and it lets me choose the drive as an installation destination, but constantly times out on the Internet download. I assume this is happening because it's having a hard time writing the download file to the SSD (I know the Internet works because when I'm booted into OSX I can surf the web just fine using wifi or ethernet connection).

    I also tried using gParted based on another suggestion and I was able to create an Apple partition table and then format the rest of the drive as HFS+, however I would still run into the issue of not being able to install Lion from the Internet recovery option and I get the error stating my connection it too slow, etc. When I was able to somehow get the drive formatted with a GUID partition table, I would run the "verify disk" and "repair disk" options, it would tell me that it found minor issues and repaired them, but then I noticed I was algo getting an error stating "Invalid B-Tree node size" and wouldn't let me repair it.

    Anybody have any tips? I don't think the drive is bad, but I just can't seem to find the right combination of procedures to go through to fix it. I'd really like to get my SSD back up and running asap. I thought I'd be able to just pop it in, format, and restore. I guess nothing is ever easy... as usual :rolleyes:
     
  2. CoolmaxMini macrumors member

    Joined:
    Jan 22, 2012
    #2
    You need to format it on a USB external case, install LION and make sure it can boot off it. Firewire case I found is not reliable enough unless you supply an external power source to it. And then, it is when you would install it inside the Mac Mini. If you do it your way which I did mine the same, it just won't work or stalls for some reason with some SSD with SandForce controllers which I assume your OWC is.
     
  3. ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #3
    I do have an external USB caddy that I can pop the SSD into. So all I should need to do is remove the OWC SSD from the Mini, install it into the external case, then attempt to format it with Disk Utility and it shouldn't hang up? I'll see about giving this a shot after work. I guess I still don't understand, from a disk formatting perspective, how it makes a difference if the drive is formatted when installed in an external USB case vs being directly connected inside the Mini itself. If that's what it takes I'll do it :D I just don't understand the reason behind it.
     
  4. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #4
    this is a very simple item to own.


    http://www.newegg.com/Product/Product.aspx?Item=N82E16817153066

    why own it ?

    You are doing diy all diy pc/mac people need something like this unit

    it is lost cost and it helps solve problems like yours.

    it also handles 2.5 inch and 3.5 inch drives.

    pull the ssd and try to partition it on the t take then

    you create a good boot image on the ssd .

    boot test it while it is in the thermaltake. then install it in the mini.
     
  5. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #5
    It probably wouldn't hurt to leave the SSD out after you remove it, then boot up the mini from its factory drive and update Lion. (My new i7 2.7GHz mini that I received at start of January was behind on several updates.)

    There's a possibility it could be a bug that has been fixed (Lion updates could rule that out), a procedural problem somewhere, or something flaky with the SSD drive itself, or even something flaky with the mini ... or the cable you're using to plug the SSD into it.
     
  6. CoolmaxMini macrumors member

    Joined:
    Jan 22, 2012
    #6
    Yeah, I am not sure why too. I got a response from Apple saying that the reason is yours not an Apple SSD drive.
     
  7. ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #7
    I think I should be clear about a couple of things:

    I am trying to ultimately install Lion on the SSD as I want this to be my main drive for the OS and applications. I just need to run the Lion recovery to install on this drive and not the stock 500gb HD that came with the unit. The 500gb is only going to be used for media storage.


    Also, the support tech at OWC told me to try swapping drive positions inside the Mini and try again. I had actually installed the drives in position as per the iFixit guide (which I did also on my prior Mini), but if I'm going to rip the whole Mini apart again to get at the drives, I might as well plug it in to the USB enclosure and go that route I think.
     
  8. CoolmaxMini macrumors member

    Joined:
    Jan 22, 2012
    #8
    Yes, I understood your question. Remember that I have 2 SSD drives inside the Mini Core i5 and both can be formatted by the Mini using the internal SATA ports. I also started out with 1 SSD and 1 stock 500Gb stock drive and experienced the same issue as yours. Yes, swapping does help but it is a 50/50 chance that even swapping ports will not work -- I tried. However, it is not difficult to take the whole Mini apart either. I have the same iFixit kit as yours and they should give you a metal U shape bar to help you slide the motherboard out completely. I had taken the Mini about 15 times apart trying out different drive combos; what works and what does not. The easiest way is the USB clone and then you place it back into the Mini.

    Why do you just clone the stock 500Gb drive to your SSD, assuming the 500Gb is currently not filled up with anything? That is what I did on 2 spares SSD drives I have in the event the 2 internal ones die on me.
     
  9. ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #9
    It's brand new so I don't have anything on the 500gb. I just figured I'd start out with a brand new Lion install on the SSD and then do a TM restore to get all my old files back. As far as cloning goes, I suppose I could do that and just do a TM restore of my files after the fact. I don't even know how to do the cloning anyway.

    Regardless, I know I'm going to have to take the Mini apart again. It's not that big of a deal. I'm pretty comfortable with it since I've done it a few times.
     
  10. ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #10
    Got the SSD out of the Mini and into the external USB caddy. Reassembled the Mini with only the stock Apple HD and was able to format the SSD via USB in no time. It worked as you'd expect. I am now in the process of installing Lion by Internet recovery via USB. So far so good. We'll see how this goes. I'm really regretting not knowing this information ahead of time, but I guess live and learn...
     
  11. ndriver182, Feb 8, 2012
    Last edited: Feb 8, 2012

    ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #11
    Well, once again I've hit a wall. I have no idea what happened, but I fear the prognosis is not good. Lion downloaded and installed on to the SSD just fine. When the Mini rebooted, it did so off of the SSD automatically. Everything was working great. I decided to re-install the SSD back into the Mini itself at that point and that's when things got ugly.

    When I installed the SSD back into the Mini, I opted to leave the stock HD plugged in as well. When I put everything back together and booted up, the Mini decided to use the stock HD as the default boot disk. No big deal. Once I reached the desktop, it saw the SSD, but then it told me the drive was unrecognized and needed to be initialized. What?!? I just went through the whole process of formatting and installing Lion on it! Now I'm thinking maybe it's just a bad SATA/power cable from iFixit that was causing the issue.

    I pulled everything apart... again... and decided that before I try the stock Mini SATA cable on the SSD (not using the stock HD at all for testing purposes), I would plug the SSD back into the USB caddy just to see if the disk showed up with Lion installed or if it would show as needing to be initialized again. Here's where the real bad news lies. After booting up the USB caddy, the SSD does not show up at all. No prompts for initialization. Doesn't show up in Disk Utility. Rebooted and booted from my gParted USB drive and it doesn't show the SSD either. Tried unmounting and restarting my USB caddy multiple times with no results. The same USB caddy has a 2TB drive connected with my TM backups and it pops up just fine on the desktop, Disk Utility, gParted, etc.

    I have no idea what happened. I didn't do anything at all except shut down the computer after I received that prompt to initialize the drive so I could do some further troubleshooting. Now I get nothing at all. I have a sinking feeling that somehow the drive is toast. If that's the case I'm going to be seriously upset. I'm already more than annoyed at this whole situation as-is. :mad:

    *EDIT*
    Perhaps I spoke too soon. I just plugged the SSD into the port that my 2TB drive was plugged in to and it shows up as an external drive in Lion. Stay tuned...

    *EDIT 2*
    Installed the SSD into the Mini as the only drive using the stock Apple SATA cable. Mini boots up just fine with the new install of Lion I just did. Looks like the question now is whether or not the stock drive will work using the iFixit cable. If it doesn't, maybe this whole mess was a result of a bad cable.

    *EDIT 3*
    For whatever reason, the stock HD seems to work fine when plugged into the iFixit SATA cable in the secondary position in the Mini. The drive shows up just fine with no issues. Now I show BOTH drives on the system and the SSD is the main boot drive. I've buttoned up the Mini and I'm going to keep my fingers crossed that everything will work as I hoped now.

    Hopefully all of this helps somebody. I'll be back if something comes up... Thanks to everybody for their help so far.
     
  12. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #12
    Sounds like you've had some fun!

    Thanks for the updates.
     
  13. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #13
    Now you know why that external drive case can help. I have seen minis do some weird things. since 2006 I have had close to 200 in my home. Only 2 or 3 were truly Dead. 10 or 15 have been loopy or punch drunk for one reason or the other. Those I was able to get working fully.

    Watch that machine and keep very good backups.

    as a complete and total aside I am getting my seagate thunderbolt adapters shipped this friday(seagate emailed me today). if these work as i hope they will putting in hdds or ssds will not be as important.
     
  14. shortcut3d macrumors 65816

    Joined:
    Aug 24, 2011
    #14
    I've seen similar issues and replicated the problem by deleting the hidden GUID parition in Windows 7 on drives formatted as GUID Partition HFS. One would think this would not have an impact on a drive fully partitioned with MBR NTFS, but it does. If OSX or Disk Utility put the hidden GUID partition on the drive leave it alone. In this case, it could have become corrupt while trying to install OSX the first time.
     
  15. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #15
    Along these lines I have a done 7 pass and canceled the erase in the middle of the third pass. This has helped fix a few ssds. Of course it also will age an ssd as only so many over writes can be done.

    (but a little bit older is better then fff'n dead!)
     
  16. ndriver182 thread starter macrumors 6502a

    Joined:
    Jun 26, 2007
    #16
    Yeah, it was a total blast... :rolleyes:

    Haha. I'm just glad the "pain" is overwith and I can actually use my new Mini the way I want to. This thing hums right along now with the SSD working properly.
     
  17. Chf macrumors newbie

    Joined:
    Jan 12, 2014
    #17
    Had the same problem - swapping drives is enough to solve the problem

    Hi, I ran into the exact same problem yesterday, and this thread helped me fix it.
    I hereby want to give some more information to help anyone else who runs into this pretty annoying issue.

    My setup is a 2012 Mac mini, i7 2.3, 1TB hdd and I wanted to add a brand new Samsung 840 Evo 250GB ssd.

    Same issue as mentioned above... The ssd is always seen as MBR partitioned.
    When connected via usb, all is fine.

    I can confirm that simply swapping the internal disks was enough for osx to see that the ssd was gpt partitioned.
    Once swapped, I restored a TimeMachine backup via the recovery partition and it worked nicely.

    The good thing is that I can now disassemble and reassemble a Mac mini almost with my eyes closed ;-)
    (I have done that about 5 times yesterday :) ).

    Cheers,
    Charles
     

Share This Page